Just a question. Has anyone used the Samsung ML1450 Laser Printer with Red Hat 8 successfully? I tried both local and thru Samba while the printer was hooked up to my network, and neither way worked. With the local, I am supposed to run a script on the driver cd that replaces a 'printerdb' on the system with one on the cd, however, the db doesn't even exist on the system. The printer is compatible with Linux, but it appears that the scripts were written for Red Hat 6 or 7. I tried to set up the printer hoping, that Linux would support it out of the box, but when I used the printer setup tool, the printer wasn't even on the list. So, I tried using the PostScript driver, the Text only driver, and the Raw driver and all gave me the same results, both locally and through Samba.
This is verbatim what I see when I print a test page:

%!PS-Adobe-2.0
%%Title: testpage.fig
%%Creator:fig2dev Version 3.2.3 Patchlevel
%

The rest of the page prints blank, along with 5 more empty pages.
I am relatively new to the *nix scene, and I have no idea where to start. Any help would be greatly appreciated. Thanks.