Results 1 to 5 of 5

Thread: Another problem.

  1. #1

    Another problem.

    I tried to install another application. I opened the tarball glibc-linuxthreads-2.3.tar.gz and then cd'd into the directory 'glibc-linuxthreads-2.3'. I did ./configure, but when I did make I got two error messages,

    Makefile:53: ../Makeconfig: No such file or directory
    Makefile:77: ../Rules: No such file or directory

    I looked inside Makefile and found these two lines,

    include ../Makeconfig
    include ../Rules

    Now that means that make was looking for the files Makeconfig and Rules in the parent directory. I checked and found that there no such files there. There was a file Makeconfig in the current directory, i.e.'glibc-linuxthreads-2.3' but no Rules.

    1) Shouldn't they both be in the current directory?
    2) Makefile creates Makeconfig but what creates Rules?

    Since I was inside Makefile I adjusted 'include ../Makeconfig' to 'incude Makeconfig' and commented out the line 'include ../Rules'. Then the error message was,

    make: *** No rule to make target `crti.o', needed by `'. Stop.

    3) How can I get past this problem?


  2. #2

    Re:Another problem.

    Do you have the kernel sources installated? i can't find much on your issue. that is about the only thing that i could think of. Is there anything else that you could post that could help us?

  3. #3

    Re:Another problem.

    Hi. you said earlier that I should install gtk2-devel. Since the file I'm missing is gtk+-2.0.pc, then it shouldn't have been gtk+2-devel, should it? Anyway,

    I downloaded gtk2-devel-2.0.6-10.i386.rpm. It had dependencies,

    I downloaded pango-devel-1.1.1-1.i386.rpm. It had dependencies,

    I downloaded fontconfig-2.0.3-3.i386.rpm. It had dependencies,

    and is found in glibc-2.3.tar.gz. I downloaded and 'detarred' this and ran ./configure in the source directory and got this final message. (I'm not sure if the first two lines are relevant)

    running configure fragment for ./sysdeps/i386/elf
    running configure fragment for ./sysdeps/unix/sysv/linux
    checking installed Linux kernel header files... 2.0.10 or later
    *** On GNU/Linux systems it is normal to compile GNU libc with the
    *** `linuxthreads' add-on. Without that, the library will be
    *** incompatible with normal GNU/Linux systems.
    *** If you really mean to not use this add-on, run configure again
    *** using the extra parameter `--disable-sanity-checks'.

    Now I ran make and got these error messages,

    [root@localhost glibc-2.3]# make
    Makeconfig:84: sysdeps/../config.make: No such file or directory
    Makerules:694: no file name for `include'
    The GNU C library has not been configured.
    Run `configure' to configure it before building.
    Try `configure --help' for more details.
    make: *** [sysdeps/../config.status] Error 1

    So, I thought the final message from ./configure was some kind of error, so I thought I might get rid of it if I installed the linuxthreads thing. Besides it was on the same web page that I downloaded glibc-2.3.tar.gz.from.

    Well. that's how I got where I am.

    I'm not too sure what's meant by kernel sources. Isn't the kernel a base part of the operating system?

  4. #4

    Re:Another problem.

    Right now I am going through kinda the same thing.....I would highly suggest doing the rpm, installing glibc by source is a chore...and don't forget that you have to have glibc-common of the same version for it to ever work properly.
    If you give a man a fire he'll be warm, if you light the man on fire he'll be warm for life.

  5. #5

    Re:Another problem.

    yes, use the rpms for this. btw, what distro are you on, and other cool specs you'd want to give. i never got that info from you.


Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts