Results 1 to 10 of 10

Thread: Installing DevHelp

  1. #1
    Fermat
    Guest

    Installing DevHelp

    Can anyone help me with this error?
    I've been trying to install devhelp for Anjuta. I cd'd to the source directory
    and typed in ./configure. Lots of messages get printed to the screen then I get
    this error:

    Checking for pkg-config.
    Could not run GLIB program.
    GLIB may not be correctly installed.
    Package gtk+-2.0 not found.
    Perhaps you should add the directory containing `gtk+-2.0.pc'
    to the PKG_CONFIG_PATH environment variable.

    First, my PKG_CONFIG_PATH was empty. I don't have any file called
    'gtk+-2.0.pc', but I do have one called 'gtk+.pc' in 'usr/lib/pkgconfig/'. I set
    PKG_CONFIG_PATH="usr/lib/pkgconfig" and renamed 'gtk+.pc' to 'gtk+-2.0.pc', but
    it still gave the same error. I checked to see if I had the gtk+ package and
    found that "The package 'gtk+2.-2.0.6-8mdk' is installed".

    How can I get past this error?

  2. #2

    Re:Installing DevHelp

    see if this link helps you, another person had a similiar issue.

    http://www.getlinuxonline.com/yabbse...;threadid=1745

    Goodluck,

    Babbing

  3. #3
    Fermat
    Guest

    Re:Installing DevHelp

    Thanks for the link. doggiebone and I had a very similar problem - but with a
    difference. doggiebone's error message listed libgphoto2.pc and he had such a
    file. My error message lists gtk+-2.0.pc, but I had no such file. The nearest
    file to that I have is gtk+.pc, in /usr/lib/pkgconfig. As I mentioned in my
    original post, I set PKG_CONFIG_PATH="usr/lib/pkgconfig" and renamed 'gtk+.pc'
    to 'gtk+-2.0.pc', but it (./configure) still gave the same error. I set
    PKG_CONFIG_PATH manually at the command line. That shouldn't make any difference
    should it?

  4. #4

    Re:Installing DevHelp

    Do you have GLIB installed? Do you have gtk2.0 installed? sorry about the obvious questions, but there is a little hitch. this is from FM:

    GLib was previously distributed with the GTK toolkit, but has been split off as of the developers' version 1.1.0.



  5. #5
    Fermat
    Guest

    Re:Installing DevHelp

    I thought that I had glib installed, but it wsa glibc instead! glibc-devel-*****-mdk. I've downloaded the glib package, glib-1.2.10-8.src.rpm. Should I now install this? What options/switches should I use? Thanks.

  6. #6
    Fermat
    Guest

    Re:Installing DevHelp

    I managed to get glib installed - I was missing a few packages but I've got them installed now. But I'm back to my original problem. The configfure script is looking for a file called gtk+-2.0.pc and I only have one called gtk+.pc. (see my first post) Do I have to find and install sometrhing else now?

  7. #7

    Re:Installing DevHelp

    did you make sure to install gtk2-devel? that is where you would actualyl get the file from

  8. #8
    Fermat
    Guest

    Re:Installing DevHelp

    >> did you make sure to install gtk2-devel?

    Nope! I'm trying to do that now. I've found gtk2-devel on the net, but it has dependencies, pango and atk. And they have dependencies! Well it's the wee small hours just now, so I'm off to bed. I'll start again to-morrow.

  9. #9

    Re:Installing DevHelp

    cool, goodluck, maybe using the rpms would keep things simple for you

  10. #10

    Re:Installing DevHelp

    hmm, yeah
    you will need the -devel packages to install source programs
    whatdoyougetwhenyoumultiplysixbynine??

Similar Threads

  1. installing ftp
    By kwaslee in forum Suse
    Replies: 1
    Last Post: 02-27-2008, 09:53 AM
  2. Installing GCL on FC8
    By omidkamangar in forum Redhat / Fedora
    Replies: 1
    Last Post: 12-21-2007, 12:09 AM
  3. Installing
    By MicroTechXP in forum Windows - General Topics
    Replies: 7
    Last Post: 12-11-2006, 01:47 AM
  4. Need help installing app.
    By Dswissmiss in forum Linux - Software, Applications & Programming
    Replies: 1
    Last Post: 03-04-2003, 03:14 PM
  5. Installing with tar
    By papanohair in forum Linux - General Topics
    Replies: 11
    Last Post: 01-05-2002, 11:57 PM

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •