Warning: Function ereg() is deprecated in ..../includes/class_postbit.php(345) : eval()'d code on line 4

Warning: Function split() is deprecated in ..../includes/class_postbit.php(345) : eval()'d code on line 19

Warning: Function ereg() is deprecated in ..../includes/class_postbit.php(345) : eval()'d code on line 4

Warning: Function split() is deprecated in ..../includes/class_postbit.php(345) : eval()'d code on line 19

Warning: Function ereg() is deprecated in ..../includes/class_postbit.php(345) : eval()'d code on line 4

Warning: Function split() is deprecated in ..../includes/class_postbit.php(345) : eval()'d code on line 19

Warning: Function ereg() is deprecated in ..../includes/class_postbit.php(345) : eval()'d code on line 4

Warning: Function split() is deprecated in ..../includes/class_postbit.php(345) : eval()'d code on line 19
Never contented with one. Jphoto - Page 2
Page 2 of 2 FirstFirst 12
Results 11 to 14 of 14

Thread: Never contented with one. Jphoto

  1. #11
    doggiebone
    Guest

    Re:Never contented with one. Jphoto

    knoppix detects all drives including windows one. There is an article which tells you how make the drive writable both FAT32 and linux, however as usual NTFS it will become corrupt.

    Ok I've found something out by mistake by messing about commands.

    I put this command in my fstab for gphoto2

    usb /proc/bus/usb usbdevfs devmode=0666 0 0

    This command works great with gphoto2. However when my system boots it tells me that /proc is already mounted according to mtab. I did notice that /proc was already in the fstab. Is this anything to worry about ? My system works great so I can't complain. Alternativly do you have one of your great sites I can go to for more info?

  2. #12

    Re:Never contented with one. Jphoto

    knoppix detects all drives including windows one. There is an article which tells you how make the drive writable both FAT32 and linux, however as usual NTFS it will become corrupt.
    The linux community is still working on that

    I put this command in my fstab for gphoto2

    usb /proc/bus/usb usbdevfs devmode=0666 0 0

    This command works great with gphoto2. However when my system boots it tells me that /proc is already mounted according to mtab. I did notice that /proc was already in the fstab. Is this anything to worry about ? My system works great so I can't complain. Alternativly do you have one of your great sites I can go to for more info?
    i will get back to you on that. can you post me the output of:

    cat /etc/fstab

    and

    mount

    thanks

    Babbing

  3. #13
    doggiebone
    Guest

    Re:Never contented with one. Jphoto

    heres the output for cat /etc/fstab

    cat /etc/fstab
    LABEL=/ / ext3 defaults 1 1
    LABEL=/boot /boot ext3 defaults 1 2
    none /dev/pts devpts gid=5,mode=620 0 0
    none /proc proc defaults 0 0
    none /dev/shm tmpfs defaults 0 0
    /dev/hda5 swap swap defaults 0 0
    /dev/cdrom /mnt/cdrom iso9660 noauto,owner,kudzu,ro 0
    0
    /dev/fd0 /mnt/floppy auto noauto,owner,kudzu 0 0

    and here is my mtab

    /dev/hda3 / ext3 rw 0 0
    none /proc proc rw 0 0
    usbdevfs /proc/bus/usb usbdevfs rw 0 0
    /dev/hda2 /boot ext3 rw 0 0
    none /dev/pts devpts rw,gid=5,mode=620 0 0
    none /dev/shm tmpfs rw 0 0


    and here's mount

    rootfs / rootfs rw 0 0
    /dev/root / ext3 rw 0 0
    /proc /proc proc rw 0 0
    usbdevfs /proc/bus/usb usbdevfs rw 0 0
    /dev/hda2 /boot ext3 rw 0 0
    none /dev/pts devpts rw 0 0
    none /dev/shm tmpfs rw 0 0

  4. #14

    Re:Never contented with one. Jphoto

    i did find this, maybe this will help, and i took the liberty to patch in here the important part:

    Add the line

    none /proc/bus/usb usbdevfs defaults 0 0

    to /etc/fstab, if it isn't there already. To mount the filesystem, run

    # mount -a

    or re-boot your system.


    7.1. Set the permissions for the device files
    After you have mounted the usbdevfs like described before, you will notice, that you can't scan as a normal user, because the permissions are set to 0644 (owner root). This simply means, that only root has read and write access. You now have two possibilities to enable access for normal users:

    7.1.1 Mount the device filesystem with devmode=0666
    Add a line like this to /etc/fstab (instead of the line mentioned under 7.)

    none /proc/bus/usb usbdevfs defaults,devmode=0666 0 0

    Now all users are allowed to access all usb devices. Please note, that this won't work with all kernel versions, just try it. This method probably is acceptable for a single user system, but many people need a better control of access permissions.




    http://www.angelfire.com/linux/craps...tallation.html

    just look at the applicable sections, they should be similiar to what you want to do

    Goodluck

    Babbing

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •