Page 1 of 2 12 LastLast
Results 1 to 10 of 14

Thread: Never contented with one. Jphoto

  1. #1
    doggiebone
    Guest

    Never contented with one. Jphoto

    Hi guys

    I got digi kamera with gphoto2 works ok on desktop RH 8.0. I cannot get gphoto2 to work on my laptop so I've installed jphoto it detects my camera no problem. Permissions fine. When I type the jphoto tree I get this error

    [dread@kevin dread]$ jphoto capture
    PTP device at usb-dce0-1
    Device does not support InitiateCapture
    [dread@kevin dread]$ jphoto status
    PTP device at usb-dce0-1
    Manufacturer: Eastman Kodak Company
    Model: DX4330 Zoom Digital Camera
    Device Version: 01.00
    Serial Number: KCKAX30303796
    Extensions (Eastman Kodak Company): Eastman Kodak PTP Extensions
    Operations: 22
    Modes: Pull
    Object count: 20
    I/O exception: { response; len 12; StoreNotAvailable; xid 3 }

    The io error happens on jphoto images, thumbs, caputure. Does anyone have any ideas?

    regards doggiebone

  2. #2

    Re:Never contented with one. Jphoto

    you again eh? : 8) ;D ;D

    it looks to me like jphoto doesn't know how to deal with your camara. i can't find much on your errors, were there any others? btw, what happened with gphoto. Why didn't it install?

  3. #3
    doggiebone
    Guest

    Re:Never contented with one. Jphoto

    LOL I just can't keep away. I'm always dabbling with things ;D. I get this error and this is the response the developers have put on there site in the FAQ
    --------------------

    3.3.1.1. I just downloaded the libgphoto2-2.1.1 distribution off sourceforge and it builds "libgphoto2.so.2.0.3". Has anyone else reported this?

    Yes, many times. The release number ("2.1.1") and the library version ("2.0.3") are by their respective definitions completely unrelated. As we won't “fix” a problem which is not there, please stop bugging us with that “problem”.
    -----------------------

    I went back to the site and looked through some archived posting and I think its something to do the internal memory in my camera. i've been told to try the CVS but not got a clue what cvs is. I think jphoto looks for memory cards that are plugged in. I've been searching for the last two days but found nothing apart from going back to the archived site which is on sourceforge.



  4. #4

    Re:Never contented with one. Jphoto

    so what happened with gphoto? you've got skills there. also i wrote a little tid bit on cvs, maybe it will help.

    http://www.getlinuxonline.com/yabbse...;threadid=1243

  5. #5
    doggiebone
    Guest

    Re:Never contented with one. Jphoto

    I got gphoto2 working fine on my desktops in command line(But it don't work on my laptop). I''ll have to read up on CVS stuff. I've gotten Jphoto to work on my laptop but I just can't seem to down load the images from my camera to laptop.


    One thing users should bear in mind though, if you uninstall gphoto2 rpm and then install libgphoto2 and gphoto2 you will get an error regarding libgphoto2.so.2.0.3". If you re-install gphoto2 rpm after doing the source it works. The rpm holds onto this library and removes it when you unistall the rpm.

    So I'm trying to get jphoto to workwith my laptop. I've found a program called Knoppix and that works on my laptop but its read only. You can make your partition writable but its something I'll look at the end of the weekend. For now I will check out your CVS article. ;D

  6. #6

    Re:Never contented with one. Jphoto

    cool, well it isn't too big, but it does give you the jist of CVS, thats why it is a tidbit. i hope to be around more, i have just been too busy, and not near a computer often enough.

  7. #7
    doggiebone
    Guest

    Re:Never contented with one. Jphoto

    Hi Babbing

    I know that feeling. I've finally got jphoto to work on my laptop no problem, the issue as I said before was I needed an external memory card and it worked. I could download from my internal card as well as external card. i Believe it reads the external card first then the internal.

    Now I need to work on the permissions on gphoto2 as non root user. ;D

  8. #8

    Re:Never contented with one. Jphoto

    check this out then:

    http://www.getlinuxonline.com/yabbse...;threadid=1268

    that was a very helpful tidbit

    Goodluck,

    Babbing

  9. #9
    doggiebone
    Guest

    Re:Never contented with one. Jphoto

    Hi I checked out that article and found it very useful. I've decided to stick jphoto it works well and is not buggy. Gphoto2 is is prone to falling over and I'm sick of it. I'm gonna convert my desktops to jphoto ;D

    Even gtkam is unstable. However if I run knoppix it works from a readonlyl. Any thats my rant for the week. I've had a hell of a week at work.

    speak soon

  10. #10

    Re:Never contented with one. Jphoto

    About knoppix, don't you have to tell it that you have a harddrive? otherwise, i think everything is, one way or the other, readonly. maybe if you pass it an option upon boot, it will use the HD to store your pictures. then again, it could be that the harddrive is automagically detected. Anyways, see if you can tell it to use the harddrive.

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •