Page 1 of 2 12 LastLast
Results 1 to 10 of 12

Thread: correct path in gphoto2

  1. #1
    doggiebone
    Guest

    correct path in gphoto2

    Hi guys

    finally done it got me self the digi kamera ;D.


    Ok I installed libgphoto2-2.1.1 when I go to install gphoto2-2.1.1 after running the ./configure comand half way down I get this error.

    --------------------

    checking for pkg-config... /usr/bin/pkg-config
    checking for libgphoto2 >= 2.1.1... Package libgphoto2 was not found in the pkg-config search path.
    Perhaps you should add the directory containing `libgphoto2.pc'
    to the PKG_CONFIG_PATH environment variable
    No package 'libgphoto2' found

    configure: error: Library requirements (libgphoto2 >= 2.1.1) not met; consider adjusting the PKG_CONFIG_PATH environment variable if your libraries are in a nonstandard prefix so pkg-config can find them.
    -------------------------

    There is no pkgconfing in /usr/bin cos I've checked. I tried copying the pkgconfig but that did not work.

    Secondly what should be path be when I edit the pkgconfig/libphoto2.pc file. At this point I'm alittle stuck

    Any help appreciated

  2. #2

    Re:correct path in gphoto2

    maybe if you run /sbin/ldconfig before you try and compile gphoto
    what distro are you in, anyway?
    whatdoyougetwhenyoumultiplysixbynine??

  3. #3
    doggiebone
    Guest

    Re:correct path in gphoto2

    hi alastair

    There's documentation saying that you need to run sbin/idconfig. Was going use a storage medium only to find I ordered the wrong one so while I'm waiting thought I get gphoto2/gtkam to install.

    I'm using RH8.0 2.4.18 18.8.0 256mb , 20gbhdd

  4. #4

    Re:correct path in gphoto2

    redhat....
    use the rpms
    they will be _far_ easier to install
    whatdoyougetwhenyoumultiplysixbynine??

  5. #5
    doggiebone
    Guest

    Re:correct path in gphoto2

    Hi M8

    I have to use source cos the current rpm dont support my kodak dx430, if there was rpm I would use it. All I wanting to know is what should go in pkgcofig path. So I can continue compiling gphoto2/gtkam >

  6. #6

    Re:correct path in gphoto2

    i believe what it is asking is for you to link libgphoto2.pc to the directory of pkg-config. So find libgphoto2.pc and use the 'ln' command to link it to pkg-config's dir

  7. #7
    doggiebone
    Guest

    Re:correct path in gphoto2

    I'm not sure how to link it cos I dont know the command ;D in the /usrbin/pkgconfig/libgphoto2.pc resides. but the libgphoto2-2.1.1 resides in /usr/local/share/libgphoto2/2.1.1 Where does the link want to go? This has been bugging me for days. Babbings is there a site with commands that I could aqainte myself with?

  8. #8

    Re:correct path in gphoto2

    sorry all you have to do is add the dir of libgphoto2 to the PKG_CONFIG_PATH, no biggie, and i found a cool little thing to help you on your way. Have Fun!

    $./configure
    /* I received the error message above*/

    To fix this you need to setup an environment variable for PKG_CONFIG_PATH so that it is set to the directory where the file libgphoto2.pc is located. There may be multiple ways to do this with all the different distro's out there, some of which were setting environment variables in ~./bashrc or bash_conf. So here is what I did in bash with Slackware 9.0.0-beta on an A7A266/1.4ghz system.

    $echo $PKG_CONFIG_PATH

    /* if you had an error this will most likely output a blank line, or possibly something that you recently set it to */

    $cd /

    $find -R | grep libgphoto2.pc
    /* this outputs to your screen the directory info of all the libgphoto2.pc files in all subdirectories from / The directory you come up with may be different than what I came up with as shown below */

    $export PKG_CONFIG_PATH=/usr/local/lib/pkgconfig/
    /* this sets the environment variable for PKG_CONFIG_PATH */

    $echo $PKG_CONFIG_PATH
    /* the screen output of this should be what is after the = in the export command above, and now that you have the environment varialbe set you should be able to successfully install gphoto2-2.1.1.tar.gz and gtkam-0.1.10.tar.gz*/

    $cd gphoto2-2.1.1
    $./configure
    /* this should now configure without the error message */


    Goodluck,


    Babbing

  9. #9
    doggiebone
    Guest

    Re:correct path in gphoto2

    hi babbing

    here's whats in my ./bashrc /home/dread

    # .bashrc

    # User specific aliases and functions
    export PKG_CONFIG_PATH=/usr/local/lib/pkgconfig/

    # Source global definitions
    if [ -f /etc/bashrc ]; then
    . /etc/bashrc
    fi
    --------------------------------

    in my /user/bin/pkgconfig

    prefix=/usr/local
    exec_prefix=${prefix}
    libdir=${exec_prefix}/lib
    includedir=${prefix}/include
    export PKG_CONFIG_PATH=/usr/local/lib/pkgconfig/ <--- I had to add this it wans't there

    Name: libgphoto2
    Description: Library for easy access to digital cameras
    Requires:
    Version: 2.0
    Libs: -L${libdir} -lgphoto2 -lm
    Cflags: -I${includedir}/gphoto2 -I${includedir}
    ------------------------------------------------------

    When I run ./configure for gtkam I get this

    [root@open gtkam-0.1.10]# ./configure
    checking for a BSD-compatible install... /usr/bin/install -c
    checking whether build environment is sane... yes
    checking for gawk... gawk
    checking whether make sets ${MAKE}... yes
    checking whether to enable maintainer-specific portions of Makefiles... no
    checking for style of include used by make... GNU
    checking for gcc... gcc
    checking for C compiler default output... a.out
    checking whether the C compiler works... yes
    checking whether we are cross compiling... no
    checking for suffix of executables...
    checking for suffix of object files... o
    checking whether we are using the GNU C compiler... yes
    checking whether gcc accepts -g... yes
    checking dependency style of gcc... gcc3
    checking for strerror in -lcposix... no
    checking for gcc... (cached) gcc
    checking whether we are using the GNU C compiler... (cached) yes
    checking whether gcc accepts -g... (cached) yes
    checking dependency style of gcc... (cached) gcc3
    checking for gcc option to accept ANSI C... none needed
    checking how to run the C preprocessor... gcc -E
    checking for ANSI C header files... yes
    checking for msgfmt... no
    checking for gmsgfmt... :
    checking for xgettext... no
    checking for msgmerge... no
    checking build system type... i686-pc-linux-gnu
    checking host system type... i686-pc-linux-gnu
    checking for ranlib... ranlib
    checking for gcc option to accept ANSI C... none needed
    checking for an ANSI C-conforming const... yes
    checking for inline... inline
    checking for sys/types.h... yes
    checking for sys/stat.h... yes
    checking for stdlib.h... yes
    checking for string.h... yes
    checking for memory.h... yes
    checking for strings.h... yes
    checking for inttypes.h... yes
    checking for stdint.h... yes
    checking for unistd.h... yes
    checking for off_t... yes
    checking for size_t... yes
    checking for working alloca.h... yes
    checking for alloca... yes
    checking for stdlib.h... (cached) yes
    checking for unistd.h... (cached) yes
    checking for getpagesize... yes
    checking for working mmap... yes
    checking whether we are using the GNU C Library 2.1 or newer... yes
    checking whether integer division by zero raises SIGFPE... yes
    checking for inttypes.h... yes
    checking for stdint.h... yes
    checking for unsigned long long... yes
    checking for inttypes.h... yes
    checking whether the inttypes.h PRIxNN macros are broken... no
    checking for ld used by GCC... /usr/bin/ld
    checking if the linker (/usr/bin/ld) is GNU ld... yes
    checking for shared library run path origin... done
    checking argz.h usability... yes
    checking argz.h presence... yes
    checking for argz.h... yes
    checking limits.h usability... yes
    checking limits.h presence... yes
    checking for limits.h... yes
    checking locale.h usability... yes
    checking locale.h presence... yes
    checking for locale.h... yes
    checking nl_types.h usability... yes
    checking nl_types.h presence... yes
    checking for nl_types.h... yes
    checking malloc.h usability... yes
    checking malloc.h presence... yes
    checking for malloc.h... yes
    checking stddef.h usability... yes
    checking stddef.h presence... yes
    checking for stddef.h... yes
    checking for stdlib.h... (cached) yes
    checking for string.h... (cached) yes
    checking for unistd.h... (cached) yes
    checking sys/param.h usability... yes
    checking sys/param.h presence... yes
    checking for sys/param.h... yes
    checking for feof_unlocked... yes
    checking for fgets_unlocked... yes
    checking for getc_unlocked... yes
    checking for getcwd... yes
    checking for getegid... yes
    checking for geteuid... yes
    checking for getgid... yes
    checking for getuid... yes
    checking for mempcpy... yes
    checking for munmap... yes
    checking for putenv... yes
    checking for setenv... yes
    checking for setlocale... yes
    checking for stpcpy... yes
    checking for strcasecmp... yes
    checking for strdup... yes
    checking for strtoul... yes
    checking for tsearch... yes
    checking for __argz_count... yes
    checking for __argz_stringify... yes
    checking for __argz_next... yes
    checking for iconv... yes
    checking for iconv declaration...
    extern size_t iconv (iconv_t cd, char * *inbuf, size_t *inbytesleft, char * *outbuf, size_t *outbytesleft);
    checking for nl_langinfo and CODESET... yes
    checking for LC_MESSAGES... yes
    checking for bison... bison
    checking version of bison... 1.35, ok
    checking whether NLS is requested... yes
    checking whether included gettext is requested... no
    checking for GNU gettext in libc... yes
    checking for pkg-config... /usr/bin/pkg-config
    checking for gtk+-2.0 libgphoto2 >= 2.1.1... Requested 'libgphoto2 >= 2.1.1' but version of libgphoto2 is 2.0

    configure: error: Library requirements (gtk+-2.0 libgphoto2 >= 2.1.1) not met; consider adjusting the PKG_CONFIG_PATH environment variable if your libraries are in a nonstandard prefix so pkg-config can find them.
    ---------

    at this point I'm banging my head alitlle thanks for your help. I gonna go for a drive and come back to it. later >

  10. #10

    Re:correct path in gphoto2

    n my /user/bin/pkgconfig

    prefix=/usr/local
    exec_prefix=${prefix}
    libdir=${exec_prefix}/lib
    includedir=${prefix}/include
    export PKG_CONFIG_PATH=/usr/local/lib/pkgconfig/
    earlier you told us that libgphoto2 was at /usr/local/share/libgphoto2/2.1.1

    extract your head from monitor, apply ice, and reconfigure ;D ;D ;D ;D ;D

Similar Threads

  1. Correct configuration of /etc/hosts
    By R.Bucky in forum Linux - Hardware, Networking & Security
    Replies: 1
    Last Post: 05-12-2009, 07:12 PM
  2. gphoto2 config
    By doggiebone in forum Redhat / Fedora
    Replies: 3
    Last Post: 12-17-2002, 12:52 AM
  3. Path
    By mugs in forum Linux - General Topics
    Replies: 8
    Last Post: 11-24-2002, 08:35 PM
  4. Add to PATH
    By trickster in forum Linux - Software, Applications & Programming
    Replies: 2
    Last Post: 09-28-2002, 10:26 PM
  5. Path question
    By PatC in forum Redhat / Fedora
    Replies: 3
    Last Post: 07-10-2002, 11:14 PM

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •