Results 1 to 5 of 5

Thread: couple of newbie anomalies !?!?

  1. #1
    muppet-boy
    Guest

    couple of newbie anomalies !?!?

    hi

    i've just reinstalled mandrake 8.2 prosuite ed. and come across the following..

    1.real handy tool 'locate' isnt installed and i've no idea how i'd go about doing that.. is it an rpm? or...

    2.i've been trying to get all my file permissions sorted under a normal user so that i can get reasonable access without having to login as superuser every 5 mins.. however.. i've just used chmod on /var/www/html so i can create some files there,
    - problem - kde says i dont have permission to create files, but if i go to the command line and login as the same user, i have no problems ??? i have no idea whats going on

    any help with my 2 problems would be great! i'm not the best at writing what i mean.. so if it doesnt make sense.. just complain and i'll have another go

    thanks

    nev

  2. #2

    Re:couple of newbie anomalies !?!?

    Hello muppet-boy,

    I'm not an rpm wiz, but look on your Mandrake CD's for locate, also it may be included with some other package that you may not have choosen to install. If you do find it then something like rpm -Uvh packagename.rpm will install it.

    Now for a complete listing of what rpm does see JimH ;D

    As for the permissions. Once you create a user, most things should already be setup to allow that user to have control over installed applications. However if they user wanted to install an application then it would have to be in that users home directory. For installing applications anywhere else, that's root's job. If you wanted to edit system wide files, that's root's job as well. It's all about security.

    If you wanted to let user X play with /var/www/html then that dir would need to be owned by that user, as well as the files within. Or you could add that user to the group that owns the files. Then you would need the permissions to look something like this: rw-rw---. It would have to be that way for the directory as well as the files. Another way would be to all other to access the files. In which case nothing needs to be done about adding groups etc. Only need to modify permissions to allow other to access the files. That would like like this: rw-rw-rw-. This later method though is pretty much like saying everyone, and their gandmother need to come play with my files.
    AMD Athlon 2200+ 1.8Ghz
    1280MB PC-3200 CAS2.5 RAM
    ATI Radeon 9600 Pro 128MB AGP
    Western Digital WDC WD2500JB-00FUA0 250GB 7200 rpm ATA/133
    Seagate ST3200822A 200GB 7200 rpm ATA/133
    Western Digital WDC WD1200BB-00CAA1 120GB 7200 rpm ATA/133
    Western Digital WDC WD800BB-00CAA1 80GB 7200 rpm ATA/133
    Maxtor OneTouch 2HA43R32 1TB 7200 rpm USB 2.0
    D-Link DFE-530TX+ 10/100 NIC
    D-Link DWL-G520 Rev.A
    Debian 5.0r1 Lenny

  3. #3
    muppet-boy
    Guest

    Re:couple of newbie anomalies !?!?

    Quote Originally Posted by SkyNet
    Or you could add that user to the group that owns the files. Then you would need the permissions to look something like this: rw-rw---. It would have to be that way for the directory as well as the files.
    thanx for the reply. i found locate - its actually called slocate

    i added my user to the apache group to give r/w to /var/www/html which worked fine... at the command line.. but not in the kde gui > which is where i came unstuck - coz i thought they should all obey the same rules.


  4. #4

    Re:couple of newbie anomalies !?!?

    this is another possibitily for the web thing:
    use user directorys.
    in /etc/httpd/conf/httpd.conf...

    <IfModule mod_userdir.c>
    #UserDir disable
    UserDir public_html
    </IfModule>
    you want this section to look something like this... mine is an apache 2.0 config file, so it might looks slightly different.

    under it, this should be commented out... uncomment it. (remove the #'s)
    <Directory /home/*/public_html>
    AllowOverride FileInfo AuthConfig Limit
    Options MultiViews Indexes SymLinksIfOwnerMatch IncludesNoExec
    <Limit GET POST OPTIONS>
    Order allow,deny
    Allow from all
    </Limit>
    <LimitExcept GET POST OPTIONS>
    Order deny,allow
    Deny from all
    </LimitExcept>
    </Directory>

    at a terminal.
    $cd /home
    $chmod 711 <user>
    $cd <user>
    $mkdir public_html
    $chmod 755 public_html

    now put in an index.html file there and go
    $chmod a+r index.html
    --all files in here need to be world readable, that is something like -rw-rw-r--

    restart apache
    $su
    <password>
    #/sbin/service httpd restart

    now going to http://localhost/~<user>/ should load up the page

    Have fun!
    whatdoyougetwhenyoumultiplysixbynine??

  5. #5

    Re:couple of newbie anomalies !?!?

    Yes, KDE's gui should obey the permissions as well. Perhaps it just needed to be restarted?
    AMD Athlon 2200+ 1.8Ghz
    1280MB PC-3200 CAS2.5 RAM
    ATI Radeon 9600 Pro 128MB AGP
    Western Digital WDC WD2500JB-00FUA0 250GB 7200 rpm ATA/133
    Seagate ST3200822A 200GB 7200 rpm ATA/133
    Western Digital WDC WD1200BB-00CAA1 120GB 7200 rpm ATA/133
    Western Digital WDC WD800BB-00CAA1 80GB 7200 rpm ATA/133
    Maxtor OneTouch 2HA43R32 1TB 7200 rpm USB 2.0
    D-Link DFE-530TX+ 10/100 NIC
    D-Link DWL-G520 Rev.A
    Debian 5.0r1 Lenny

Similar Threads

  1. Couple of cli questions.
    By gmoreno in forum Linux - General Topics
    Replies: 3
    Last Post: 05-20-2003, 08:14 PM
  2. Couple of questions
    By gmoreno in forum Linux - Software, Applications & Programming
    Replies: 5
    Last Post: 05-01-2003, 03:01 AM
  3. Couple Parts - FT
    By gmoreno in forum General Chat
    Replies: 4
    Last Post: 02-20-2002, 10:15 PM
  4. a couple of questions
    By possumpuss in forum Linux - General Topics
    Replies: 9
    Last Post: 12-26-2001, 02:28 PM
  5. I need a couple of things
    By paradox in forum Linux - Software, Applications & Programming
    Replies: 7
    Last Post: 12-16-2001, 12:35 AM

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •