Results 1 to 9 of 9

Thread: Midi

  1. #1
    mugs
    Guest

    Midi

    My Midi isnt configured. In the KDE Control Center, under Midi, there are no devices listed. Can anyone point me in the direction to get started? thanks.

    For example, I cant get any of those virtual keyboards to work, and when I start Kmid, it crashes with signal 11. This is the backtrace:

    (no debugging symbols found)...(no debugging symbols found)...
    (no debugging symbols found)...(no debugging symbols found)...
    (no debugging symbols found)...(no debugging symbols found)...
    (no debugging symbols found)...(no debugging symbols found)...
    (no debugging symbols found)...(no debugging symbols found)...
    (no debugging symbols found)...(no debugging symbols found)...
    (no debugging symbols found)...(no debugging symbols found)...
    (no debugging symbols found)...(no debugging symbols found)...
    (no debugging symbols found)...(no debugging symbols found)...[New Thread 1024 (LWP 2515)]

    (no debugging symbols found)...(no debugging symbols found)...
    (no debugging symbols found)...(no debugging symbols found)...
    (no debugging symbols found)...(no debugging symbols found)...
    (no debugging symbols found)...(no debugging symbols found)...
    (no debugging symbols found)...(no debugging symbols found)...
    (no debugging symbols found)...(no debugging symbols found)...
    0x4106f099 in wait4 () from /lib/libc.so.6
    #0 0x4106f099 in wait4 () from /lib/libc.so.6
    #1 0x410e9bd8 in __DTOR_END__ () from /lib/libc.so.6
    #2 0x40f05072 in waitpid () from /lib/libpthread.so.0
    #3 0x407030de in KCrash::defaultCrashHandler ()
    from /opt/kde3/lib/libkdecore.so.4
    #4 0x40f02a74 in pthread_sighandler () from /lib/libpthread.so.0
    #5 <signal handler called>
    #6 0x4005dbbe in MidiOut::setMidiMapper () from /opt/kde3/lib/libkmid.so.0
    #7 0x40064c4b in DeviceManager::setMidiMap () from /opt/kde3/lib/libkmid.so.0
    #8 0x4003b2f6 in kmidClient::setMidiMapFilename ()
    from /opt/kde3/lib/libkmidpart.so.1
    #9 0x40038a6d in kmidClient::kmidClient () from /opt/kde3/lib/libkmidpart.so.1
    #10 0x40033723 in kmidFrame::kmidFrame () from /opt/kde3/lib/libkmidpart.so.1
    #11 0x08048af1 in __register_frame_info ()
    #12 0x40fe49ed in __libc_start_main () from /lib/libc.so.6

    A program called KMidi plays, but gives some messages that certain components cant be found



  2. #2

    Re:Midi

    by 'midi' what do you mean?
    you have a keyboard that you want to plug up, you want to fiddle with a virtuakl keyboard, or you want to play .mid/.midi files??
    whatdoyougetwhenyoumultiplysixbynine??

  3. #3
    mugs
    Guest

    Re:Midi

    It would be the last 2.

  4. #4

    Re:Midi

    no devices will be listed under midi because thats for option 1
    im not sure if kmid needs them or something? what does the handbook/homepage say?

    are there 2 apps... Kmid and Kmidi? or was it just a typo
    Kmid seems to be a player, Kmidi is... also a player... :P :P a bit of clarity might help there
    whatdoyougetwhenyoumultiplysixbynine??

  5. #5
    JimH
    Guest

    Re:Midi

    What sound card?

  6. #6
    mugs
    Guest

    Re:Midi

    I would like to revisit this, please. I now run Mandrake 9.0 as opposed to Suse 8.0.

    I can open a .mid file and run KMid, it doesnt crash. But, there is no sound. It looks like is is playing, but no sound.

    I have a Turtle Beach Santa Cruz sound card.

    Thanks.

  7. #7
    mugs
    Guest

    Re:Midi

    Well, it does work if I use KMIDI, although it says it cant load a couple of things. so, I guess midis do work...thanks.

  8. #8

    Re:Midi

    Do you have issues hear other media formats?

  9. #9
    mugs
    Guest

    Re:Midi

    No, I can hear other formats, althouth I am not so happy with the sound quality. Someone suggested that it is because my sound card is sharing an IRQ, but I dont know.

Similar Threads

  1. How to convert from MIDI??
    By in forum General Chat
    Replies: 10
    Last Post: 07-06-2003, 09:48 AM
  2. Audio(mp3/wav) --> MIdi
    By gmoreno in forum Linux - General Topics
    Replies: 4
    Last Post: 11-01-2002, 09:01 PM

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •