Help me people!

I just got a new computer and have got it to dual boot with windows 2000 and Redhat 8.0. The thing is I am not able to get the sound card to work. I have tried to install the sound drivers and also the alsa package but still does not work.

here is the details.

machine specs-
System Mainboard
Manufacturer : ECS
MP Support : No
Model : M925
Version : 1.0
Serial Number : 00000000
BIOS ID : 62-0627-001131-00101111-040201-VIA

System Chipset
Model : VIA Technologies Inc VT8751 ProSavageDDR P4M266 System Controller
Bus(es) : ISA AGP PCI USB SMBus/i2c
Front Side Bus Speed : 4x 100MHz (400MHz data rate)
Max FSB Speed / Max Memory Speed : 4x 100MHz / 1x 133MHz
In Order Queue Depth : 8 req(s)

Onboard Sound card is
VIA VT8233

on installation redhat detects that that the machine has a sound card VIA AC'97 Codec, but sound does not play. I mean I cannot hear any thing.

When I run sndconfig it correctly probes the card but then says that there are some errors in files that are laocted in

I am not able to install the drivers on VIA website because the kernal versions do not match

Then I tired installing ALSA. I followed the steps given for the VIA systems. Once I finish going thru the steps and when I run alsamixer I get an error.

Listed below is the various errors I get -

alsamixer: function snd_ctl_open failed for default: No such file or directory

aumix: error opening mixer

During shutdown it gives an error for the mixer. and shows failed.

uname -a
Linux localhost.localdomain 2.4.18-14 #1 Wed Sep 4 13:35:50 EDT 2002 i686 i686 i386 GNU/Linux

Module Size Used by Not tainted
nls_cp437 5116 1 (autoclean)
vfat 13084 1 (autoclean)
fat 38712 0 (autoclean) [vfat]
snd-seq-oss 33920 0 (unused)
snd-seq-midi-event 5640 0 [snd-seq-oss]
snd-seq 47472 2 [snd-seq-oss snd-seq-midi-event]
snd-pcm-oss 44452 0 (unused)
snd-mixer-oss 15512 0 [snd-pcm-oss]
snd-via82xx 11660 0 (unused)
snd-pcm 83328 0 [snd-pcm-oss snd-via82xx]
snd-timer 15304 0 [snd-seq snd-pcm]
snd-mpu401-uart 4796 0 [snd-via82xx]
snd-rawmidi 18400 0 [snd-mpu401-uart]
snd-seq-device 6176 0 [snd-seq-oss snd-seq snd-rawmidi]
snd-ac97-codec 36100 0 [snd-via82xx]
snd 39404 0 [snd-seq-oss snd-seq-midi-event snd-seq snd-pcm-oss snd-mixer-oss snd-via82xx snd-pcm snd-timer snd-mpu401-uart snd-rawmidi snd-seq-device snd-ac97-codec]
nls_iso8859-1 3516 2 (autoclean)
sr_mod 18136 2 (autoclean)
soundcore 6532 2 (autoclean) [snd]
mousedev 5524 1 (autoclean)
input 5888 0 (autoclean) [mousedev]
autofs 13348 0 (autoclean) (unused)
via-rhine 15628 0
mii 2156 0 [via-rhine]
ipt_REJECT 3736 6 (autoclean)
iptable_filter 2412 1 (autoclean)
ip_tables 14936 2 [ipt_REJECT iptable_filter]
ide-scsi 10512 1
scsi_mod 107176 2 [sr_mod ide-scsi]
ide-cd 33608 0
cdrom 33696 0 [sr_mod ide-cd]
ext3 70368 2
jbd 52212 2 [ext3]

I hope someone can help me to get my sound on my machine to sound.

waiting for help.