Warning: Function ereg() is deprecated in ..../includes/class_postbit.php(345) : eval()'d code on line 4

Warning: Function split() is deprecated in ..../includes/class_postbit.php(345) : eval()'d code on line 19

Warning: Function ereg() is deprecated in ..../includes/class_postbit.php(345) : eval()'d code on line 4

Warning: Function split() is deprecated in ..../includes/class_postbit.php(345) : eval()'d code on line 19

Warning: Function ereg() is deprecated in ..../includes/class_postbit.php(345) : eval()'d code on line 4

Warning: Function split() is deprecated in ..../includes/class_postbit.php(345) : eval()'d code on line 19

Warning: Function ereg() is deprecated in ..../includes/class_postbit.php(345) : eval()'d code on line 4

Warning: Function split() is deprecated in ..../includes/class_postbit.php(345) : eval()'d code on line 19

Warning: Function ereg() is deprecated in ..../includes/class_postbit.php(345) : eval()'d code on line 4

Warning: Function split() is deprecated in ..../includes/class_postbit.php(345) : eval()'d code on line 19

Warning: Function ereg() is deprecated in ..../includes/class_postbit.php(345) : eval()'d code on line 4

Warning: Function split() is deprecated in ..../includes/class_postbit.php(345) : eval()'d code on line 19

Warning: Function ereg() is deprecated in ..../includes/class_postbit.php(345) : eval()'d code on line 4

Warning: Function split() is deprecated in ..../includes/class_postbit.php(345) : eval()'d code on line 19

Warning: Function ereg() is deprecated in ..../includes/class_postbit.php(345) : eval()'d code on line 4

Warning: Function split() is deprecated in ..../includes/class_postbit.php(345) : eval()'d code on line 19
Install tar files - Page 3
Page 3 of 3 FirstFirst 123
Results 21 to 28 of 28

Thread: Install tar files

  1. #21
    JimH
    Guest

    Re:Install tar files

    The problem is that Gkrellm does not use configure. Other programs that use configure will probably find pkg-config's location, but Gkrellm expects it to be in /usr not /usr/local.

    Either reinstall pkg-config to /usr or try creating a couple symlinks.

    ln -s /usr/local/bin/pkg-config /usr/bin/pkg-config

    and you will have to link the directory with the *.pc files. More then likely they will be in /usr/local/lib/pkgconfig

    ln -s /usr/local/lib/pkgconfig /usr/lib/pkgconfig


  2. #22
    mugs
    Guest

    Re:Install tar files

    Still no success:

    linux:/home/mugs/Desktop/gk # cd gkrellm-2.1.4
    linux:/home/mugs/Desktop/gk/gkrellm-2.1.4 # make
    (cd po && make all)
    make[1]: Entering directory `/home/mugs/Desktop/gk/gkrellm-2.1.4/po'
    make[1]: Nothing to be done for `all'.
    make[1]: Leaving directory `/home/mugs/Desktop/gk/gkrellm-2.1.4/po'
    (cd src && make gkrellm)
    make[1]: Entering directory `/home/mugs/Desktop/gk/gkrellm-2.1.4/src'
    cc -Wall -O2 -I.. `pkg-config --cflags gtk+-2.0 gthread-2.0` -DENABLE_NLS -DLOCALEDIR=\"/usr/share/locale\" -c -o main.o main.c
    Package gtk+-2.0 was not found in the pkg-config search path.
    Perhaps you should add the directory containing `gtk+-2.0.pc'
    to the PKG_CONFIG_PATH environment variable
    No package 'gtk+-2.0' found
    In file included from main.c:22:
    gkrellm.h:30: gtk/gtk.h: No such file or directory
    In file included from main.c:24:
    gkrellm-sysdeps.h:62: parse error
    make[1]: *** [main.o] Error 1
    make[1]: Leaving directory `/home/mugs/Desktop/gk/gkrellm-2.1.4/src'
    make: *** [all] Error 2


    I do not want to go back to Windows, because I really beleive in Linux, but this past week, I really cant accompish these few things I am trying to do:

    Install Gkrellm
    Fix the fonts in Mozilla
    Get Midi to work
    prevent the mozilla lock file from reappearing
    get Xchat, etc to work correctly

    I know I have a lot to learn, and I really dont have enough time to do it as fast as I want, but it has been way too frustrating. How can I convince my wife to use Linux if she sees me constantly struggling. :P ??? >

  3. #23
    JimH
    Guest

    Re:Install tar files

    Well at least it finds pkg-config now.

    What does this show. Do an update to the locate db first.

    updatedb

    locate gtk+-2.0.pc


  4. #24
    mugs
    Guest

    Re:Install tar files

    I tried updatedb, but it says permission denied, so I tried it as su and as root, and nothing happens....

  5. #25
    JimH
    Guest

    Re:Install tar files

    Why do you think nothing happens? Is gtk+-2.0.pc on your system?

  6. #26
    mugs
    Guest

    Re:Install tar files

    Apparently not. I looked out there for the file, but wasnt sure which one to get. Can you point me? ;D
    Thanks.

  7. #27
    JimH
    Guest

    Re:Install tar files

    gtk+-2.0.pc will be in the gtk2-devel package. You probably don't have it installed.

  8. #28
    mugs
    Guest

    Re:Install tar files

    I downloaded it, gtk-devel, but it has 4 or 5 dependenices I need, and then each one has 4 or 5 more..... :P

    Is the only way to do it to go one by one and get them? >

    Well, this just gets more and more frustrating one of my 2nd level dependcies says I need atk 1.0.0. , when I try to install it it says atk 1.0.3 is already installed...so why does atk-devel say I still need atk 1.0.0?

    All this just for gkrellm. Starting to not be worth it. This isnt even that important in the scheme of things. More important is sound, fonts, etc. But, this has become a challenge. Why is it so hard? :P

Similar Threads

  1. log files
    By flandercan in forum Redhat / Fedora
    Replies: 8
    Last Post: 03-27-2003, 11:16 PM
  2. Redhat 8.0: Should I install only rpms or tar files or both?
    By JockVSJock in forum Linux - General Topics
    Replies: 5
    Last Post: 02-10-2003, 04:57 PM
  3. zip files
    By friskydrifter in forum Linux - Software, Applications & Programming
    Replies: 4
    Last Post: 11-24-2002, 09:20 PM
  4. .wma files
    By trickster in forum Linux - Software, Applications & Programming
    Replies: 3
    Last Post: 09-22-2002, 01:27 AM
  5. Re-Install LILO after W2K Install
    By Pleiades in forum Linux - General Topics
    Replies: 12
    Last Post: 08-18-2002, 04:58 PM

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •