Results 1 to 7 of 7

Thread: I think I messed up :)

  1. #1

    I think I messed up :)

    The other day when I was installing something I got a message saying the disk was out of space, I cleaned up some stuff in tmp dir but didn't really trust the message (cause I have fairly amount of disk space).

    However I tried the df command today and found out I had only some 50mb of free space in my / partition .... that made me wonder cause I haven't really installed so many apps since I installed slackware 8.1.

    Then I realized that I forgot to put my /opt on a separate partition (something I always do, but somehow forgot when messing around with different setups)

    Anyway, I mounted another partion on another disk into /opt (using fstab)
    and moved the stuff over and rebooted ... everything semed to be fine, I fired up KDE and everything was running .. however when I tried to open up a "konsole" I got an error ... (I rebooted and tried again .. same error)
    thats when I realized I had screwed up somehow.. this is what the backtrace gives me.:

    [New Thread 1024 (LWP 667)]
    0x40e06239 in __wait4 () at __wait4:-1
    in __wait4
    #0 0x40e06239 in __wait4 () at __wait4:-1
    #1 0x40e80e58 in __DTOR_END__ () from /lib/
    #2 0x40cca7b2 in waitpid (pid=669, stat_loc=0x0, options=0)
    at wrapsyscall.c:173
    #3 0x405687ec in KCrash::defaultCrashHandler ()
    from /opt/kde/lib/
    #4 0x40cc8144 in pthread_sighandler (signo=11, ctx=
    {gs = 0, __gsh = 0, fs = 0, __fsh = 0, es = 43, __esh = 0, ds = 43, __dsh = 49168, edi = 1090802265, esi = 135229264, ebp = 3221220720, esp = 3221220672, ebx = 1085848860, edx = 0, ecx = 1088940545, eax = 0, trapno = 14, err = 4, eip = 1082055223, cs = 35, __csh = 0, eflags = 66195, esp_at_signal = 3221220672, ss = 43, __ssh = 0, fpstate = 0xbfffeac0, oldmask = 2147483648, cr2 = 36})
    at signals.c:97
    #5 <signal handler called>
    #6 0x407eda37 in QObject::inherits () from /usr/lib/qt/lib/
    #7 0x410346fa in Konsole::makeGUI () from /opt/kde/lib/
    #8 0x4103c193 in Konsole::activateSession () from /opt/kde/lib/
    #9 0x4103bdd7 in Konsole::activateSession () from /opt/kde/lib/
    #10 0x4103b782 in Konsole::runSession () from /opt/kde/lib/
    #11 0x4103d4ae in Konsole::newSession () from /opt/kde/lib/
    #12 0x41034048 in Konsole::Konsole () from /opt/kde/lib/
    #13 0x4103292f in main () from /opt/kde/lib/
    #14 0x0804cf87 in launch ()
    #15 0x0804dd0a in handle_launcher_request ()
    #16 0x0804e225 in handle_requests ()
    #17 0x0804f107 in main ()
    #18 0x40d7c17d in __libc_start_main (main=0x804eb08 <main>, argc=3,
    ubp_av=0xbffff844, init=0x804aa5c <_init>, fini=0x804fc40 <_fini>,
    rtld_fini=0x4000a534 <_dl_fini>, stack_end=0xbffff83c)
    at ../sysdeps/generic/libc-start.c:129

    I do not have a clue to what I have done wrong, or how to solve this .. so I'm hopin you guys can save me..

    Also I can not understand why my / partition is so loaded ... this is a df -h
    output ...

    Filesystem Size Used Avail Use% Mounted on
    /dev/hda1 5.0G 3.9G 830M 83% /
    /dev/hda5 16G 2.1G 13G 14% /usr
    /dev/hda7 85G 14G 67G 17% /home
    /dev/hdb1 20G 1.5G 17G 8% /opt
    /dev/hdb5 45G 3.8G 38G 9% /mnt/hdb5
    /dev/hdb6 46G 64k 45G 1% /mnt/hdb6

    I've been looking around to see where all that space has gone .. but no luck so far ... something strange here .. hehehe .. or maybe I don't see the trees cause of the forrest that lies before my eyes ..

    anyway, any help is greatly appreciated

    //KenHan ;D

  2. #2

    Re:I think I messed up :)

    You obviously moved something you were not supposed too....

    Try running, as root: ldconfig

    See if that cures the problem. Although you might want to look at /etc/

    You probably moved a shared library. Although if the library path is hard coded in the app ldconfig will not help.

  3. #3

    Re:I think I messed up :)

    In a little experince playing around with fstab and partitons I noticed somthing. When you only change the fstab you dont transfer files in the dir.

    So check your /opt folder ill bet you its blank

    to fix it use fs tab and mount it to /mnt/opt (don't forget to make the directory)
    Then run #cp -r /opt /tmp/opt
    Then try refixing the fstab and it should work

    Hope it helps ;D

  4. #4

    Re:I think I messed up :)

    Quote Originally Posted by KenHan
    Anyway, I mounted another partion on another disk into /opt (using fstab)
    and moved the stuff over and rebooted
    I assume you didn't move everything in /? Did you?

  5. #5

    Re:I think I messed up :)

    before I rebooted I moved everything from my "old" (opt to the new partition that I intended to mount as /opt (moved it using MC) and then I edited fstab to make /opt point to the new partition and then rebooted ..

    so everthing is there alright .. thats why I do not understand ..




  6. #6

    Re:I think I messed up :)

    I finally tried to log into gnome and that worked fine, so I decided to try to reinstall kde 3.05 and that solved the problem.

    strange .. hehehe ...

    can I trust midnight commander not to mess up file attrib/rights etc when moving/copying stuff around between partitions ?

    you guys think that is what happened ? or is it just another of them computer mysteries .... ??

    well most likely it was my fault somehow

    thanks for helping me !!

    (still don't know though what happened to all my diskspace on my / partition ... maybe I need to call agent scully from archive X ... you guys think???)


  7. #7

    Re:I think I messed up :)

    It could have been a permission issue. Unless you specifically say to perserve permissions they can change while moving/copying files.

    Look at the man page for cp.

    cp -a

Similar Threads

  1. Messed up documents. HELP!
    By relyanddefy in forum Windows - General Topics
    Replies: 0
    Last Post: 06-07-2006, 06:02 PM
  2. Russian characters all get messed up
    By AljoshaNL in forum Linux - Software, Applications & Programming
    Replies: 4
    Last Post: 01-14-2006, 08:18 AM
  3. Messed Folders, Can someone Help?
    By Raikesy in forum Windows - General Topics
    Replies: 5
    Last Post: 08-17-2005, 04:26 AM
  4. Mandrake 10 messed up win2k partition
    By grasshopper in forum Linux - General Topics
    Replies: 11
    Last Post: 03-23-2004, 03:06 PM
  5. My window messed up....
    By teknik0s in forum Linux - Software, Applications & Programming
    Replies: 2
    Last Post: 06-26-2002, 07:35 AM


Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts