Yes give your box a static Address instead of a dynamic one (dhcp)
This is specified in the ifcfg-eth0 file, where it says BOOTPROTO=none
When you do this you need to tell it what the IP address is going to be, look at the rest of the ifcfg-eth0 file.
look up at last post - i modified it with the settings

Also if your internet is working then wot IP adresses do you have in /etc/resolv.conf?
They should be working DNS server addresses.