Page 1 of 2 12 LastLast
Results 1 to 10 of 15

Thread: DHCP

  1. #1


    I know I have asked about this before, but I still need some help. My setup is this:

    Suse 8.0 Pro. I have a Netgear router which I use with Earthlink (Mindspring) DSL. I have eth0 set up to use DHCP. MOST of the time when Suse boots up, it says that eth0 (DHCP) failed. When that happens, my internet works fine! In fact it is even faster than in Windows. Sometimes, it says: NO IP address yet....backgrounding. When that happens, I have no internet. It happens sporadically. I need to use DHCP, as far as I know, since I dont get a static IP with Earthlink.

    Does anyone use a router with cable or dsl?

    I assume that my dhcpd.conf is not configured correctly.

    If anyone can offer some suggestions, I would appreciate it. For the first several months, my internet always worked. It is only lately that I am occasionally getting the backgrounding message.


  2. #2


    I havent got this setup but shouldnt your router get the IP Address dynamically from your ISP, not your Suse box?

    then you would have the router run DHCP on the interface the Suse box is connected to. Or your Suse box could be assigned a static IP to match the interface you are using on the router, using the router interface IP as the gateway IP for the Suse machine.

    You shouldnt be running dhcpd on your Suse Box because that is offering dhcp to the router (i think).

    your internet might still work because maybe you are offering dhcp not recieving and your eth0 may have a static IP that allows connection to the router?
    Check your ifcfg-eth0?

    Just a thourght ???

    My setup is a box running RH 7.3 with a modem connection to the internet and a LAN connection to another box running RH 8.0/WinXP

    I run dhcpd on eth0 from the RH 7.3 box that is connected to the internet via ppp0. I configure the RH 8.0 box to get it's address from eth0 of the RH 7.3 box. Then the RH 7.3 box routes packets from eth0 to ppp0 when needed. ie RH 8.0 Machine requests something from the internet.

    Kinda like this

    internet-----ppp0<-RH 7.3->eth0(running dhcpd)-----RH 8.0(configured to get IP address dynamically)

    Hope this helps
    Its better to regret something you have done than to regret something you havent done :P

  3. #3


    Thanks for the reply. I cannot seem to get my internet working unless I have DHCP running on the Suse box. I could live with the eth0 showing as failed as long as the internet works (although I still want to know why), but the times it says backgrounding I have no internet and I cant live with that. In those instances I seem to just have to go into Yast2 in Suse and restart DHCP. Here is the ifconfig:

    eth0 Link encap:Ethernet HWaddr 00:B00:E73:BD
    inet addr: Bcast: Mask:
    inet6 addr: fe80::2b0:d0ff:fee7:d3bd/10 Scope:Link
    RX packets:8 errors:0 dropped:0 overruns:0 frame:0
    TX packets:90 errors:0 dropped:0 overruns:0 carrier:0
    collisions:0 txqueuelen:100
    RX bytes:728 (728.0 b) TX bytes:5592 (5.4 Kb)
    Interrupt:11 Base address:0xec80

    Perhaps I dont have the domain name and stuff configured correctly in Yast2?


  4. #4


    I Dont know anything about Suse, i've never even seen it.

    You shoudnt need dhcpd running on your Suse Box.
    All i can think of that makes it necessary to to ge the internet working with dhcpd is that maybe you are giving the router interface an ip address that is in the same range as eth0 on the Suse box, thus making it possible for the two machines to communicate? Im thinking your router gets its addresses automatically so this would probably work.

    This probably wont work if you dont use dhcp because the router interface and the Suse interface probably have different IP ranges as default.??

    dunno - hard to tell from here - you should check if you havent already

    you want dhcp services running on the router interface that the Suse box is connected to, and have the Suse box send dhcp requests.

    For the internet - Do you have your ISP's DNS Servers in /etc/resolv.conf?
    you can get dhcp to do this for you but in not sure what your router is capable of?

    To configure the Suse box to send dhcp requests make your /ifcfg-eth0 like mine
    an example of my /etc/sysconfig/network-scripts/ifcfg-eth0

    then restart the network service

    For the internet to work your machine needs to know where the DNS servers are so it can change into an IP Address. This is done in /etc/resolve.conf on my box.
    my /etc/resolve.conf

    Make sure the IP Addresses there are the DNS servers of your ISP.

    The resolve.conf file entries are put in there automaticaly because of the line PEERDNS=yes from the ifcfg-eth0 file when getting an IP Address by dhcp (with my setup anyway)

    this could be stuffing up from the dhcp server side of things? (it might not be sending the DNS server info?)
    you can put the DNS server addresses in /etc/resolve.conf manually if you like.

    Also make sure your Default gateway is the IP Address of the router interface you are connected to.

    Im assuming you Suse Box is connected to the router by ethernet? (cat5 cable and RJ-45 plugs?)

    Im not the best at explaining things but i hope this is where your headed.

    good luck
    Its better to regret something you have done than to regret something you havent done :P

  5. #5


    Well, I have been experimenting with most of the things you mentioned. This morning, eth0 didnt fail, and didnt say backgrounding, it actually got an IP, for the first time. The weird thing is that I didnt change anything. I do want to look at it some more and appreciate your suggestions. I am not sure if it will continue to work like this but I hope so.

  6. #6


    Cool 8)
    Its better to regret something you have done than to regret something you havent done :P

  7. #7


    Yeah, maybe it was a fluke. I want to make sure it always works correct, so I am working on it now.

  8. #8


    Yes, it was a fluke! :-[ I just restarted and eth0 (dhcp) failed again, but of course I still have internet. So, I guess changes do have to be made. I tried inputting the DNS I got from earthlink, but it said they were invalid. Back to the drawing board!

  9. #9


    What happens if you configure everything manually?

    eth0 -
    gateway - (whatever the ip address is of the router interface you are connected to)

    so ure /etc/sysconfig/network-scripts/ifcfg-eth0 looks like this

    (im assuming the router interface is in the 192.168.0.x range of IP Addresses)


    And ure /etc/sysconfig/network has this in it
    GATEWAY=(the Ip address of the router interface)

    then type
    ifdown eth0
    ifup eth0


    service network restart
    Its better to regret something you have done than to regret something you havent done :P

  10. #10


    What do you mean, when you say "manually"? Do you mean without dhcp?

Similar Threads

  1. Dhcp help
    By soccer05 in forum Linux - Software, Applications & Programming
    Replies: 6
    Last Post: 12-26-2012, 02:42 PM
  2. Dhcp Dns
    By natishkc in forum Redhat / Fedora
    Replies: 4
    Last Post: 04-01-2008, 09:13 AM
  3. please help with DHCP
    By mujtba in forum Linux - General Topics
    Replies: 2
    Last Post: 02-14-2005, 01:31 PM
  4. Disable Wireless Router DHCP and Use Linux DHCP Server?
    By omnivore in forum Linux - General Topics
    Replies: 0
    Last Post: 01-19-2005, 04:18 PM
  5. DHCP
    By BurntAsh in forum Linux - Hardware, Networking & Security
    Replies: 12
    Last Post: 01-19-2003, 09:36 PM


Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts