Warning: Function ereg() is deprecated in ..../includes/class_postbit.php(345) : eval()'d code on line 4

Warning: Function split() is deprecated in ..../includes/class_postbit.php(345) : eval()'d code on line 19

Warning: Function ereg() is deprecated in ..../includes/class_postbit.php(345) : eval()'d code on line 4

Warning: Function split() is deprecated in ..../includes/class_postbit.php(345) : eval()'d code on line 19

Warning: Function ereg() is deprecated in ..../includes/class_postbit.php(345) : eval()'d code on line 4

Warning: Function split() is deprecated in ..../includes/class_postbit.php(345) : eval()'d code on line 19

Warning: Function ereg() is deprecated in ..../includes/class_postbit.php(345) : eval()'d code on line 4

Warning: Function split() is deprecated in ..../includes/class_postbit.php(345) : eval()'d code on line 19

Warning: Function ereg() is deprecated in ..../includes/class_postbit.php(345) : eval()'d code on line 4

Warning: Function split() is deprecated in ..../includes/class_postbit.php(345) : eval()'d code on line 19

Warning: Function ereg() is deprecated in ..../includes/class_postbit.php(345) : eval()'d code on line 4

Warning: Function split() is deprecated in ..../includes/class_postbit.php(345) : eval()'d code on line 19

Warning: Function ereg() is deprecated in ..../includes/class_postbit.php(345) : eval()'d code on line 4

Warning: Function split() is deprecated in ..../includes/class_postbit.php(345) : eval()'d code on line 19
dhcpd
Results 1 to 7 of 7

Thread: dhcpd

  1. #1

    dhcpd

    Ok i'm having trouble with using dhcp. setup like this
    dhcpd is running on eth1of the RH 7.3 Box and using the rpm from the Red Hat 8.0 Disk
    The RH7.3 Box also has a modem connection to the internet and masquerades for the XP and RH8 Box


    Internet
    |
    Red Hat 7.3-eth0----------winXP
    -eth1----------Red hat8

    When i try to connect to the internet from the RH 8.0 machine it cant find the page. Im thinking its something to do with the default gateway? or the DNS servers. I added the DNS servers to /etc/dhcpd.conf by looking at /etc/resolve.conf of the RH7.3 Box when connected to the internet.



    My /etc/dhcpd.conf :

    ddns-update-style ad-hoc;
    default-lease-time 1200;
    max-lease-time 9200;
    option subnet-mask 255.255.255.0;
    option broadcast-address 192.168.1.255;
    option domain-name-servers 203.194.27.57, 203.194.56.150;
    subnet 192.168.1.0 netmask 255.255.255.0 {
    range 192.168.1.10 192.168.1.100;
    }


    Cheers
    Its better to regret something you have done than to regret something you havent done :P

  2. #2
    JimH
    Guest

    Re:dhcpd

    Try adding the ip address of your gateway.

    option routers whatever-ip;

    Jim H

  3. #3

    Re:dhcpd

    Added the routers and the gateway is correct now but the DNS still isnt working. It does if i add the DNS servers to /etc/resolv.conf on the clients, but i was hoping that DHCP would take care of it?
    Is there a way of making the 7.3 server point the way to the DNS servers for the clients. So configuring the clients doesn't mean adding entries to /etc/resolv.conf.

    TA
    Its better to regret something you have done than to regret something you havent done :P

  4. #4
    JimH
    Guest

    Re:dhcpd

    It should automatically update /etc/resolv.conf. I haven't played with dhcp under Red Hat 8 something might have changed other then the switch to using dhclient.

    Try forcing it by adding "PEERDNS=yes" to your /etc/sysconfig/network-scripts/ifcfg-eth*

    replace * with the correct number.

    Jim H

  5. #5

    Re:dhcpd

    Ok ill try that, im not at home at the moment - fill you in when i do. But also what about ideas for the windows clients?
    Anyway i'll persevere and let u guys know if i have a win.
    Its better to regret something you have done than to regret something you havent done :P

  6. #6

    Re:dhcpd

    PEERDNS=yes worked for the linux client YAY!
    Actually it was already in the ifcfg-eth0 file, and set to no. I guess i should have guessed that :


    Thanks again Jim
    Its better to regret something you have done than to regret something you havent done :P

  7. #7
    JimH
    Guest

    Re:dhcpd

    Hmm, you must have accidently at some time changed it to "no". "yes" is the default.

    Jim H

Similar Threads

  1. dhcpd fails to start
    By JoeW in forum Linux - Hardware, Networking & Security
    Replies: 2
    Last Post: 06-01-2012, 10:27 PM
  2. dhcpd unable to serve multiple subnets
    By licause in forum Linux - Hardware, Networking & Security
    Replies: 10
    Last Post: 06-09-2009, 06:50 AM
  3. starting dhcpd: failed
    By lynntwin in forum Linux - Hardware, Networking & Security
    Replies: 6
    Last Post: 03-25-2008, 01:28 AM
  4. Getting madwifi, wpa_supplicant and dhcpd to run at boot time
    By JoeyJoeJoe in forum Linux - Hardware, Networking & Security
    Replies: 8
    Last Post: 07-25-2007, 02:34 AM
  5. DHCPD problem.
    By CK in forum Linux - Hardware, Networking & Security
    Replies: 2
    Last Post: 07-15-2003, 09:54 AM

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •