Warning: Function ereg() is deprecated in ..../includes/class_postbit.php(345) : eval()'d code on line 4

Warning: Function split() is deprecated in ..../includes/class_postbit.php(345) : eval()'d code on line 19

Warning: Function ereg() is deprecated in ..../includes/class_postbit.php(345) : eval()'d code on line 4

Warning: Function split() is deprecated in ..../includes/class_postbit.php(345) : eval()'d code on line 19

Warning: Function ereg() is deprecated in ..../includes/class_postbit.php(345) : eval()'d code on line 4

Warning: Function split() is deprecated in ..../includes/class_postbit.php(345) : eval()'d code on line 19

Warning: Function ereg() is deprecated in ..../includes/class_postbit.php(345) : eval()'d code on line 4

Warning: Function split() is deprecated in ..../includes/class_postbit.php(345) : eval()'d code on line 19

Warning: Function ereg() is deprecated in ..../includes/class_postbit.php(345) : eval()'d code on line 4

Warning: Function split() is deprecated in ..../includes/class_postbit.php(345) : eval()'d code on line 19

Warning: Function ereg() is deprecated in ..../includes/class_postbit.php(345) : eval()'d code on line 4

Warning: Function split() is deprecated in ..../includes/class_postbit.php(345) : eval()'d code on line 19

Warning: Function ereg() is deprecated in ..../includes/class_postbit.php(345) : eval()'d code on line 4

Warning: Function split() is deprecated in ..../includes/class_postbit.php(345) : eval()'d code on line 19

Warning: Function ereg() is deprecated in ..../includes/class_postbit.php(345) : eval()'d code on line 4

Warning: Function split() is deprecated in ..../includes/class_postbit.php(345) : eval()'d code on line 19

Warning: Function ereg() is deprecated in ..../includes/class_postbit.php(345) : eval()'d code on line 4

Warning: Function split() is deprecated in ..../includes/class_postbit.php(345) : eval()'d code on line 19

Warning: Function ereg() is deprecated in ..../includes/class_postbit.php(345) : eval()'d code on line 4

Warning: Function split() is deprecated in ..../includes/class_postbit.php(345) : eval()'d code on line 19
Linux and a hub w/ cable
Results 1 to 10 of 10

Thread: Linux and a hub w/ cable

  1. #1
    stodgel
    Guest

    Linux and a hub w/ cable

    using Mandrake 8.2, and one other computer running Windows, I have the computers connected to a hub and I have a cable modem connected to the uplink on the hub. The problem is that the Windows machine connects to the internet fine but the Linux machine will not connect at all. In fact the hub doesn't even recognize the Linux machine. The light on the hub does not come on for Linux. I have tried switching from #1 to #2 and 3 and 4. This is DHCP so I don't understand why this isn't working. As soon as I unplug the Linux machine from the hub and plug it straight into the modem it works fine. Is there something in particular that has to be done with Linux before a connection like this can be made. All I want is to be able to have both computers connected so I don't have to switch wires all the time.

  2. #2
    JimH
    Guest

    Re:Linux and a hub w/ cable

    Unless your ISP allows multiple simultaneous connections the way you have it setup, it is not going to work.

    Jim H

  3. #3
    stodgel
    Guest

    Re:Linux and a hub w/ cable

    That's just it. They do allow multiple connections. In fact when I plug each of the two computers into the cable modem individually I get a different IP address for each one. That's why I can't figure out why it's not working. The isp said that whatever the problem is it's on my end. The addresses are DHCP so they should be picked up automatically. What is it that I need to do?

  4. #4
    JimH
    Guest

    Re:Linux and a hub w/ cable

    Any errors in /var/log/messages when you have the linux box connected to the hub?

    Jim H

  5. #5

    Re:Linux and a hub w/ cable

    Have you tried unplugging the Windows machine from the hub, and just having the Linux box plugged into the hub, and not just straight to the Cable modem?

    You may have the wrong type of cable. If your connecting to a hub, then you will want a Straight Through Cable. If you are only connecting to another machine then a Crossover Cable is need. This could be why the Linux box is only able to connect to the Cable box, and not go through the hub. (This is a guess from left field now, as I've never tried connecting various cable's like this before.)

    This is how to make a crossover cable if you ever need to: http://www.littlewhitedog.com/reviews_other_00009.asp

    This is how to make a straight through cable(really it's both): http://www.ertyu.org/~steven_nikkel/ethernetcables.html
    AMD Athlon 2200+ 1.8Ghz
    1280MB PC-3200 CAS2.5 RAM
    ATI Radeon 9600 Pro 128MB AGP
    Western Digital WDC WD2500JB-00FUA0 250GB 7200 rpm ATA/133
    Seagate ST3200822A 200GB 7200 rpm ATA/133
    Western Digital WDC WD1200BB-00CAA1 120GB 7200 rpm ATA/133
    Western Digital WDC WD800BB-00CAA1 80GB 7200 rpm ATA/133
    Maxtor OneTouch 2HA43R32 1TB 7200 rpm USB 2.0
    D-Link DFE-530TX+ 10/100 NIC
    D-Link DWL-G520 Rev.A
    Debian 5.0r1 Lenny

  6. #6
    stodgel
    Guest

    Re:Linux and a hub w/ cable

    I did try to do this on 10/12, yesterday and I do have a copy of the messages from the /var/log/messages. I have no idea what any of this means, I imagine that if there were any errors they would be in there. I didn't post it because it is somewhat long and I didn't know if I should post something that large or not. So if it's ok I will go ahead and post what I have from 10/12/02.

  7. #7
    stodgel
    Guest

    Re:Linux and a hub w/ cable

    About the cables. I have used a few different cables. I don't know what the differences are that you mentioned. However there were cables that came with the hub (Linksys 5 port workgroup hub). I also had a few other cables laying around, plus the one that came with the modem. I have tried all of them, just in trying different configurations. That may very well be something that I need to look into as well.

  8. #8
    JimH
    Guest

    Re:Linux and a hub w/ cable

    You don't need to post the entire file. Just post the section with the errors.

    Jim H

  9. #9
    stodgel
    Guest

    Re:Linux and a hub w/ cable

    Every line just has the date, time, and ip address along with whatever message is there. Unless an error would specifically say "error" I don't know what's an error and what isn't. I don't know what any of this means.

  10. #10
    beatlejuice321
    Guest

    Re:Linux and a hub w/ cable

    Stodgel,

    SkyNet is correct, you can pretty much only have a problem with your cable (Crossover, Straight Through, or Bad Cable), or of course it could be your configuration of your NIC etc... that prevents Internet access.

    However, it is my understanding that when the connection between your HUB and your NIC is good. You should see a light on the HUB and the NIC. This shows a "Good" Ethernet (802.3) compliant physical connection. And as I understand it, this has nothing to do with the OS or software you are running.

    This is the same method Network Admins use to check cabling connections in buildings. Many times when a "Cable Tester" is not available, they just plug two HUB's (not unlike your model) together and see if the LED lights up (showing a good physical connection). No software connection is involved with the physcial connection of your NIC either. (note: I just tested this to make sure I wasn't lying, my computers NIC "lights up" as soon as my computer is turned on (at POST), not when my OS starts.

    Bottom line, no LED light, no Internet access.

    Note: you should also try "pinging" your other PC while connected to the HUB if you believe you have a good physical connection. This will tell you if your NIC and network connections are configured correctly (which I am sure they are if you get Internet access from the Modem directly).

    If all else fails, it may be easier to drop that old 10-Mbps HUB and go for an actual Router (I know this will work). They are only about $60.00-100.00 now, and I am sure you could utilize the built-in Firewall protection for your new network.

    Hope this helps,

    Beatlejuice


Similar Threads

  1. Linux cannot tolerate swapped IDE cable
    By azgs in forum Linux - General Topics
    Replies: 6
    Last Post: 11-19-2007, 09:34 PM
  2. Lan, Cable and PPTP (FIXED IP OVER CABLE)
    By mailservertest in forum Linux - Hardware, Networking & Security
    Replies: 1
    Last Post: 08-15-2005, 10:12 PM
  3. Cable
    By countach44 in forum General Chat
    Replies: 5
    Last Post: 09-28-2004, 06:35 AM
  4. Replies: 31
    Last Post: 12-07-2002, 02:48 AM
  5. Trouble Getting Cable Internet To Work in Linux.
    By xin in forum Linux - Hardware, Networking & Security
    Replies: 9
    Last Post: 05-29-2002, 06:20 AM

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •