unning on Red Hat 7.3, openldap rpm 2.0.23-4
Slapd can be started ok.
Here is my slapd.conf:
include /etc/openldap/schema/core.schema
include /etc/openldap/schema/cosine.schema
include /etc/openldap/schema/inetorgperson.schema
################################################## ##################
# ldbm database definitions
################################################## ##################
database ldbm
suffix "o=blg"
suffix "dc=websense,dc=blg,dc=org"
rootdn "cn=ldapadmin,o=blg"
rootpw secret1
directory /var/lib/ldap/blg
defaultaccess read
schemacheck on
lastmod on
index cn,sn,st pres,eq,sub

Here is my very basic ldif file (blg.ldif, located in the same directory as slapd.conf (/etc/openldap)
dn: dc=websense,dc=blg,dc=org
objectClass: top
objectClass: dcObject
objectClass: organization
dc: blg
o: blg
description: Big Log Group

dn: o=blg
objectClass: top
objectClass: organization
o: blg
description: Big Log Group

Next thing I do after ldap started is to issue the command:
ldapadd -f blg.ldif -xv -D "cn=ldapadmin,o=blg" -W
...and it gives me the following error:
add objectClass:
top
dcObject
organization
add dc:
blg
add o:
blg
add description:
Big Log Group
adding new entry "dc=websense,dc=blg,dc=org"
ldap_add: Operations error
ldif_record() = 1

Another debugging info:
According to the tutprial:
- after I issue ldapadd I should issue slapdd -l blg.ldif -v (which I did, and I got the following output:
# added: "dc=websense,dc=blg,dc=org" (00000001)
added: "o=blg" (00000002)
I restarted ldap and tried to do ldapadd -f blg.ldif -xv -D "cn=ldapadmin,o=blg" -W
but it gave the same error.

Could you please tell me what's wrong with the things I'm doing?
Thank you.