Warning: Function ereg() is deprecated in ..../includes/class_postbit.php(345) : eval()'d code on line 4

Warning: Function split() is deprecated in ..../includes/class_postbit.php(345) : eval()'d code on line 19

Warning: Function ereg() is deprecated in ..../includes/class_postbit.php(345) : eval()'d code on line 4

Warning: Function split() is deprecated in ..../includes/class_postbit.php(345) : eval()'d code on line 19

Warning: Function ereg() is deprecated in ..../includes/class_postbit.php(345) : eval()'d code on line 4

Warning: Function split() is deprecated in ..../includes/class_postbit.php(345) : eval()'d code on line 19

Warning: Function ereg() is deprecated in ..../includes/class_postbit.php(345) : eval()'d code on line 4

Warning: Function split() is deprecated in ..../includes/class_postbit.php(345) : eval()'d code on line 19

Warning: Function ereg() is deprecated in ..../includes/class_postbit.php(345) : eval()'d code on line 4

Warning: Function split() is deprecated in ..../includes/class_postbit.php(345) : eval()'d code on line 19

Warning: Function ereg() is deprecated in ..../includes/class_postbit.php(345) : eval()'d code on line 4

Warning: Function split() is deprecated in ..../includes/class_postbit.php(345) : eval()'d code on line 19

Warning: Function ereg() is deprecated in ..../includes/class_postbit.php(345) : eval()'d code on line 4

Warning: Function split() is deprecated in ..../includes/class_postbit.php(345) : eval()'d code on line 19

Warning: Function ereg() is deprecated in ..../includes/class_postbit.php(345) : eval()'d code on line 4

Warning: Function split() is deprecated in ..../includes/class_postbit.php(345) : eval()'d code on line 19

Warning: Function ereg() is deprecated in ..../includes/class_postbit.php(345) : eval()'d code on line 4

Warning: Function split() is deprecated in ..../includes/class_postbit.php(345) : eval()'d code on line 19

Warning: Function ereg() is deprecated in ..../includes/class_postbit.php(345) : eval()'d code on line 4

Warning: Function split() is deprecated in ..../includes/class_postbit.php(345) : eval()'d code on line 19
Switch to RH
Page 1 of 2 12 LastLast
Results 1 to 10 of 11

Thread: Switch to RH

Hybrid View

  1. #1
    mugs
    Guest

    Switch to RH

    Ok, this morning before work (I get up early) I installed RH 7.3 in place of Suse 8.0. The install went fine! However, I installed GRUB (was using LILO with Suse) and it only gave me one choice...Red Hat. I would have thought it would have put Windows in there like LILO did. So, after a little bit of panic that maybe Windows was gone (my wife uses it), I finally configured the grub.conf file and now Windows can be booted. I have some other questions, though, and maybe it is becuase I am more used to Suse. When I would start Suse, I would get a graphical menu with choices of who to log in as (me, root, etc) and choices for Gnome, KDE, etc. With RH, I get a prompt that says dhcpp1 and I have to log in from there. I havent tried, but I assume you can log in as root from there? Also, my internet doesnt seem to be working, while with Suse, it worked right out of the box. I plan on using it and reading up on the RH site, etc on how to use it and Gnome, but 1 more quick question...where do I go to mount my C (windows) drive?

  2. #2
    mugs
    Guest

    Re:Switch to RH

    I did choose Graphical for log in, but I am still just getting a prompt. Where do I change this? Thanks.

  3. #3
    JimH
    Guest

    Re:Switch to RH

    However, I installed GRUB (was using LILO with Suse) and it only gave me one choice...Red Hat.
    You must be using a version of windoze that uses NTFS. This problem seems to effect a limited number of people. I don't think it is a problem with Grub specifically. More then likely it is a problem specific to some motherboard/motherboard bios. I have never seen this problem, either on my systems or for installs for other people.

    With RH, I get a prompt that says dhcpp1 and I have to log in from there. I havent tried, but I assume you can log in as root from there?
    That prompt looks to me like you configured your NIC to use dhcp and it is grabbing a hostname from your ISP when it connects.

    Also, my internet doesnt seem to be working
    How do you connect to your ISP? DHCP? PPPOE? Did you configure you internet connection?

    where do I go to mount my C (windows) drive?
    NTFS partition? Read:
    http://www.getlinuxonline.com/omp/di...t/ompntfs2.htm

    Jim H

  4. #4
    JimH
    Guest

    Re:Switch to RH

    Quote Originally Posted by mugs
    I did choose Graphical for log in, but I am still just getting a prompt. Where do I change this? Thanks.
    What kind of video card are you using?

    You change the runlevel you boot into by editing the file /etc/inittab.

    Look for the line: id:*:initdefault:
    The * will be a number.

    Change the * to one of these two values.

    3 - boot to console mode
    5 - boot directly in X11

    Jim H

  5. #5
    mugs
    Guest

    Re:Switch to RH

    Thanks for the replies, Jim!

    Yes, I have NTFS, but like I said, I figured it out and now get the Windows option.

    Yes, I configured it to use dhcp. I have DSL and I use a router. With Suse, I never had to configure anything, so when I get home tonight, I will take another look at the internet.

    Thank you for the graphical login info. I have since gone to the RH site and saw the awesome info they have there. It is clear and very well organized. I am sure I will be there a lot.
    I am looking forward to working with RH!

  6. #6
    JimH
    Guest

    Re:Switch to RH

    Quote Originally Posted by mugs
    Yes, I configured it to use dhcp. I have DSL and I use a router.
    OK I see, the router provides the internet connection. The dhcp functions of the router must be enabled. Red Hat automatically sets any NIC it detects to dhcp. I must be pulling the strange hostname from the router. With the router providing the internet connection you want set your NIC to use BOOTPROTO=none. There is no reason to have dhcp enabled on the router.

    Edit /etc/sysconfig/network-scripts/ifcfg-eth0

    DEVICE=eth0
    BOOTPROTO=none
    BROADCAST=
    IPADDR=
    NETMASK=
    NETWORK=
    ONBOOT=yes

    Edit /etc/sysconfig/network More then likely the router has an ip address of 192.168.1.1, bu this is only a guess.

    GATEWAY=192.168.1.1

    You will have to edit /etc/resolv.conf and add you ISP's nameservers to it.

    Reboot. Yes reboot. To check and make sure everything works on boot.

    This should get you working. Since I don't use hardware routers this is a guess.

    Jim H

  7. #7
    mugs
    Guest

    Re:Switch to RH

    Thanks again Jim, actually the internet does work! But, I am having problems with the runtime. I went to change the runlevel to 5, but it was already set to 5!!!, but I am not getting the graphical logon. This is what happens on boot: I get dhcppc1 login, so I log in. Then it says [mugs@dhcppc1 mugs]$ and I type startX. Then it pops up with a gnome box and says: "Could not look up internet address for dhcppc1-This will prevent Gnome from operating correctly. It may be possible to correct this problem my adding dchppc1 to the file etc/hosts. Should I try that? What about the runlevel. And, should I take your last suggestions, even though the internet is working? Thanks!

  8. #8
    mugs
    Guest

    Re:Switch to RH

    Here is my inittab...still no graphical logon and still the error message...


    #
    # inittab This file describes how the INIT process should set up
    # the system in a certain run-level.
    #
    # Author: Miquel van Smoorenburg, <miquels@drinkel.nl.mugnet.org>
    # Modified for RHS Linux by Marc Ewing and Donnie Barnes
    #

    # Default runlevel. The runlevels used by RHS are:
    # 0 - halt (Do NOT set initdefault to this)
    # 1 - Single user mode
    # 2 - Multiuser, without NFS (The same as 3, if you do not have networking)
    # 3 - Full multiuser mode
    # 4 - unused
    # 5 - X11
    # 6 - reboot (Do NOT set initdefault to this)
    #
    id:5:initdefault:

    # System initialization.
    si::sysinit:/etc/rc.d/rc.sysinit

    l0:0:wait:/etc/rc.d/rc 0
    l1:1:wait:/etc/rc.d/rc 1
    l2:2:wait:/etc/rc.d/rc 2
    l3:3:wait:/etc/rc.d/rc 3
    l4:4:wait:/etc/rc.d/rc 4
    l5:5:wait:/etc/rc.d/rc 5
    l6:6:wait:/etc/rc.d/rc 6

    # Things to run in every runlevel.
    ud:nce:/sbin/update

    # Trap CTRL-ALT-DELETE
    ca::ctrlaltdel:/sbin/shutdown -t3 -r now

    # When our UPS tells us power has failed, assume we have a few minutes
    # of power left. Schedule a shutdown for 2 minutes from now.
    # This does, of course, assume you have powerd installed and your
    # UPS connected and working correctly.
    pf:owerfail:/sbin/shutdown -f -h +2 "Power Failure; System Shutting Down"

    # If power was restored before the shutdown kicked in, cancel it.
    pr:12345owerokwait:/sbin/shutdown -c "Power Restored; Shutdown Cancelled"


    # Run gettys in standard runlevels
    1:2345:respawn:/sbin/mingetty tty1
    2:2345:respawn:/sbin/mingetty tty2
    3:2345:respawn:/sbin/mingetty tty3
    4:2345:respawn:/sbin/mingetty tty4
    5:2345:respawn:/sbin/mingetty tty5
    6:2345:respawn:/sbin/mingetty tty6

    # Run xdm in runlevel 5
    # xdm is now a separate service
    x:5:respawn:/etc/X11/prefdm -nodaemon


    Thanks!

  9. #9
    JimH
    Guest

    Re:Switch to RH

    Quote Originally Posted by mugs
    This is what happens on boot: I get dhcppc1 login, so I log in. Then it says [mugs@dhcppc1 mugs]$ and I type startX. Then it pops up with a gnome box and says: "Could not look up internet address for dhcppc1-This will prevent Gnome from operating correctly.
    The problem is your router is supplying your linux box with an invalid hostname, dhcppc1. You need to change the configuration on your router so that it does not rename your linux box.

    Jim H

  10. #10
    mugs
    Guest

    Re:Switch to RH

    Well, I really hate to mess with it, as it works fine in Windows, worked fine in Suse, and the internet does work fine in RH. Do you think this is tied to the problem that i dont get a graphical login?

Similar Threads

  1. Gigabit switch
    By vwgtiturbo in forum Linux - Hardware, Networking & Security
    Replies: 15
    Last Post: 08-31-2006, 04:11 PM
  2. How to switch from XDM to GDM ?
    By Compunuts in forum Linux - Software, Applications & Programming
    Replies: 5
    Last Post: 10-16-2004, 06:20 AM
  3. KVM Switch
    By BurntAsh in forum Linux - Hardware, Networking & Security
    Replies: 1
    Last Post: 03-18-2003, 07:03 PM
  4. KVM Switch
    By mcdougrs in forum Linux - Hardware, Networking & Security
    Replies: 6
    Last Post: 01-03-2003, 08:56 PM
  5. Made the switch -need a little help
    By wader in forum Linux - Software, Applications & Programming
    Replies: 14
    Last Post: 09-17-2002, 03:04 AM

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •