Results 1 to 4 of 4

Thread: apm settings in /etc/lilo.conf

  1. #1
    Associate
    Join Date
    Apr 2002
    Posts
    39

    apm settings in /etc/lilo.conf

    This newbie's working on a new install record ... done 4 in the last week.

    The silver lining is I'm learning something!

    Anyway, about the only thing 'funky' about my most recent re-do is that the PC doesn't shut down now. I believe I'm to modify my /etc/lilo.conf file to make it 'right'!?

    This is it, currently:


    message = /boot/message

    image = /boot/vmlinuz
    label = linux
    root = /dev/hda8
    vga = 788
    initrd = /boot/initrd
    append = " ide=nodma apm=off acpi=off"

    image = /boot/vmlinuz.suse
    label = failsafe
    root = /dev/hda8
    vga = 788
    initrd = /boot/initrd.suse

    append = "ide=nodma apm=off acpi=off ide=nodma apm=off acpi=off"
    optional

    other = /dev/hda1
    label = windows

    image = /boot/memtest.bin
    label = memtest86


    I read in my SuSE help to change an apm line to:

    append="apm=real-mode-poweroff"

    I assume I would change this in both places on the line colored red, above?? Would this force a poweroff on shutdown??

    ~ Phaete

  2. #2
    Associate
    Join Date
    Sep 2002
    Posts
    31

    Re:apm settings in /etc/lilo.conf

    don't know about this one
    but maybe take a look at /etc/inittab could help

  3. #3

    Re:apm settings in /etc/lilo.conf

    You're probably right. No harm in trying. In the event that things go terribly terribly wrong, have a bootdisk nearby. Boot up with the bootdisk, and mount your filesystem that has lilo.conf on it (with the "mount -t <fstype> /dev/hd<x> /<mountdirectory>" command (everything in <> brackets will depend on your setup). However, with an option like this you probably won't get stuck with an unbootable option. If you feed it invalide appends, it usually keeps on going. Another option would be to make another entry in lilo.conf called "failsafe2" and give it exactly the same info. If failsafe doesn't work, boot up failsafe2 and change things.
    There's also been a post regarding apm recently in either tech support or software issues. Maybe take a look there? Anyway tell us if changing your lilo lines works, and when you change them, BE SURE TO RUN "lilo" AS ROOT! This confused me a lot when I first installed it. Running lilo as root implements your config file. Do that, then reboot and good luck!

  4. #4

    Re:apm settings in /etc/lilo.conf

    apm must be enabled to do a real shutdown, either remve both apm= things, or if that doesnt work try modprobe apm before you halt

Similar Threads

  1. smb.conf example
    By trickster in forum Linux - Hardware, Networking & Security
    Replies: 1
    Last Post: 06-21-2004, 11:48 PM
  2. DMA settings.....
    By SwampDonkey in forum Linux - Hardware, Networking & Security
    Replies: 3
    Last Post: 10-23-2002, 07:16 AM
  3. vga=792 in /etc/lilo.conf
    By wing328 in forum Linux - General Topics
    Replies: 1
    Last Post: 06-03-2002, 03:11 PM
  4. jumper settings
    By agar in forum Linux - General Topics
    Replies: 8
    Last Post: 12-25-2001, 05:47 PM
  5. Date Settings
    By mrkeef in forum Linux - Software, Applications & Programming
    Replies: 3
    Last Post: 10-03-2001, 02:31 PM

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •