Results 1 to 10 of 10

Thread: Nvidia And Sorry

Hybrid View

  1. #1

    Nvidia And Sorry

    I am sorry for doing the multiposts across 5 different boards on this site. A regular member here gave me advice and I am now taking it and I am going to make this my main thread and would like to continue to try and solve this problem...once again I am sorry for multiposting and it shall not happen again.I plan on doing this post the way it should be done...right.

    I am running Redhat 7.3 and currently nothing graphical works..IE. Tuxracer, xlogo and xwindows which concerns me most.

    My hardware setup is this:
    MSI K7N420 Pro with the nForce chipset (integrated audio, video and ethernet)
    AMD Tbird 1.4 Ghz
    384mb Ram
    HP Pavilion M70 monitor
    42x Cdrom drive
    Teac W54E Cd Burner
    Generic Floppy
    Kingston KNEIIITX (ETHERX VPII 10/100 PCI FAST ETHERNET ADAPTER) Which currently doesnt work as well.

    Several people have tried to help me to no success but I hope that someone or someones will be able to solve this.

    I downloaded the the following drivers:
    Redhat 7.3 nForce drivers named NVIDIA_nforce-1.0-0241.rh73up.athlon.rpm from this page

    It installed the rpm and later found out it went to a folder that isnt checked by XF86Config so I copied it to a folder where it does get read, I updated the XF86Config-4 to what people instructed me to and changed the driver name from nv to nvidia which gave me an error when I tried startx, the error is as follows:
    Loading module "nvidia"
    Module nvidia not found
    Unloading module "nvidia"
    (dont remember this part) [module does not exist,0]
    then the mouse driver loaded here
    under the mouse driver loading thing it said:
    No drivers found

    Fatal error ocured:
    no screens found

    So then I changed it nvnet as that is what the installed driver was called and got these errors when startx:
    Loading module "nvnet"
    not loading .fixup
    not loading .re.fixup
    not loading .modinfo
    not loading __ex_table
    not loading .re__ex_table
    Could not find nvnetModuleData data object
    [invalid module,0]

    This is where I currently stand...if anyone needs more info about other documents please ask and I will get them posted up here. Once again I am sorry for the multiposting.

    PS-Aragorn when you have a chance could you delete the other 4 or 5 topics I made? Thank you

  2. #2

    Re:Nvidia And Sorry

    A perfect example of the proper post, thanks for listening to me for a bit and taking care of business on the board Torch. You have made it off my shitlist :P. I am sure this issue will get much attention/help, since we can all learn from this issue.

    Well Done,


  3. #3

    Re:Nvidia And Sorry

    Just checking, but how did you install that rpm file? If you didn't already take a look:

  4. #4

    Re:Nvidia And Sorry

    I did:
    mount /mnt/floppy
    cd /mnt/floppy
    rpm -ivh NVIDIA_nforce(rest of name ehre).athlon.rpm
    -qsl (filename) or rpm -qsl (filename)
    then I noticed it installed it to somewhere it wasnt looking for it in the XF86Config file so I did:
    cp /lib/modules/2.4.18-3/kernel/drivers(I think thats the path) /usr/X11R6/lib/modules/drivers

  5. #5

    Re:Nvidia And Sorry

    just for future notice. it is a lot safer to do rpm -Uvh . it won't copy straight over anything that might be there.



    *looking into that readme to see waht the hell is going on :P

  6. #6

    Re:Nvidia And Sorry

    *reincarnates* hey guys been a long time...I can tell my post did still stuck with the integrated ghettoness I call nForce...Red Hat still doesnt work so if anyone has come up with anything please post here...

  7. #7

    Re:Nvidia And Sorry

    The way *I* did it

    In the install, make sure you have installed the kernel_source, kernel headers (glibckern-headers or something) and gcc installed. You can always install these from the rpm directory in CD2 at a later date. Do the following while logged in as root.

    Download 3 tarballed files from, the nforce driver (NVIDIA_nforce-1.0-0241.tar.gz), the kernel driver (NVIDIA_kernel-1.0-3123.tar.gz) and the GLX driver (NVIDIA_GLX-1.0-3123.tar.gz) and stick these on a CD (or fat32 partition). Then boot to runlevel 3 in linux, make a directory in say /home called nvidia:
    mkdir nvidia (while in /home),
    mount the cd
    mount /mnt/cdrom,
    and copy the files over
    cp /mnt/cdrom/file.tar.gz /home/nvidia.
    Then switch to the nvidia directory and type
    tar -xzvf NVIDIA_nforce-1.0-0241.tar.gz
    which willl end up making a directory called nvidia. Switch to this directory and type
    and then
    make install
    (which will both come up with gibberish). Then reboot and linux will detect the network card (which you can setup to use DCHP if you wish). Then when linux boots to shell log in as root again and switch to /home/nvidia. Then type
    tar -xzvf NVIDIA_kernel-1.0-3123.tar.gz,
    which will create a directory called NVIDIA_kernel-1.0-3123. Go into this and type make and make install again. Repeat this last step for NVIDIA_GLX-1.0-3123.tar.gz. Then go to /etc/X11 and type
    vi XF86Config-4. Press i, and then put a # in front of the "Load "dri"" and "Load "GLCore"" lines, and make sure you have a line "Load "glx"". Now scroll down to where it says
    "Driver = "nv"" and change the "nv" to "nvidia". Now press escape and then shift and xx to save and close. Now type
    and X should start.


  8. #8

    Re:Nvidia And Sorry

    Hmm im not sure what GLX and kernel file you are referring are talking about for the nforce right? I got the nforce driver you refered to and the right glx file(I think) but im not sure on what kernel file you are talking about
    edit- I found the kernel file but it isnt the right one I dont think...the one I found is NVIDIA_kernel-1.0-1251.tar.gz
    Another edit-all files found...thanks getting ready to try this out

    Yet another edit....Alrighty I followed your directions but when I do make and make install on any file I get loads of erros...

  9. #9

    Re:Nvidia And Sorry

    I'm not really very good on linux, I can't really troubleshoot I just posted what worked for me. The only other thing I can think of is a fresh install (making sure of course you install the kernel_source, glibc-kernheaders and gcc rpms from 'select individual packages'), and then trying again.



  10. #10

    Re:Nvidia And Sorry

    Just a note. Red Hat considers nForce based motherboards to be incompatible and are not supported.

    Jim H

Similar Threads

  1. NVIDIA TV-Out
    By peter in forum Tutorials
    Replies: 0
    Last Post: 11-24-2008, 05:51 AM
  2. nVIDIA or ATI?
    By Marik in forum Windows - General Topics
    Replies: 20
    Last Post: 01-27-2005, 10:02 PM
  3. nvidia
    By gmoreno in forum Linux - General Topics
    Replies: 4
    Last Post: 06-03-2003, 12:45 AM
  4. Nvidia help
    By thor4linux in forum Linux - General Topics
    Replies: 5
    Last Post: 12-27-2001, 04:23 PM
  5. Nvidia
    By jman_77 in forum Mandriva
    Replies: 2
    Last Post: 07-22-2001, 03:35 AM


Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts