Results 1 to 8 of 8

Thread: KDE3 and XMMS

  1. #1
    Bogler
    Guest

    KDE3 and XMMS

    When i start xmms (from cmd line) with xmms & on kde3 and then play an mp3 it prints a "SIG PIPE" (not at the terminal so can't reproduce exact error) or similar error to the shell window.

    Has anyone else noticed this problem? It appears to print the same message every time xmms moves to a new track on the playlist.

    Anyone know of a fix for this?

    Thanks

    Bogler :-\

    RH7.3, KDE3, XFree 4.1, kernel; 2.4.18-5, VIA chipset.

  2. #2
    JimH
    Guest

    Re:KDE3 and XMMS

    Probably just a bug in xmms or a bug when it is run under KDE.

    I can't reproduce this on my Limbo box under Gnome. I have not tried it under KDE. Maybe it has been fixed. I will try and force myself to switch to KDE and try it later. :P

    $ rpm -qa | grep xmms
    xmms-devel-1.2.7-4
    xmms-1.2.7-4
    xmms-skins-1.2.7-4

    Jim H

  3. #3

    Re:KDE3 and XMMS

    while we're on xmms errors....
    im using sawfish(mill?? - can never remember what one to use..) but not gnome etc..
    when i try to use a dialoge box like the options or add dir i get an error to sderr saying "Stacking constraint failed"
    it only happens in sawmill and not in any other wms

    any ideas? im assuming its a sawmill bug but i can't seem to find a fix

    Alastair
    whatdoyougetwhenyoumultiplysixbynine??

  4. #4
    JimH
    Guest

    Re:KDE3 and XMMS

    Alastair, I have never seen that error. Never used Sawfish without Gnome and I am not using Sawfish at all right now.

    Jim H

  5. #5

    Re:KDE3 and XMMS

    [me=alastair]downloads metacity[/me]
    whatdoyougetwhenyoumultiplysixbynine??

  6. #6
    Aaron_Adams
    Guest

    Re:KDE3 and XMMS

    Hey Bogler,

    The SIGPIPE signal is generated from an application trying to do a write to a pipe that has nothing to read it on the other end. It's normally caused in network applications though. I think it is possible if a process is trying to write to another process that isn't reading. It could be that everytime XMMS goes to write the data to the pipe for the sound to interpret (or however that works) maybe sound interpreter has a delay that causes a SIGPIPE, but on the next write it's reading. (That's assuming XMMS isn't crashing on receiving the signal)

    That's sort of out there, so I don't know how accurate it would be. Doing a bit of googling I only found one site that mentioned a problem with XMMS and SIGPIPE but it didn't have much of an explanation, and I believe it occured from a plugin.

    Is it actually crashing XMMS? Or just displaying the error but still playing the mp3? It only happens when it's in the background too?

    Aaron

  7. #7
    Bogler
    Guest

    Re:KDE3 and XMMS

    Thanks for the responses.. i have been away for a few days (Amsterdam in the sun.....SUPERB ).

    I'll have another look tonight and write a better description.
    XMMS doesn't crash but simply writes a line to the terminal. I have plugins installed right enough, i'll disable these and have another look.

    Regards

    Bogler

  8. #8

    Re:KDE3 and XMMS

    that is really weird man, i run both KDE 3 and XMMS and _never_ have issues. that is pretty wild. maybe try reinstalling XMMS. who knows ???

Similar Threads

  1. xmms problem with mp3
    By HISSAM in forum Linux - Software, Applications & Programming
    Replies: 0
    Last Post: 08-30-2007, 02:11 PM
  2. Why not XMMS?
    By gmoreno in forum Linux - Software, Applications & Programming
    Replies: 12
    Last Post: 08-02-2005, 06:06 AM
  3. xmms
    By JuggaloAnt in forum Linux - General Topics
    Replies: 11
    Last Post: 06-19-2004, 11:35 AM
  4. xmms buggy
    By grimey in forum Linux - Software, Applications & Programming
    Replies: 6
    Last Post: 11-19-2003, 12:00 AM
  5. Xmms Volume
    By BurntAsh in forum Linux - Software, Applications & Programming
    Replies: 5
    Last Post: 04-24-2003, 04:33 AM

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •