Page 1 of 6 123 ... LastLast
Results 1 to 10 of 57

Thread: SWAT Connection to refused

  1. #1

    SWAT Connection to refused

    Samba appears to be working, shares ad printers but I cannot run SWAT at all, have tried playing with IPChains etc but simply do not understand it ! RH7.2 newbie

    have tried running gnome lokkit but it does nothing - what am i doing wrong ?

    Whatever i do I cannot get into port 901 !!

    please someone give me clue for eternal gratitude !

  2. #2

    Re:SWAT Connection to refused

    Swat is disabled by default you have to enable it. As the root user.

    Open the file /etc/xinetd.d/swat

    change the line "disable = yes" to "disable=no"

    or you could just use some command line trickery ;D

    cd /etc/xinetd.d
    cat swat | sed '/disable/s/yes/no/' > swat

    Then restart xinetd: /sbin/service xinetd restart

    Jim H

  3. #3

    Re:SWAT Connection to refused

    yes - checked that before - though the swat file lists
    but i cannot find that one at all - or anything similar
    most grateful for you help - any more clues ?


  4. #4

    Re:SWAT Connection to refused

    Are you using the Red Hat provided swat rpms?

    Jim H

  5. #5

    Re:SWAT Connection to refused

    installed 7.1 from cd's - it installed samba common with no swat at all - downloaded samba-swat-2.2.1a-4.i386.rpm from redhat and installed - i have some swat files now but i cannot be sure they are all installed

    i also cannot run lokkit - it seems to run but makes no changes - not sure of the significance here though - could be vital if a firewall is stopping it !

  6. #6

    Re:SWAT Connection to refused

    Post your /etc/xinetd.d/swat file.

    This almost sounds like it might be a bug in /etc/xinetd.d/swat.

    Try this and look where the swat executable is installed. Edit your /etc/xinetd.d/swat as necessary.

    rpm -ql samba-swat | grep bin

    Don't forget to restart xinetd

    The firewall will not block the lookback interface by default. I doubt this is the problem.

    see if the firewall is enabled.
    service ipchains status


    ipchains -nL

    Jim H

  7. #7

    Re:SWAT Connection to refused

    ## /etc/xinetd.d/swat
    service swat
    disable= no
    port = 901
    socket type = stream
    wait = no
    only_from =
    user = root
    server = /usr/local/samba/bin/swat
    log_on_failure += USERID
    note the server line is invalid but i do not know where to point it !
    the rpm -ql line ran as follows:
    then three lines of /usr.share/swat/help/xxxxxx
    (i assume the html files are of little interest)
    have resetarted xinetd -still refused connection

    ipchains suggestion yielded:
    Chain input (policy ACCEPT):
    ditto for forward and output

    thanks again

  8. #8

    Re:SWAT Connection to refused

    read it wrong on the rpm -ql line

  9. #9

    Re:SWAT Connection to refused

    Quote Originally Posted by boxers
    This is the swat executable. So

    server = /usr/local/samba/bin/swat

    should be

    server = /usr/sbin/swat

    Jim H

  10. #10

    Re:SWAT Connection to refused

    i spotted that one - changed it accordingly, restarted xinetd and smb - and guess what !! conection refused
    interesting isn't it !

Similar Threads

  1. Unable to configure the DNS in RHEL6-- Getting an error status - REFUSED
    By ranjithraj in forum Linux - General Topics
    Replies: 0
    Last Post: 08-28-2013, 02:11 PM
  2. Replies: 0
    Last Post: 12-06-2007, 04:52 PM
  3. The connection was refused when attempting to contact localh
    By budhead in forum Linux - Software, Applications & Programming
    Replies: 2
    Last Post: 01-04-2005, 08:02 PM
  4. vsftpd connection refused!!
    By rhonneil in forum Linux - Hardware, Networking & Security
    Replies: 16
    Last Post: 10-03-2003, 04:03 PM
  5. Connection refused to port 25
    By asaf in forum Linux - General Topics
    Replies: 6
    Last Post: 07-12-2002, 09:51 PM


Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts