Results 1 to 4 of 4

Thread: PCMCIA nic on peanut linux

  1. #1

    PCMCIA nic on peanut linux

    Problem: Configuring a PCMCIA nic using peanut linux install 2.4.19 on Winbook XL Laptop with a
    Xircom PCMCIA Card (spec's below). On install, Kudzu does not recognize a NIC. Under the
    Networkcard Install feature, the PCMCIA card configuration tool does not register any errors but the
    Control Center on the Peanut desktop does not recognize that a PCMCIA card is present. LISa dameon error message: "No network interface card was found on your system."

    1. I have tried the following terminal commands:

    2. #autonic indicates "networking card using the com20020.0 module has been detected."

    3.#modprobe -l | more displays the library modules including,
    "lib/modules/2.4.19/kernel/drivers/net carnet/xirc2ps_cs"

    4. #ifconfig eth0 generates error message: "eth0: error fetching inteface information: Device not found"

    5. #lspci -v does not list a Xircom or a generic equivalent of a PCMCIA Nic.

    6. #/sbin/modprobe pcmcia_core #(Responds Error Message: "Can't locate module core")
    #/sbin/modprobe xirc2ps_cs # doesn't help either.

    7. dmesg > output.txt
    Linux version 2.4.19 (root@Peanut-Linux) (gcc version 2.95.3 20010315 (release)) #1 Fri Mar 8 20:57:26 UTC 2002
    BIOS-provided physical RAM map:
    BIOS-e820: 0000000000000000 - 000000000009fc00 (usable)
    BIOS-e820: 000000000009fc00 - 00000000000a0000 (reserved)
    BIOS-e820: 00000000000e0000 - 0000000000100000 (reserved)
    BIOS-e820: 0000000000100000 - 0000000004000000 (usable)
    BIOS-e820: 00000000fec00000 - 00000000fec01000 (reserved)
    BIOS-e820: 00000000fee00000 - 00000000fee01000 (reserved)
    BIOS-e820: 00000000fffe0000 - 0000000100000000 (reserved)
    On node 0 totalpages: 16384
    zone(0): 4096 pages.
    zone(1): 12288 pages.
    zone(2): 0 pages.
    No local APIC present or hardware disabled
    Kernel command line: BOOT_IMAGE=Linux ro root=303
    Initializing CPU#0
    Detected 267.277 MHz processor.
    Console: colour VGA+ 80x25
    Calibrating delay loop... 532.48 BogoMIPS
    Memory: 60832k/65536k available (2014k kernel code, 4316k reserved, 784k data, 308k init, 0k highmem)
    Dentry-cache hash table entries: 8192 (order: 4, 65536 bytes)
    Inode-cache hash table entries: 4096 (order: 3, 32768 bytes)
    Mount-cache hash table entries: 1024 (order: 1, 8192 bytes)
    Buffer-cache hash table entries: 4096 (order: 2, 16384 bytes)
    Page-cache hash table entries: 16384 (order: 4, 65536 bytes)
    CPU: Before vendor init, caps: 008001bf 00000000 00000000, vendor = 0
    Intel Pentium with F0 0F bug - workaround enabled.
    CPU: After vendor init, caps: 008001bf 00000000 00000000 00000000
    CPU: After generic, caps: 008001bf 00000000 00000000 00000000
    CPU: Common caps: 008001bf 00000000 00000000 00000000
    CPU: Intel Mobile Pentium MMX stepping 01
    Checking 'hlt' instruction... OK.
    POSIX conformance testing by UNIFIX
    mtrr: v1.40 (20010327) Richard Gooch (
    mtrr: detected mtrr type: none
    PCI: PCI BIOS revision 2.10 entry at 0xfdba1, last bus=0
    PCI: Using configuration type 1
    PCI: Probing PCI hardware
    PCI: Using IRQ router PIIX [8086/7110] at 00:01.0
    Limiting direct PCI/PCI transfers.
    isapnp: Scanning for PnP cards...
    isapnp: No Plug & Play device found
    PnPBIOS: Found PnP BIOS installation structure at 0xc00f6570
    PnPBIOS: PnP BIOS version 1.0, entry 0xf0000:0x5efe, dseg 0x400
    PnPBIOS: 17 nodes reported by PnP BIOS; 17 recorded by driver
    Linux NET4.0 for Linux 2.4
    Based upon Swansea University Computer Society NET3.039
    Initializing RT netlink socket
    apm: BIOS version 1.2 Flags 0x03 (Driver version 1.16)
    Starting kswapd
    VFS: Diskquotas version dquot_6.5.0 initialized
    Journalled Block Device driver loaded
    NTFS driver v1.1.22 [Flags: R/W]
    parport0: PC-style at 0x378 [PCSPP,TRISTATE]
    pty: 1024 Unix98 ptys configured
    block: 112 slots per queue, batch=28
    RAMDISK driver initialized: 16 RAM disks of 8192K size 1024 blocksize
    Uniform Multi-Platform E-IDE driver Revision: 6.31
    ide: Assuming 33MHz system bus speed for PIO modes; override with idebus=xx
    PIIX4: IDE controller on PCI bus 00 dev 09
    PIIX4: chipset revision 1
    PIIX4: not 100% native mode: will probe irqs later
    ide0: BM-DMA at 0xffa0-0xffa7, BIOS settings: hdaMA, hdbio
    hda: IC25N020ATCS04-0, ATA DISK drive
    hdb: TOSHIBA CD-ROM XM-1602B, ATAPI CD/DVD-ROM drive
    ide0 at 0x1f0-0x1f7,0x3f6 on irq 14
    hda: 39070080 sectors (20004 MB) w/1768KiB Cache, CHS=2432/255/63, UDMA(33)
    hdb: ATAPI 20X CD-ROM drive, 128kB Cache
    Uniform CD-ROM driver Revision: 3.12
    ide-floppy driver 0.99.newide
    Partition check:
    hda: hda1 hda2 < hda5 > hda3
    Floppy drive(s): fd0 is 1.44M
    FDC 0 is a National Semiconductor PC87306
    loop: loaded (max 8 devices)
    Linux agpgart interface v0.99 (c) Jeff Hartmann
    agpgart: Maximum main memory to use for agp memory: 28M
    agpgart: no supported devices found.
    Cronyx Ltd, Synchronous PPP and CISCO HDLC (c) 1994
    Linux port (c) 1998 Building Number Three Ltd & Jan "Yenya" Kasprzak.
    ide-floppy driver 0.99.newide
    SCSI subsystem driver Revision: 1.00
    Loading Adaptec I2O RAID: Version 2.4 Build 5
    Detecting Adaptec I2O RAID controllers...
    scsi: <fdomain> Detection failed (no card)
    NCR53c406a: no available ports found
    sym53c416.c: Version 1.0.0-ac
    Failed initialization of WD-7000 SCSI card!
    IBM MCA SCSI: Version 4.0b
    IBM MCA SCSI: No Microchannel-bus present --> Aborting.
    This machine does not have any IBM MCA-bus
    or the MCA-Kernel-support is not enabled!
    DC390: 0 adapters found
    scsi0 : SCSI host adapter emulation for IDE ATAPI devices
    ppa: Version 2.07 (for Linux 2.4.x)
    WARNING - no ppa compatible devices found.
    As of 31/Aug/1998 Iomega started shipping parallel
    port ZIP drives with a different interface which is
    supported by the imm (ZIP Plus) driver. If the
    cable is marked with "AutoDetect", this is what has
    imm: Version 2.05 (for Linux 2.4.0)
    pci_hotplug: PCI Hot Plug PCI Core version: 0.4
    IEEE 802.2 LLC for Linux 2.1 (c) 1996 Tim Alpaerts
    NET4: Linux TCP/IP 1.0 for NET4.0
    IP Protocols: ICMP, UDP, TCP, IGMP
    IP: routing cache hash table of 512 buckets, 4Kbytes
    TCP: Hash tables configured (established 4096 bind 4096)
    Linux IP multicast router 0.06 plus PIM-SM
    NET4: Unix domain sockets 1.0/SMP for Linux NET4.0.
    NET4: AppleTalk 0.18a for Linux NET4.0
    FAT: bogus logical sector size 5632
    UMSDOS: msdos_read_super failed, mount aborted.
    FAT: bogus logical sector size 5632
    FAT: bogus logical sector size 5632
    reiserfs: checking transaction log (device 03:03) ...
    Using r5 hash to sort names
    reiserfs: using 3.5.x disk format
    ReiserFS version 3.6.25
    VFS: Mounted root (reiserfs filesystem) readonly.
    Freeing unused kernel memory: 308k freed
    Adding Swap: 128484k swap-space (priority -1)
    Real Time Clock Driver v1.10e
    lp0: using parport0 (polling).
    lp0: console ready
    arcnet: v3.93 BETA 2000/04/29 - by Avery Pennarun et al.
    arcnet: COM20020 chipset support (by David Woodhouse et al.)
    ip_conntrack (512 buckets, 4096 max)
    usb.c: registered new driver usbdevfs
    usb.c: registered new driver hub
    Serial driver version 5.05c (2001-07-08) with MANY_PORTS SHARE_IRQ SERIAL_PCI ISAPNP enabled
    ttyS00 at 0x03f8 (irq = 4) is a 16550A
    ttyS02 at 0x03e8 (irq = 4) is a 16550A
    ehci-hcd.c: $Revision: 1.1 $ USB 2.0 'Enhanced' Host Controller (EHCI) Driver
    ehci-hcd.c: block sizes: qh 96 qtd 96 itd 192 sitd 64
    usb-uhci.c: $Revision: 1.275 $ time 12:21:51 Mar 8 2002
    usb-uhci.c: High bandwidth mode enabled
    PCI: Found IRQ 11 for device 00:01.2
    usb-uhci.c: USB UHCI at I/O 0xef80, IRQ 11
    usb-uhci.c: Detected 2 ports
    usb.c: new USB bus registered, assigned bus number 1
    hub.c: USB hub found
    hub.c: 2 ports detected
    usb-uhci.c: v1.275:USB Universal Host Controller Interface driver
    Linux video capture interface: v1.00
    ad1848/cs4248 codec driver Copyright (C) by Hannu Savolainen 1993-1996
    ad1848: No ISAPnP cards found, trying standard ones...
    opl3sa2: No PnP cards found
    opl3sa2: Search for a card at 0x880.
    opl3sa2: chipset version = 0x3
    opl3sa2: Found OPL3-SA3 (YMF715B or YMF719B)
    <OPL3-SA3> at 0x370 irq 5 dma 0,0
    <MS Sound System (CS4231)> at 0x534 irq 5 dma 0,0
    <MPU-401 0.0 Midi interface #1> at 0x330 irq 5 dma -1,0
    opl3sa2: Control I/O port 0x370 not free
    opl3sa2: There was a problem probing one of the ISA PNP cards, continuing
    opl3sa2: Control I/O port 0x370 not free
    opl3sa2: There was a problem probing one of the ISA PNP cards, continuing
    opl3sa2: Control I/O port 0x370 not free
    opl3sa2: There was a problem probing one of the ISA PNP cards, continuing
    VFS: Disk change detected on device fd(2,0)
    UMSDOS 0.86k (compatibility level 0.4, fast msdos)


    PCMICIA CARD: Xircom 10/100 XE2000
    PROCESSOR: Intel Pentium w/MMX 266
    MEMORY: 128MB, EDO 60ns, 144-pin SODIMMs
    CACHE: Synchronous, pipeline burst, 256k
    MECHANICAL LAYOUT, Device Bays: "Three spindle" design, CD-ROM, FDD and HDD are
    simultaneously available
    Chip Set: Intel Mobile Triton II, 430TX
    Display Chipset: Chips & Technologies 65554
    Memory Type: EDO
    Memory Size: 2 MB
    Bus: PCI
    Maximum Color Depth/Resolution-
    External Monitor: 16.7 Million colors/800x600, LCD, 13.1" TFT, Resolution: 800x600 r
    1024x768, Depth:
    HARD DRIVE: 20 GB Western Digital (replacement)
    PS/2: 1 mini-DIN 6-pin, keyboard or mouse
    Chip Set: TI PCI 1131
    Slots: 2 Type II or 1 Type III
    CardBus: Both sockets
    ZoomVideo: Lower socket only
    # Keys: 84
    Windows 95 Keys: Yes
    Suspend to RAM?: Yes
    Suspend to Disk?: Yes
    Pointing Device: 2-button Touchpad

  2. #2

    Re:PCMCIA nic on peanut linux

    i just enabled PCMCIA serices on my Winbook Laptop as detailed below. My new problem is that my mouse is IRQ 12.
    it worked fine until i enabled PCMCIA services. Now, when i issue the startx command, the desktop loads beautifully but the keyboard and mouse are locked up.

    i suspect that this is because PCMCIA services (i82365) is on IRQ 12 and my mouse is not shown. Can anyone help me relocate the PCMCIA services to another IRQ? I've tried moving the IRQ of the PCMCIA card. It was originally configured for 3, but I uncommented some options in the edit /etc/pcmcia/*.opts file and it now safely resides at 10. ismod i83265 type commands generate an error message: "the file already exists."

    I wonder if this is a BIOS issue. Can someone describe to me what the various BIOS options for an AMI board for a Winbook XL that might help resolve this problem. I have heard that this only necessary to enable a special interface for running old 16 bit MS-DOS drivers. This is a dual boot machine (Win95) and wonder if disabling the PNP bios option (if i can find it) will affect the Win95 stuff.

    ************************************************** **********
    HERE ARE MY IRQ's AFTER I STARTED THE PCMCIA SERVICES (since then if have moved the PCMCIA car to 10)
    cat /proc/interrupts > output.txt
    0: 42986 XT-PIC timer
    1: 190 XT-PIC keyboard
    2: 0 XT-PIC cascade
    3: 93 XT-PIC xirc2ps_cs
    8: 1 XT-PIC rtc
    11: 0 XT-PIC usb-uhci
    12: 4 XT-PIC i82365
    14: 4156 XT-PIC ide0
    NMI: 0
    LOC: 0
    ERR: 0
    ************************************************** **********
    I have initialized the PCMCIA and the Xircom card is apparently recognized
    and configured. Unfortunately, it may have created an IRQ conflict. When I
    start an X session, my mouse and keyboard lock up. I need help trouble
    shooting this.

    The details of the PCMCIA fix follow:

    Peanut linux comes with PCMCIA commented out. You need to:

    1. Open a terminal as root and edit by typing as root "vi /etc/rc.d/rc.S"

    2. use the arrow keys to scroll down to the "# Inititialize PCMCIA devices"

    3. place the cursor on the "#" on the three lines below that appear like this
    and delete the "#".
    # if [ -x /etc/rc.d/rc.pcmcia ]; then
    # . /etc/rc.d/rc.pcmcia start
    # fi

    4. the lines should now read:
    if [ -x /etc/rc.d/rc.pcmcia ]; then
    . /etc/rc.d/rc.pcmcia start

    5. Type ":wq" and hit the Return key. If you are unsure that you have made
    the right choices, leave the file without saving by typing ":q!" and hit the
    return key.

    6. When the file is correctly configured save and reboot. The card should be recognized with a two beep audible signal.

  3. #3

    Re:PCMCIA nic on peanut linux

    I don't know Peanut Linux, but hopefully you'll have something similar to Redhat or Mandrake. In those systems, there's a config file under /etc/pcmcia that has sections pertaining to which IRQs are paged for the cardbus and cards. I don't remember offhand which file it is(config.opts perhaps?), sorry - my laptop is in the process of being rebuilt at the moment. If you can find that particular file, you should be able to comment out the offending IRQ and then it shouldn't be an option to be assigned to the card.

  4. #4

    Re:PCMCIA nic on peanut linux

    Here is some additional information on the problem I am having with the NIC /PSAUX conflict.

    The Peanut install went great and detected "some kind of ps-2/psaux. startx
    works great and the gui interface works perfectly. The problem occurs when I
    enable the PCMCIA nic. Peanut disables PCMCIA services until after the install.
    When I edit the /etc/rc.d/rc.S to allow detection of the PCMCIA,
    the nic is probed (two beeps) and configured. The NIC can be pinged from another machine.
    Unfortunately, after PCMCIA starts, the graphical interface will load and lock up (both
    the keyboard and mouse). I am pretty sure that the PCMCIA
    controller (i82365) knocks the mouse out of its IRQ 12 (the Xircom
    nic steals the Floppy IRQ as well).

    I am pretty sure I can fix the NIC/floppy conflict by editing the edit
    /etc/pcmcia/*.opts file. I don't know how to fix the controller
    issue. I have tried to move the mouse / serial port using setserial
    -a /dev/tty0 but only get "Input/Output Error."
    pnpdmp -c generates a series of output like, # Trying port address
    027b, # Trying port address 0283, # Trying port address 028b" and
    concludes with the message "# No boards found."


    Cat /proc/interrupts

    0: 683318 XT-PIC timer
    1: 5263 XT-PIC keyboard
    2: 0 XT-PIC cascade
    6: 49 XT-PIC floppy
    8: 1 XT-PIC rtc
    11: 0 XT-PIC usb-uhci
    12: 11802 XT-PIC PS/2 Mouse
    14: 15199 XT-PIC ide0
    NMI: 0
    LOC: 0
    ERR: 0

    0: 23202 XT-PIC timer
    1: 313 XT-PIC keyboard
    2: 0 XT-PIC cascade
    3: 4 XT-PIC xirc2ps_cs
    8: 1 XT-PIC rtc
    11: 0 XT-PIC usb-uhci
    12: 4 XT-PIC i82365
    14: 13045 XT-PIC ide0
    NMI: 0
    LOC: 0
    ERR: 0

Similar Threads

  1. Peanut Linux
    By Gruntled in forum Linux - General Topics
    Replies: 10
    Last Post: 06-27-2004, 09:39 AM
  2. WIreless setup on Linux (PCMCIA & USB)
    By Kernel_Killer in forum Linux - General Topics
    Replies: 0
    Last Post: 10-08-2003, 12:29 AM
  3. Linksys pcmcia card in linux
    By pinehead in forum Linux - General Topics
    Replies: 2
    Last Post: 05-28-2003, 03:41 AM
  4. Installing Peanut Linux...
    By irox in forum Linux - General Topics
    Replies: 3
    Last Post: 01-12-2002, 09:32 AM
  5. Peanut.....
    By ericn in forum Linux - General Topics
    Replies: 12
    Last Post: 01-08-2002, 01:01 AM


Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts