Hello folks, I'm new around here so I'll start with some background before jumping right into my problem.

I've been using windows for years, and I work as a freelance web developer (read: unemployed!) so I do know my way around a computer all right. I've gotten caught up in the open-source hype, and have decided that Linux is for me. I am real sick of windows crashing on me three times a day!

So anyway, I bought a new 40Gig hard drive which I intend to use solely for linux, retaining C: drive for windows (and the technologically impaired people in my household!) Thus begins my saga:

Attempt to install 1:
Finally got the disk images, and installed on my D: drive which I put in especially for Linux. Installed LiLO in the boot sector on drive C: (windows 95). Made a boot disk, and rebooted. LiLo didn't work, just froze during bios with "LiL" prompt. Couldn't type anything, and neither os would boot. Tried the Linux boot floppy, told me it is not bootable media. Tried the windows boot floppy. It started win 95 in dos mode, but I couldn't navi to C: drive. Checked fdisk, told me C: was no longer a dos drive. tried restoring master boot record. No deal. So I reinstalled windows.

Attempt to install 2:
My disk images (and my first install for that matter) were luckily still untouched on my D: drive. Reinstalled anyway. Made boot disk, didn't install harddisk boot loader this time, and rebooted. The boot disk got about halfway through loading the kernal then stopped and said "boot failed". Tried using the original "install" boot disk and point to the hard drive install using: "root= /dev/hdc3" but linux said it couldn't find the kernal. tried using fdisk to make sure that kernal is in "/dev/hdc3" which is where the root partition was supposed to be installed, but fdisk wouldn't fire up.

This is where I am stuck now.If anyone has some ideas of what to do, I could use the help before I tear all my hair out. Sorry for the verbosity. PS: I installed redhat 7.3 workstation.

thanks in advance. . .

Darren