Warning: Function ereg() is deprecated in ..../includes/class_postbit.php(345) : eval()'d code on line 4

Warning: Function split() is deprecated in ..../includes/class_postbit.php(345) : eval()'d code on line 19

Warning: Function ereg() is deprecated in ..../includes/class_postbit.php(345) : eval()'d code on line 4

Warning: Function split() is deprecated in ..../includes/class_postbit.php(345) : eval()'d code on line 19

Warning: Function ereg() is deprecated in ..../includes/class_postbit.php(345) : eval()'d code on line 4

Warning: Function split() is deprecated in ..../includes/class_postbit.php(345) : eval()'d code on line 19

Warning: Function ereg() is deprecated in ..../includes/class_postbit.php(345) : eval()'d code on line 4

Warning: Function split() is deprecated in ..../includes/class_postbit.php(345) : eval()'d code on line 19

Warning: Function ereg() is deprecated in ..../includes/class_postbit.php(345) : eval()'d code on line 4

Warning: Function split() is deprecated in ..../includes/class_postbit.php(345) : eval()'d code on line 19

Warning: Function ereg() is deprecated in ..../includes/class_postbit.php(345) : eval()'d code on line 4

Warning: Function split() is deprecated in ..../includes/class_postbit.php(345) : eval()'d code on line 19
ppp-2.4.1 errors!!
Results 1 to 6 of 6

Thread: ppp-2.4.1 errors!!

  1. #1
    Toast0r
    Guest

    ppp-2.4.1 errors!!

    :-*I'm useing OpenLinux 2.2. I'm running kernels 2.2.5 and 2.4.18 though ppp does not work with 2.4, so now im on 2.2 and trying to update ppp but im getting dirty little street corner whore errors. The following is the errors im getting:

    when i type 'make':

    auth.o: In function 'check_passwd':
    auth.c: 973: Undefined reference to': 'crypt'
    auth.o In function 'plogin':
    auth.c: 1174: Undefined reference to 'crypt'
    chap_ms.o: In function 'DesEncrypt':
    chap_ms.c: 128: Undefined reference to': 'setkey'
    chap_ms.c: 135: Undefined reference to': 'encrypt'
    make[1]: *** [pppd] error 1
    make[1]: Leave dir '/root/ppp-2.4.1/pppd'
    make[1]: *** [all] Error 2

    Hmm i read other forums with similar problems like this though they were older versions of ppp and they had a option in Makefile to uncomment a string if your getting 'crypt' errors. Though ppp-2.4.1 dosnt for some odd reason, maybe they think they fixed it? I added the extra line to see if it would work and no luck.

    I have Gnu make version 3.77. Any suggestions?!

  2. #2
    JimH
    Guest

    Re:ppp-2.4.1 errors!!

    You don't have something installed or have too old a version of something that is required to compile the newer version of ppp. I will have to look at the source code for ppp2.4.1 to know exactly what you are missing.

    Jim H

  3. #3
    Toast0r
    Guest

    Re:ppp-2.4.1 errors!!

    Thanks!

  4. #4
    JimH
    Guest

    Re:ppp-2.4.1 errors!!

    Can you post a few more lines from when you type make. I want to see a few lines above what you posted.

    What version of glibc does OpenLinux 2.2 use?

    Do you have the file: /usr/include/crypt.h

    Do you have these:

    /usr/lib/libcrypt.a
    /usr/lib/libcrypt.so

    Are they on your system at all, but maybe in a different directory?

    Jim H

  5. #5
    Toast0r
    Guest

    Re:ppp-2.4.1 errors!!

    #make

    cd chat; make all
    make[1]: Entering directory `/root/ppp-2.4.1/chat'
    make[1]: Nothing to be done for `all'.
    make[1]: Leaving directory `/root/ppp-2.4.1/chat'
    cd pppd; make all
    make[1]: Entering directory `/root/ppp-2.4.1/pppd'
    cc -O2 -pipe -Wall -g -D_linux_=1 -DHAVE_PATHS_H -DIPX_CHANGE -DHAVE_MULTILINK
    -DHAVE_MMAP -I../include -DCHAPMS=1 -DUSE_CRYPT=1 -DHAVE_CRYPT_H=1 -DHAS_SHADOW
    -DPLUGIN -Wl,-E -o pppd main.o magic.o fsm.o lcp.o ipcp.o upap.o chap.o md5.o
    ccp.o auth.o options.o demand.o utils.o sys-linux.o ipxcp.o multilink.o tdb.o
    tty.o md4.o chap_ms.o -ldl
    make[1]: Leaving directory `/root/ppp-2.4.1/pppd'

    (Then errors listed)

    Nope I don't have libcrypt.a or libcrypt.so . I do have /usr/include/crypt.h. I believe i have glibc 2.1, what exactly is glibc used for? It wasnt a command 'glibc' so i just did a 'locate glibc' and found some glibc-2.1 files. Most of them were in /usr/doc/.

  6. #6
    JimH
    Guest

    Re:ppp-2.4.1 errors!!

    Quote Originally Posted by Toast0r
    I believe i have glibc 2.1, what exactly is glibc used for? It wasnt a command 'glibc' so i just did a 'locate glibc' and found some glibc-2.1 files. Most of them were in /usr/doc/.
    glibc contains the libraries your system and programs require to run.

    I'm going to take a wild guess and suggest that the version of glibc that is included on your system wasn't compiled with the glibc-crypt addon. Prior to glibc 2.2 glibc-crypt wasn't included with glibc by default.

    Jim H

Similar Threads

  1. Memory errors with XP Pro
    By in forum Windows - General Topics
    Replies: 18
    Last Post: 04-15-2004, 10:02 PM
  2. Errors after killing X
    By trickster in forum Linux - General Topics
    Replies: 1
    Last Post: 05-20-2003, 11:28 PM
  3. 404 Errors
    By trickster in forum General Chat
    Replies: 8
    Last Post: 02-17-2003, 01:08 AM
  4. FAH errors
    By mcdougrs in forum Linux - Software, Applications & Programming
    Replies: 5
    Last Post: 09-07-2002, 05:47 AM
  5. How am I doing and what are these PAM errors?
    By Rastar in forum Linux - Software, Applications & Programming
    Replies: 2
    Last Post: 03-16-2002, 06:17 AM

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •