Results 1 to 4 of 4

Thread: New problem. Not sure if modem or what?

  1. #1
    DrakeCode
    Guest

    New problem. Not sure if modem or what?

    Ok. I'm making progress. I posted the other topic about my external modem hanging once it gets to the initialization phaze. I figured out that there was just something wrong with that modem so I went out and bought a new external modem. It's just a compusa 56k V.92 modem.

    I initially hooked it up to test it while logged in as root. kppp immediately found the modem on a query and using the terminal button on the modem tab I could send commands to the modem to dial out or initialize or whatever. When I try to connect with kppp it still hangs at the initialization phaze.

    So I then try to use gnome gppp(or whatever it's called). It dials out and even connects but within 30 seconds after connecting I get a message that says the pppd daeman has died. It happens every single time.

    So I tried logging in as a regular user instead of as root. kppp acts exactly the same way but gppp won't even attempt to dial out. Instead it immediately gives me the message the the pppd has died unexpectedly.

    Does anyone have any clues as to what I'm doing wrong? Just because the modem connects it doesn't mean that my ISP let's me on does it? I've heard that you have know what authentication an ISP uses(ie PAP, CHAP, etc.). I connect through msn so does anyone else out there connect through them? If so, could you tell me how you have your settings?

    I would greatly appreciate any help with this. I am getting closer and I can almost smell the internet when I'm in linux but for now I'm forced to surf the web through windoze.

    Thanx,
    DrakeCode :P

  2. #2
    JimH
    Guest

    Re:New problem. Not sure if modem or what?

    Look in /var/log/messages and/or set debug to yes in kppp so it provides you with more details on what is happening. Post the messages it shows you.

    Jim H

  3. #3
    DrakeCode
    Guest

    Re:New problem. Not sure if modem or what?

    ;D
    Ok, I'm extremely close to getting this whole thing figure out. Actually, I'm on the internet right now through linux but I have to be logged on as root to do it. Here are my problems.

    When logged on as a regular user gnome ppp doesn't even attempt to dial out but instead gives me the error 'pppd daemon died unexpectedly'. kppp, as a regular user, still only gets as far as initialization of the modem before it hangs.

    Now, as root using gnome ppp it dials, it connects but then a few seconds later it dies with the error message, 'pppd died unexpectedly'. Now in kppp it was hanging at modem initialization until I tried something. It turns out that pppd wasn't starting for kppp so, since I was root, I started it with this command
    pppd /dev/modem 115200
    then I tried to connect through kppp. kppp then dialed and connected. So I then tried to log on as a regular user again and start pppd. It won't let me start pppd as a regular user.

    So, I think at this point my problems are because pppd isn't starting correctly for gnome ppp and it isn't starting at all for kppp. How do I make it so that either as root or as a regular user it starts automatically when I try to dial out?

    Thanx a lot everyone for all your feedback for my many many problems I've had so far. I appreciate it.

    DrakeCode

  4. #4

    Re:New problem. Not sure if modem or what?

    what does /sbin/ifconfig output?
    there should be a section for 'lo' and one for 'ppp0'
    if, not, then the ppp settings are not configured properly
    whatdoyougetwhenyoumultiplysixbynine??

Similar Threads

  1. Problem with my USB modem
    By ubunfan in forum Linux - General Topics
    Replies: 1
    Last Post: 03-10-2011, 08:07 PM
  2. problem with modem
    By 2sundar in forum Linux - General Topics
    Replies: 1
    Last Post: 03-13-2005, 09:56 PM
  3. USR5610b PCI modem problem in gentoo
    By sum0_saliva in forum Linux - Hardware, Networking & Security
    Replies: 1
    Last Post: 07-16-2004, 11:12 PM
  4. Problem with US Robtics Modem & Fedora
    By RickJ in forum Linux - General Topics
    Replies: 1
    Last Post: 03-18-2004, 02:35 PM
  5. Got a new modem
    By Digital_Froggy in forum Linux - General Topics
    Replies: 2
    Last Post: 01-12-2002, 05:31 AM

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •