Results 1 to 2 of 2

Thread: External modem hangs when initializing

  1. #1
    DrakeCode
    Guest

    External modem hangs when initializing

    Hello. I have mandrake 8.0 installed on a dual boot system with windows xp. I also have an external creative labs modem blaster 56K that I know works with linux because I used to have it connected to a laptop with mandrake 8.0 on it and I could browse the net through that modem. When the laptop gave up the ghost I decided to install everything on my desktop system. I figured it'd be a simple connect the modem, set up my ISP and start browsing but I was wrong.

    What's happening is in kppp I select /dev/ttyS0 for my modem port in the Device tab. I then go to the Modem tab and click on Query Modem. It evidently finds something because it says that it's initializing the modem and all the lights on the modem go on but all of the ATI strings that are returned from this query are blank. Also, if I go into the terminal button on the Modem tab it says that it initializes the modem(once again the lights go on) but then it won't let me do anything. It won't let me send any commands to the modem.

    Then I try to connect and it gets as far as initializing modem and it just sits there. I've tried several things already but nothig seems to work. I've looked at the output of 'setserial -g /dev/ttyS0' and everything there appears fine. I've also gone into minicom. When I go into minicom I can type in modem commands but nothing happens when I type them in and press Enter. Also, when in minicom if I try to dial out it tells me that I need to hang up the current connection first but it never dialed out in the first place. Also, to make sure that it never dialed out and hooked up to the net I unplugged the phone cable from the modem and it still says that I need to hang up the current connection.

    No matter what I do this modem doen't seem to want to work now even though it did when connected to the laptop. Does anyone have any ideas? I'm completely stumped, which, granted doesn't take much since I'm still a newbie with linux.

    Any help would be greatly appreciated.

    Thanx,
    DrakeCode

  2. #2
    DrakeCode
    Guest

    Re:External modem hangs when initializing

    Here is an update on my situation. I think that something is wrong with my external modem. I decided to see if the modem even worked so I booted up windows xp and went to creative labs site to see if they had any xp drivers for my modem which is an external creative labs modem blaster 56K. They don't have any xp drivers for my exact model number of modem so I decided just to try windows generic drivers. It installed fine but when I had windows try to query the modem it couldn't get to it even though the lights on the modem lit up just like in linux. So I've come to the conclusion that I either need to get a different modem or I need to figure out how to compile and install the stupid pctel linmodem drivers I got from linmodems.org.

    My normal windows modem is a pctel winmodem with chipset pct789 and according to linmodems.org I should be able to compile and install the driver they have for it but I can't seem to get everything to work right. As far as I can tell, everything compiled ok with one exception. The directions say that after doing the "make install" command all I should have to do is insert the modules into the kernel. Well, the first module is supposed to be pctel.o but it didn't get created and when I insert the second module which is ptserial.o I get all sorts of unresolved symbols.

    Anyone have any ideas either on what I might be doing wrong with the linmodem drivers or on a good but fairly cheap modem that I can buy that works with linux?

    Thanx,
    DrakeCode

Similar Threads

  1. EXTERNAL USB MODEM for LINUX
    By tolstoi in forum Linux - Hardware, Networking & Security
    Replies: 1
    Last Post: 11-30-2004, 02:27 AM
  2. external modem
    By cybergal in forum General Chat
    Replies: 0
    Last Post: 08-19-2004, 07:13 PM
  3. Initializing Modem
    By stryder144 in forum Linux - Hardware, Networking & Security
    Replies: 4
    Last Post: 09-04-2002, 05:38 PM
  4. Boca Tidalwave External Modem
    By gfunkmonk in forum Linux - Hardware, Networking & Security
    Replies: 3
    Last Post: 08-19-2002, 02:05 PM
  5. Actiontec USB external Modem
    By Luca in forum Linux - Hardware, Networking & Security
    Replies: 1
    Last Post: 04-23-2002, 03:03 PM

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •