Hi all,

I'm a newbie to linux. I use SUSE 8.0. I have to investigate the possibility to replace MS exchange server with a linux alternative. I found a howto (postfix-cyrus-Web-cyradmin-howto on http://www.delouw.ch/linux) which needs apache with php for the graphic interface. I downloaded the apache compile howto from the same site) and was following it. All went well untill I had to run make to install apache...

It gave the error:
...
gcc -DLINUX=22 -I/usr/include/db1 -DMOD_SSL=208108 -DMOD_PERL -DUSE_PERL_SSI -fno-strict-aliasing -D_LARGEFILE_SOURCE -D_FILE_OFFSET_BITS=64 -DUSE_HSREGEX -DEAPI -DEAPI_MM -DUSE_EXPAT -I../lib/expat-lite `../apaci` -L/usr/local/mm-1.1.3/.libs -o gen_test_char gen_test_char.o -lm -lcrypt -ldb1 -rdynamic -Wl,-rpath,/usr/lib/perl5/5.6.1/i586-linux/CORE /usr/lib/perl5/5.6.1/i586-linux/auto/DynaLoader/DynaLoader.a -L/usr/lib/perl5/5.6.1/i586-linux/CORE -lperl -lnsl -ldl -lm -lc -lcrypt -lutil -lmm -ldl
./gen_test_char >test_char.h
./gen_test_char: error while loading shared libraries: libmm.so.11: cannot open shared object file: No such file or directory
make[3]: *** [test_char.h] Error 127
make[2]: *** [subdirs] Error 1
make[2]: Leaving directory `/usr/local/apache_1.3.24/src'
make[1]: *** [build-std] Error 2
make[1]: Leaving directory `/usr/local/apache_1.3.24'
make: *** [build] Error 2

As far as I can read what is says is that it can't find the file libmm.so.11. When I run whereis libmm.so.11 I get /usr/local/lib/libmm.so.11 and I found the file also in /usr/local/mm-1.1.3/.libs
I ran configure as mentioned in the howto with:
EAPI_MM="/usr/local/mm-1.1.3" SSL_BASE="/usr/local/ssl" \
./configure \
--enable-module=unique_id \
--enable-module=rewrite \
--enable-module=speling \
--enable-module=expires \
--enable-module=info \
--enable-module=log_agent \
--enable-module=log_referer \
--enable-module=usertrack \
--enable-module=proxy \
--enable-module=userdir \
--enable-module=so \
--enable-shared=ssl \
--enable-module=ssl \
--activate-module=src/modules/perl/libperl.a \
--enable-module=perl

It gave no errors. When I run make I get the error mentioned before... I think it's a little thing I do wrong - or that's mentioned wrong in the howto.
I tried changing the path to
EAPI_MM="/usr/local/lib" SSL_BASE="/usr/local/ssl" \
without changing the rest of the configure command, but that gave me :
Configure:Error: Cannot find MM library under /usr/local/lib
changing the path to
EAPI_MM="/usr/local/mm-1.1.3/.libs" \ SSL_BASE="/usr/local/ssl" \
also without changing the rest of the configure command but that gave me:
Configure:Error: Cannot find MM library under /usr/mm/mm-1.1.3/.libs

Can anybody please help me?

Thanks in advance!
Johan