Warning: Function ereg() is deprecated in ..../includes/class_postbit.php(345) : eval()'d code on line 4

Warning: Function split() is deprecated in ..../includes/class_postbit.php(345) : eval()'d code on line 19

Warning: Function ereg() is deprecated in ..../includes/class_postbit.php(345) : eval()'d code on line 4

Warning: Function split() is deprecated in ..../includes/class_postbit.php(345) : eval()'d code on line 19

Warning: Function ereg() is deprecated in ..../includes/class_postbit.php(345) : eval()'d code on line 4

Warning: Function split() is deprecated in ..../includes/class_postbit.php(345) : eval()'d code on line 19

Warning: Function ereg() is deprecated in ..../includes/class_postbit.php(345) : eval()'d code on line 4

Warning: Function split() is deprecated in ..../includes/class_postbit.php(345) : eval()'d code on line 19

Warning: Function ereg() is deprecated in ..../includes/class_postbit.php(345) : eval()'d code on line 4

Warning: Function split() is deprecated in ..../includes/class_postbit.php(345) : eval()'d code on line 19

Warning: Function ereg() is deprecated in ..../includes/class_postbit.php(345) : eval()'d code on line 4

Warning: Function split() is deprecated in ..../includes/class_postbit.php(345) : eval()'d code on line 19

Warning: Function ereg() is deprecated in ..../includes/class_postbit.php(345) : eval()'d code on line 4

Warning: Function split() is deprecated in ..../includes/class_postbit.php(345) : eval()'d code on line 19

Warning: Function ereg() is deprecated in ..../includes/class_postbit.php(345) : eval()'d code on line 4

Warning: Function split() is deprecated in ..../includes/class_postbit.php(345) : eval()'d code on line 19

Warning: Function ereg() is deprecated in ..../includes/class_postbit.php(345) : eval()'d code on line 4

Warning: Function split() is deprecated in ..../includes/class_postbit.php(345) : eval()'d code on line 19

Warning: Function ereg() is deprecated in ..../includes/class_postbit.php(345) : eval()'d code on line 4

Warning: Function split() is deprecated in ..../includes/class_postbit.php(345) : eval()'d code on line 19
Mandrake 8.1 & 8.2 BOOT

View Poll Results: Why I have a 5 min. stop during the boot??

Voters
0. You may not vote on this poll
  • 0 0%
Page 1 of 2 12 LastLast
Results 1 to 10 of 15

Thread: Mandrake 8.1 & 8.2 BOOT

  1. #1
    DrWhOz
    Guest

    Mandrake 8.1 & 8.2 BOOT

    Hi! Sorry for my english! I have installed (4 times!!!) Mandrake 8.1 and 8.2 on my pc (Pentium II 350MHz, 128Mb ram 10Gb HD). It works really ok, but I have a problem at the boot and I'm not able to solve it! I really ask help for this, I'm very stressed!! At the boot it start regularly, until "Finding module dependencies" that give an OK. Then the blinking cursor goes to the next line (still void) and ALL is stopped for about 5 minutes (NO hd activity!). Then the boot continues normally with "Checking filesystems..." and normally arrives to the end. Linux works correctly! The automatic installation gived three partition of the disk: hda1 (Linux native, 3.4 Gb, as "/"); hda5 (Linux swap, 234Mb); hda6 (Linux native, 5.8Gb, as "/home). All formatted. I have also a lan card, but I disabled it and it's the some!I REALLY don't know what does not goes!! It's impossible to wait something like 10 minutes just for the boot!! PLEASE, HELP ME!! I thank you a lot for your support.DrWhOz drwhozzz@hotmail.com

  2. #2
    Spot
    Guest

    Re:Mandrake 8.1 & 8.2 BOOT

    Quote Originally Posted by DrWhOz
    I have also a lan card, but I disabled it
    Disabled it how?
    I would suspect that this might be part of your problem, because unless it is "disabled" properly, it might be causing the system to hang for a bit while the system tries to activate it.

    Another thing that might cause a long boot is the services you are starting up, and the following information from you would be helpful:

    Do you boot into the graphical login manager or are you taken just to a command line(text) prompt?
    If you boot into graphical mode, please login and type the following into a terminal(konsole) window:
    ls /etc/rc.d/rc5.d
    and post the output of that command.
    If you boot into console(text) mode, please login and type the following command:
    ls /etc/rc.d/rc3.d
    and post the output of that command.

    This will tell us what services are starting up when your machine boots. I suspect this might also be part of the problem, because you used the automatic installation, and you are probably starting up services that aren't yet configured properly(or needed at all), and that can cause a long bootup.

  3. #3
    DrWhOz
    Guest

    Re:Mandrake 8.1 & 8.2 BOOT

    First thanks a lot!
    The boot is the same with or without the lan card installed on the PCI bus!
    I start in the graphical mode and the command ls /etc/rc.d/rc5.d
    gave these results:

    S01 usb
    S05 harddrake
    S05 kudzu
    S10 network
    S11 portmap
    S12 syslog
    S20 random
    S25 netfs
    S26 apmd
    S40 atd
    S56 rawdevices
    S56 xinetol
    S60 cups
    S70 alsa
    S71 sound
    S75 keytable
    S80 pastman
    S85 gpm
    S85 numlock
    S89 internet
    S90 crond
    S90 xfs
    S95 anacron
    S95 kheader
    S99 devfsd
    S99 linuxconf
    S99 local
    S99 medusa

    Hooping this will help you I'll wait for a possible solution!! I'm really depressed! I love Mandrake and I would like a lot to learn to use it and Unix, but I have this problem before!
    Thanks again!
    DrWhOz.


  4. #4
    Spot
    Guest

    Re:Mandrake 8.1 & 8.2 BOOT

    OK...once you get the machine booted up, log in and fire up the Manrake Control Center.
    Proceed to the "Services" section.

    S01 usb if you aren't using any USB devices, you can disable this
    S05 harddrake if you aren't putting any new hardware in(or prefer to config it manually), disable it
    S05 kudzu same as harddrake
    S10 network leave it alone
    S11 portmap unless you're using unix shares or rcp from another machine, disable
    S12 syslog leave it
    S20 random leave it
    S25 netfs unless you're using unix shares from another machine, disable
    S26 apmd disable
    S40 atd disable
    S56 rawdevices you can safely disable this
    S56 xinetol disable
    S60 cups unless you have a printer set up, disable it
    S70 alsa leave it
    S71 sound leave it
    S75 keytable leave it
    S80 pastman don't know wtf this is, but it's most likely safe to disable
    S85 gpm unless you need mouse access at the console, disable
    S85 numlock leave it
    S89 internet leave it
    S90 crond leave it
    S90 xfs leave it
    S95 anacron disable
    S95 kheader leave it
    S99 devfsd leave it
    S99 linuxconf leave it
    S99 local leave it
    S99 medusa disable

    Disabling those *should* speed up your boot by about 80%

  5. #5
    DrWhOz
    Guest

    Re:Mandrake 8.1 & 8.2 BOOT

    OK, thanks a lot! I'll try to do that, then I'll tell you the results! ;-)
    Do you think that it may be possible that the 5min delay can be caused by a searching to obtain an internet (not lan) DNS? I already had a similar problem with windows. But I'm sure to have already put the check on "DNS by provider", so it should not search for it without a real internet connection!
    Anyway I'll try your solution. Thanks again!
    DrWhOz.

  6. #6
    DrWhOz
    Guest

    Re:Mandrake 8.1 & 8.2 BOOT

    Hi! I'm sorry... :'( I have disabled all the options you told me, but the boot stops anyway for 5 min in the some point!!
    Also because the stop (at least I think...) is BEFORE that the system starts to load those services! It stops between 10 and 11 "OK" from the boot start.
    Can it be a problem about partitions?? (They were done in auto mode).
    I'm thinking to try with another Linux system (SuSe for ex.)...
    But it makes me really angry to be not able to solve this problem! >
    Anyway thank you very much for your help!! Of course, if you'll have any other idea to obtain the result... I'll try it immediately!!
    Have a nice day!
    DrWhOz.

  7. #7
    Spot
    Guest

    Re:Mandrake 8.1 & 8.2 BOOT

    Quote Originally Posted by DrWhOz
    Do you think that it may be possible that the 5min delay can be caused by a searching to obtain an internet (not lan) DNS? I already had a similar problem with windows.
    You hadn't mentioned that part before. Yes, that will cause a delay like you're experiencing. And once again, you've said you "disabled" the network card, but you haven't said how.
    But I'm sure to have already put the check on "DNS by provider", so it should not search for it without a real internet connection!
    That's not true at all. By setting it that way, you're forcing the network deamons to search and search and search for your ISP's DHCP server so it can obtain an IP. It's not finding one, but it keeps searching because you told it to do so. Either set the network card to have a static IP (you can alter this after the machine boots if you want your connection later) or do the following:

    Open your favorite text editor as root or su, and edit the following file:
    /etc/sysconfig/network-scripts/ifcfg-eth0
    (your file may be ifcfg-eth1 or some other number, but if you only have one card, it should be ifcfg-eth0)
    look for a line similar to this:
    ONBOOT='yes'
    Change it to read:
    ONBOOT='no'
    Save and exit the file

    This can also be set using the Mandrake Control Center, but I forget exactly how.

    This will stop the machine from trying to obtain an IP, and *should* stop the delay you've been experiencing. You can start the network card manually as necessary after that via command line or the Mandrake Control Center.

  8. #8
    DrWhOz
    Guest

    Re:Mandrake 8.1 & 8.2 BOOT

    ********************
    ONBOOT='yes'
    Change it to read:
    ONBOOT='no'
    Save and exit the file

    This can also be set using the Mandrake Control Center, but I forget exactly how.
    *********************
    YES! That is what I have done! This is what I mean when I tell you that I've "disabled" the LAN card! I did not used the line control but Mandrake Control Center. It is exactly a disable on boot! But I have done this just for the lan card (that for the moment I use only with Win), NOT for the MODEM (or for internet connection if you prefere). Should I do that?? Mmmhhh... I can try also this... if it will be possible!
    My english is bad, excuse me! But of course what I mean talking about DNS it was that I already forced it as static, not dynamic...
    Thanks again.
    DrWhOz.



  9. #9
    Spot
    Guest

    Re:Mandrake 8.1 & 8.2 BOOT

    Quote Originally Posted by DrWhOz
    But I have done this just for the lan card (that for the moment I use only with Win), NOT for the MODEM (or for internet connection if you prefere). Should I do that?? Mmmhhh... I can try also this... if it will be possible!
    My english is bad, excuse me! But of course what I mean talking about DNS it was that I already forced it as static, not dynamic...
    Thanks again.
    DrWhOz.
    If disabling the modem/internet connection on boot is an option(I can't say, I don't use an analog modem anymore), then yes, try that.

    I was discussing this with some others and another point was brought up. If your machine's hostname is a single word with a dial-up, that can also cause delays similar to what you're experiencing, as it might be trying to resolve the hostname(with no connection to a network to do so)
    Please paste the out put of the following commands:
    cat /etc/hosts
    cat /etc/sysconfig/network
    cat /etc/sysconfig/networking/profiles/default/network
    So we can see exactly what that's set to.

  10. #10
    DrWhOz
    Guest

    Re:Mandrake 8.1 & 8.2 BOOT

    Hi! You are really very kind to help me!I want to thank you and your friends!
    So, first the modem: enabled or disabled it is the same!
    I list the results you requested me. (I attributed the name "server" to this pc, also if it is not really and I forced the DNS to 192.168.0.1).

    cat /etc/hosts

    127.0.0.1 localhost.localdomain localhost
    192.168.0.1 server

    cat /etc/sysconfig/network

    NETWORKING=yes
    FORWARD_IPV4=false
    HOSTNAME=server
    DOMAINNAME=localdomain

    cat /etc/sysconfig/networking/profiles/default/network

    NO SUCH FILE OR DIRECTORY

    I've typed more times the command line, but the result was this. If I stop after .../default it say that it is a directory, but both with /network or /networking at the end it says "no such file or directory".

    Hooping this will help you I want to thank you again.
    Greetings.
    DrWhOz.


Similar Threads

  1. Dual boot mandrake with win2kpro
    By grasshopper in forum Linux - Software, Applications & Programming
    Replies: 2
    Last Post: 09-19-2005, 10:51 PM
  2. Dual boot Mandrake 10 and WinXP problems
    By Joey in forum Linux - General Topics
    Replies: 35
    Last Post: 07-02-2005, 09:24 PM
  3. Mandrake takes a long time to boot
    By in forum Linux - Software, Applications & Programming
    Replies: 29
    Last Post: 10-19-2003, 11:00 PM
  4. Mandrake & LILO in mbr - can't boot from hda3
    By x in forum Linux - General Topics
    Replies: 18
    Last Post: 01-25-2003, 07:06 PM
  5. XP Pro & Mandrake 9 dual boot
    By nomadfemme in forum Mandriva
    Replies: 1
    Last Post: 11-19-2002, 06:54 AM

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •