Page 1 of 2 12 LastLast
Results 1 to 10 of 13

Thread: Installing kde 3.0 from rpm

  1. #1
    Bogler
    Guest

    Installing kde 3.0 from rpm

    I have tried to install kde 3.0 from rpm.
    I use rpm -Fvh *.rpm and i get (apologies for length).
    

    [root@david kde3]# rpm -Fvh *.rpm
    error: failed dependencies:
    usbutils >= 0.9 is needed by hotplug-2002_04_01-1
    libcups.so.2 is needed by kdeaddons-kicker-3.0.0-1
    libcups.so.2 is needed by kdeadmin-3.0.0-2
    librpm-4.0.4.so is needed by kdeadmin-3.0.0-2
    librpmbuild-4.0.4.so is needed by kdeadmin-3.0.0-2
    librpmdb-4.0.4.so is needed by kdeadmin-3.0.0-2
    librpmio-4.0.4.so is needed by kdeadmin-3.0.0-2
    libcups.so.2 is needed by kdeartwork-3.0.0-3
    libcups.so.2 is needed by kdebase-3.0.0-2
    libcups.so.2 is needed by kdebindings-3.0.0-1
    libcups.so.2 is needed by kdebindings-kmozilla-3.0.0-1
    libcups.so.2 is needed by kdegames-3.0.0-1
    cups-libs >= 1.1.12 is needed by kdelibs-3.0.0-4
    libcups.so.2 is needed by kdelibs-3.0.0-4
    libcups.so.2 is needed by kdelibs-devel-3.0.0-4
    kdemultimedia-arts = 3.0.0 is needed by kdemultimedia-devel-3.0.0-1
    noatun = 3.0.0 is needed by kdemultimedia-devel-3.0.0-1
    libcups.so.2 is needed by kdepim-3.0.0-1
    libcups.so.2 is needed by kdepim-pilot-3.0.0-1
    libpisock.so.4 is needed by kdepim-pilot-3.0.0-1
    libcups.so.2 is needed by kdetoys-3.0.0-1
    libcups.so.2 is needed by koncd-3.0.0-1
    libcups.so.2 is needed by qt-3.0.3-5
    libcups.so.2 is needed by qt-devel-3.0.3-5
    libqt.so.2 is needed by switchdesk-kde-3.9.7-1
    libqt.so.2 is needed by kdemultimedia-2.2.2-2
    libqt.so.2 is needed by kdenetwork-2.2.2-1
    libqt.so.2 is needed by kdenetwork-ppp-2.2.2-1
    libqt.so.2 is needed by kdesdk-2.2.2-1
    libqt.so.2 is needed by kdeutils-2.2.2-1
    libqt.so.2 is needed by kdegraphics-2.2.2-1
    libartsflow_idl.so.0 is needed by kdemultimedia-2.2.2-2
    libartsflow.so.0 is needed by kdemultimedia-2.2.2-2
    libkmedia2_idl.so.0 is needed by kdemultimedia-2.2.2-2
    libmcop.so.0 is needed by kdelibs-sound-devel-2.2.2-2
    libmcop.so.0 is needed by kdemultimedia-2.2.2-2
    libsoundserver_idl.so.0 is needed by kdemultimedia-2.2.2-2
    kdelibs = 2.2.2 is needed by kdelibs-sound-devel-2.2.2-2
    libDCOP.so.1 is needed by kdemultimedia-2.2.2-2
    libDCOP.so.1 is needed by kdenetwork-2.2.2-1
    libDCOP.so.1 is needed by kdenetwork-ppp-2.2.2-1
    libDCOP.so.1 is needed by kdesdk-2.2.2-1
    libDCOP.so.1 is needed by kdeutils-2.2.2-1
    libDCOP.so.1 is needed by kdegraphics-2.2.2-1
    libkab.so.3 is needed by kdenetwork-2.2.2-1
    libkab.so.3 is needed by kdeutils-2.2.2-1
    libkdecore.so.3 is needed by kdemultimedia-2.2.2-2
    libkdecore.so.3 is needed by kdenetwork-2.2.2-1
    libkdecore.so.3 is needed by kdenetwork-ppp-2.2.2-1
    libkdecore.so.3 is needed by kdesdk-2.2.2-1
    libkdecore.so.3 is needed by kdeutils-2.2.2-1
    libkdecore.so.3 is needed by kdegraphics-2.2.2-1
    libkdeprint.so.0 is needed by kdemultimedia-2.2.2-2
    libkdeprint.so.0 is needed by kdenetwork-2.2.2-1
    libkdeprint.so.0 is needed by kdeutils-2.2.2-1
    libkdeprint.so.0 is needed by kdegraphics-2.2.2-1
    libkdesu.so.1 is needed by kdemultimedia-2.2.2-2
    libkdesu.so.1 is needed by kdenetwork-2.2.2-1
    libkdesu.so.1 is needed by kdesdk-2.2.2-1
    libkdesu.so.1 is needed by kdeutils-2.2.2-1
    libkdesu.so.1 is needed by kdegraphics-2.2.2-1
    libkdeui.so.3 is needed by kdemultimedia-2.2.2-2
    libkdeui.so.3 is needed by kdenetwork-2.2.2-1
    libkdeui.so.3 is needed by kdenetwork-ppp-2.2.2-1
    libkdeui.so.3 is needed by kdesdk-2.2.2-1
    libkdeui.so.3 is needed by kdeutils-2.2.2-1
    libkdeui.so.3 is needed by kdegraphics-2.2.2-1
    libkfile.so.3 is needed by kdemultimedia-2.2.2-2
    libkfile.so.3 is needed by kdenetwork-2.2.2-1
    libkfile.so.3 is needed by kdesdk-2.2.2-1
    libkfile.so.3 is needed by kdeutils-2.2.2-1
    libkfile.so.3 is needed by kdegraphics-2.2.2-1
    libkhtml.so.3 is needed by kdenetwork-2.2.2-1
    libkio.so.3 is needed by kdemultimedia-2.2.2-2
    libkio.so.3 is needed by kdenetwork-2.2.2-1
    libkio.so.3 is needed by kdesdk-2.2.2-1
    libkio.so.3 is needed by kdeutils-2.2.2-1
    libkio.so.3 is needed by kdegraphics-2.2.2-1
    libkparts.so.1 is needed by kdemultimedia-2.2.2-2
    libkparts.so.1 is needed by kdenetwork-2.2.2-1
    libkparts.so.1 is needed by kdeutils-2.2.2-1
    libkparts.so.1 is needed by kdegraphics-2.2.2-1
    libkspell.so.3 is needed by kdenetwork-2.2.2-1
    libkspell.so.3 is needed by kdesdk-2.2.2-1
    libkspell.so.3 is needed by kdeutils-2.2.2-1
    libkssl.so.2 is needed by kdemultimedia-2.2.2-2
    libkssl.so.2 is needed by kdenetwork-2.2.2-1
    libkssl.so.2 is needed by kdesdk-2.2.2-1
    libkssl.so.2 is needed by kdeutils-2.2.2-1
    libkssl.so.2 is needed by kdegraphics-2.2.2-1
    libksycoca.so.3 is needed by kdemultimedia-2.2.2-2
    libksycoca.so.3 is needed by kdenetwork-2.2.2-1
    libksycoca.so.3 is needed by kdesdk-2.2.2-1
    libksycoca.so.3 is needed by kdeutils-2.2.2-1
    libksycoca.so.3 is needed by kdegraphics-2.2.2-1
    kdelibs-devel = 2.2.2 is needed by kdelibs-sound-devel-2.2.2-2
    libartskde.so is needed by kdemultimedia-2.2.2-2
    libqtmcop.so.0 is needed by kdemultimedia-2.2.2-2

    I have cups 1.1.12 already installed
    Do i just use the --nodeps option

    Thanks

    Bogler ???

  2. #2
    Spot
    Guest

    Re:Installing kde 3.0 from rpm

    What distro?

  3. #3
    Bogler
    Guest

    Re:Installing kde 3.0 from rpm

    I am running RedHat 7.2, kernel 2.4.7 and i have kde 2.2.2 already installed.

    Previously i installed cups and in the process had to ditch the lpr rpms.

    Nothing i can see which is particularly odd about my setup, i expected it to install no problem but was quite freaked when it spewed out all these dependencies...

    Bogler

  4. #4
    JimH
    Guest

    Re:Installing kde 3.0 from rpm

    Bogler,

    I don't have a 7.2 box with KDE installed on it right now. I am running the 7.3 beta on my desktop right now and my other boxes either have no GUI installed or only Gnome. I will see if I can do a 7.2 install on another drive later today and psot the instructions to install KDE 3.

    KDE 3 looks pretty nice. I haven't used it much though since I have been running the 7.3 beta.

    Jim H

  5. #5
    Bogler
    Guest

    Re:Installing kde 3.0 from rpm

    Thanks JimH

    Usually things are fairly straightforward with rpm -Fvh but this one had me stumped a bit.

    Looking forward to using it.

    I tried to get you on the chat site last night but had to abandon my efforts as my kid was going crazy.

    Regards

    Bogler 8)

  6. #6
    JimH
    Guest

    Re:Installing kde 3.0 from rpm

    Quote Originally Posted by Bogler
    I tried to get you on the chat site last night but had to abandon my efforts as my kid was going crazy.
    Yeah, I saw that. I wasn't there. IRC must have disconnected and re-connected so I wasn't listed as JimH|Away. :P

    Jim H

  7. #7
    Bogler
    Guest

    Re:Installing kde 3.0 from rpm

    After some further research (reading the README files on kde.org) i have discovered the following.

    "Since we have switched to building more modular packages users of KDE 1.x or 2.x should remove older KDE packages and then install the newer ones rather than trying to update. Deleting the old packages will not delet settings etc stored in the users home directories.

    To remove the old packages and install the new ones, run:

    cd /wherever you downloaded the kde3 rpms
    rpm -e `rpm -qa |egrep ^kde`
    rpm -Uvh *.rpm
    "
    My question is

    Is this safe to do?

    I installed 7.2 from an iso image (7.1 was there originally - full install) i then updated to kde 2.2.2 with rpms using rpm -Fvh *.rpm

    So it looks like i have to blow away all kde packaes and re-install from scratch

    Bogler

  8. #8
    JimH
    Guest

    Re:Installing kde 3.0 from rpm

    Yeah, I just looked at the readme file. It should be safe. Just don't do it from within KDE. :P Red Hat has changed the way they package KDE. When updating from Skipjack beta 1 and 2 I saw quite a few incorrect dependancy errors.

    I didn't have a chance to re-install 7.2 yesterday. I will try again today. ;D

    Jim H

  9. #9
    Bogler
    Guest

    Re:Installing kde 3.0 from rpm

    I have tried the above comands from the command line in run level 3.
    It complains about broken dependencies, first lot is koncd.
    I then tried rpm -e `rpm -qa |egrep ^kde` --nodeps and it was then complaining about
    links to Mozilla.

    I'm not sure if the above (this post) syntax is correct but i'm having limited luck with this.

    Cheers

    Bogler

  10. #10
    JimH
    Guest

    Re:Installing kde 3.0 from rpm

    Alright I have KDE 3 up and running on 7.2. ;D

    Your mileage is going to vary depending on what packages you have installed.

    I first ran the command below to see what packages I had to remove before I could uninstall KDE 2.2.2

    rpm -e --test `rpm -qa |egrep ^kde`

    This showed me I needed to remove 4 packages first.

    rpm -e kpppload licq-kde kdbg koffice


    Then I uninstalled KDE 2.2.2 with:

    rpm -e `rpm -qa |egrep ^kde`


    Then I checked to see if any of the packages I downloaded were going to cause any problems.

    rpm -Uvh --test *.rpm

    I created a directory and moved the problem packages into it. These are the packages I had to move and why.

    These are going to require packages from rawhide to install.
    gphoto2-2.0-2.i386.rpm
    gphoto2-devel-2.0-2.i386.rpm
    hotplug-2002_04_01-1.i386.rpm
    hwdata-0.9-1.noarch.rpm
    kamera-3.0.0-3.i386.rpm
    kdepim-pilot-3.0.0-1.i386.rpm
    usbutils-0.9-5.i386.rpm

    I don't have Mysql and/or PostgreSQL installed so I don't need these.
    qt-MySQL-3.0.3-5.i386.rpm
    qt-ODBC-3.0.3-5.i386.rpm
    qt-PostgreSQL-3.0.3-5.i386.rpm

    Then I installed KDE 3

    rpm -Uvh *.rpm

    That's it. ;D

    I will look and see what packages are needed from rawhide to install the ones I haven't installed yet. This should give you an idea of what is required. If you have a problem post the output of the command you have the problem with.

    Jim H

Similar Threads

  1. installing ftp
    By kwaslee in forum Suse
    Replies: 1
    Last Post: 02-27-2008, 09:53 AM
  2. Installing GCL on FC8
    By omidkamangar in forum Redhat / Fedora
    Replies: 1
    Last Post: 12-21-2007, 12:09 AM
  3. Need help installing app.
    By Dswissmiss in forum Linux - Software, Applications & Programming
    Replies: 1
    Last Post: 03-04-2003, 03:14 PM
  4. Installing GTK with apt-get
    By gmoreno in forum Linux - Software, Applications & Programming
    Replies: 2
    Last Post: 03-05-2002, 03:07 PM
  5. Installing with tar
    By papanohair in forum Linux - General Topics
    Replies: 11
    Last Post: 01-05-2002, 11:57 PM

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •