Results 1 to 7 of 7

Thread: R.P. IceWM

  1. #1
    LiNuts
    Guest

    R.P. IceWM

    I have just been reading the boards about IceWM not being developed anymore,(and i use it as my main WM). so i thought that as i have Gnome installed, i will have a look at it. (never really bothered with it before), I must have run over a chinaman, because when i select Gnome it starts to boot then throws me back to the login prompt.

    I checked a file in my ~/ called gnome-errors, and this is what it had in it.

    /etc/gdm/Sessions//Gnome: checking /etc/login.defs for option UMASK
    /etc/gdm/Sessions//Gnome: /etc/login.defs: "UMASK" is "022"
    /etc/gdm/Sessions//Gnome: checking /etc/login.defs for option ULIMIT
    /etc/gdm/Sessions//Gnome: checking /etc/login.defs for option MAIL_DIR
    /etc/gdm/Sessions//Gnome: /etc/login.defs: "MAIL_DIR" is "/var/spool/mail"
    /etc/gdm/Sessions//Gnome: using /etc/X11/Xsession.options for options
    /etc/gdm/Sessions//Gnome: checking /etc/X11/Xsession.options for option allow-user-resources
    /etc/gdm/Sessions//Gnome: checking /etc/X11/Xsession.options for option allow-user-modmap

    Gdk-WARNING **: locale not supported by C library
    SESSION_MANAGER=local/libranet:/tmp/.ICE-unix/964

    Gdk-WARNING **: locale not supported by C library

    Gdk-WARNING **: locale not supported by C library

    Gdk-WARNING **: locale not supported by C library

    Gdk-WARNING **: locale not supported by C library

    Gdk-WARNING **: locale not supported by C library

    Gdk-WARNING **: locale not supported by C library

    Gdk-WARNING **: locale not supported by C library

    Gtk-WARNING **: invalid cast from (NULL) pointer to `GtkOptionMenu'

    Gtk-CRITICAL **: file gtkoptionmenu.c: line 248 (gtk_option_menu_set_history): assertion `option_menu != NULL' failed.
    Gdk-ERROR **: X connection to :0.0 broken (explicit kill or server shutdown).
    ICE default IO error handler doing an exit(), pid = 1004, errno = 0

    Gdk-WARNING **: locale not supported by C library

    Gdk-WARNING **: locale not supported by C library
    X connection to :0.0 broken (explicit kill or server shutdown).
    Xlib: connection to ":0.0" refused by server
    Xlib: Client is not authorized to connect to Server

    Gtk-WARNING **: cannot open display: :0
    Gdk-ERROR **: X connection to :0.0 broken (explicit kill or server shutdown).

    I thought it might have something to do with my XFree86 setup, so i reconfigured that, but it is still the same.

    Any help appreciated
    Cheers
    LiNuts

    BTW: my apologies to any chinamen, for my reference to you
    ;D

  2. #2
    JimH
    Guest

    Re:R.P. IceWM

    Can you reproduce this problem in runlevel 3 instead of using GDM and runlevel 5?

    Did you select a locale setting in GDM before you logged in?

    Is there a default locale set in your gdm.conf? Iis it set correctly?


    Does this workaround allow you to start GNOME?

    In runlevel 3 at the console prompt before you type startx:

    export LC_ALL=C

    Jim H



  3. #3
    LiNuts
    Guest

    Re:R.P. IceWM

    JimH,
    Many thanks for the reply, that did it, the locale was not set, I did as you suggested "export LC_ALL=C" and now i can use Gnome.

    Bloody hell i have a lot to learn about linux :'(

    Cheers
    LiNuts

  4. #4
    Spot
    Guest

    Re:R.P. IceWM

    Quote Originally Posted by LiNuts
    Bloody hell i have a lot to learn about linux :'(
    heh..don't we all

  5. #5
    JimH
    Guest

    Re:R.P. IceWM

    Quote Originally Posted by LiNuts
    Many thanks for the reply, that did it, the locale was not set, I did as you suggested "export LC_ALL=C" and now i can use Gnome.
    Did you recheck you locale setting? The "export LC_ALL=C" isn't really a fix it is really just a work around to get it working.

    Jim H

  6. #6
    LiNuts
    Guest

    Re:R.P. IceWM

    How do i recheck the locale settings ?.
    Cheers
    LiNuts

  7. #7
    JimH
    Guest

    Re:R.P. IceWM

    Quote Originally Posted by LiNuts
    How do i recheck the locale settings ?.
    Cheers
    LiNuts
    Under the System menu there should be an entry "Locale Chooser".

    Or in a console window: locale_config

    You also should check you gdm.conf and see what the default locale is set too.

    Jim H

Similar Threads

  1. IceWM is dead.
    By cga in forum Linux - Software, Applications & Programming
    Replies: 33
    Last Post: 05-20-2002, 05:45 PM
  2. IceWM PET
    By cga in forum Linux - General Topics
    Replies: 1
    Last Post: 05-08-2002, 01:57 AM
  3. IceWM: Its alive!!!
    By cga in forum Linux - Software, Applications & Programming
    Replies: 0
    Last Post: 04-21-2002, 10:00 PM
  4. cga's icewm ss
    By cga in forum Linux - Software, Applications & Programming
    Replies: 12
    Last Post: 03-15-2002, 09:16 PM
  5. LOL - Back to iceWM
    By cga in forum Linux - Software, Applications & Programming
    Replies: 10
    Last Post: 12-18-2001, 11:14 PM

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •