Warning: Function ereg() is deprecated in ..../includes/class_postbit.php(345) : eval()'d code on line 4

Warning: Function split() is deprecated in ..../includes/class_postbit.php(345) : eval()'d code on line 19

Warning: Function ereg() is deprecated in ..../includes/class_postbit.php(345) : eval()'d code on line 4

Warning: Function split() is deprecated in ..../includes/class_postbit.php(345) : eval()'d code on line 19

Warning: Function ereg() is deprecated in ..../includes/class_postbit.php(345) : eval()'d code on line 4

Warning: Function split() is deprecated in ..../includes/class_postbit.php(345) : eval()'d code on line 19

Warning: Function ereg() is deprecated in ..../includes/class_postbit.php(345) : eval()'d code on line 4

Warning: Function split() is deprecated in ..../includes/class_postbit.php(345) : eval()'d code on line 19

Warning: Function ereg() is deprecated in ..../includes/class_postbit.php(345) : eval()'d code on line 4

Warning: Function split() is deprecated in ..../includes/class_postbit.php(345) : eval()'d code on line 19

Warning: Function ereg() is deprecated in ..../includes/class_postbit.php(345) : eval()'d code on line 4

Warning: Function split() is deprecated in ..../includes/class_postbit.php(345) : eval()'d code on line 19

Warning: Function ereg() is deprecated in ..../includes/class_postbit.php(345) : eval()'d code on line 4

Warning: Function split() is deprecated in ..../includes/class_postbit.php(345) : eval()'d code on line 19

Warning: Function ereg() is deprecated in ..../includes/class_postbit.php(345) : eval()'d code on line 4

Warning: Function split() is deprecated in ..../includes/class_postbit.php(345) : eval()'d code on line 19

Warning: Function ereg() is deprecated in ..../includes/class_postbit.php(345) : eval()'d code on line 4

Warning: Function split() is deprecated in ..../includes/class_postbit.php(345) : eval()'d code on line 19

Warning: Function ereg() is deprecated in ..../includes/class_postbit.php(345) : eval()'d code on line 4

Warning: Function split() is deprecated in ..../includes/class_postbit.php(345) : eval()'d code on line 19
gfx trouble with Redhat 7.2
Results 1 to 10 of 10

Thread: gfx trouble with Redhat 7.2

  1. #1
    doggiebone
    Guest

    gfx trouble with Redhat 7.2

    Hi guys

    hope you can help I have Redhat 7.2 2.4.7. I'm using a g-force 2 mx 32mb ram and the lastest drivers 2880, and xfree86 4.1.0 .When i install the kernel i get this error

    [root@localhost gfx]# rpm -ivh NVIDIA_kernel-1.0-2880.rh72up.i686.rpm
    Preparing... ########################################### [100%]
    1:NVIDIA_kernel ########################################### [100%]
    depmod: *** Unresolved symbols in /lib/modules/2.4.7-10/kernel/drivers/video/NVdriver
    /lib/modules/2.4.7-10/kernel/drivers/video/NVdriver: unresolved symbol register_chrdev_R82739b6c
    /lib/modules/2.4.7-10/kernel/drivers/video/NVdriver: unresolved symbol proc_root_Rd611da4a
    /lib/modules/2.4.7-10/kernel/drivers/video/NVdriver: unresolved symbol init_mm_Rda088e62
    /lib/modules/2.4.7-10/kernel/drivers/video/NVdriver: unresolved symbol irq_stat_R757431be
    /lib/modules/2.4.7-10/kernel/drivers/video/NVdriver: unresolved symbol create_proc_entry_R0bae5560
    /lib/modules/2.4.7-10/kernel/drivers/video/NVdriver: unresolved symbol proc_root_driver_Rfe7a1c71
    /lib/modules/2.4.7-10/kernel/drivers/video/NVdriver: unresolved symbol __pollwait_R047dd2bd
    /lib/modules/2.4.7-10/kernel/drivers/video/NVdriver: unresolved symbol remove_proc_entry_R23c20f40
    /lib/modules/2.4.7-10/kernel/drivers/video/NVdriver: unresolved symbol mem_map_R9141227f
    /lib/modules/2.4.7-10/kernel/drivers/video/NVdriver: insmod /lib/modules/2.4.7-10/kernel/drivers/video/NVdriver failed
    /lib/modules/2.4.7-10/kernel/drivers/video/NVdriver: insmod NVdriver failed

    NVdriver installed successfully

    I then install the glx module and get this
    [root@localhost gfx]# rpm -ivh NVIDIA_GLX-1.0-2880.i386.rpm
    Preparing... ########################################### [100%]
    /var/tmp/rpm-tmp.75654: strings: command not found
    --- WARNING!!
    libglx.a
    /var/tmp/rpm-tmp.75654: strings: command not found
    libGLcore.a
    /var/tmp/rpm-tmp.75654: strings: command not found
    libGL.so.1.2.030402
    --- The above file(s) possibly belong to a conflicting MESA rpm.
    --- They have been renamed to xxx.<originalFile>.RPMSAVE to
    --- avoid conflicting with the files contained within this
    --- package.
    --- Please see the FREQUENTLY ASKED QUESTIONS section of
    --- /usr/share/doc/NVIDIA_GLX-1.0/README for more details.
    1:NVIDIA_GLX ########################################### [100%]

    At this stage i edit the driver and modules after reboot i dont get the gui, i'm booted into text mode. I then have to re-install.

    any idea's?

  2. #2
    JimH
    Guest

    Re:gfx trouble with Redhat 7.2

    Hmmm, I don't use Nvidia cards. I would try upgrading your your kernel to the lastest available for 7.2 and grab the Nvidia drivers for that kernel and try again.

    Jim H

  3. #3
    doggiebone
    Guest

    Re:gfx trouble with Redhat 7.2

    hi jim

    thx for the info Generally is wise to rebuild the kernel when having gfx probs? Cos I'm a newbie to Linux but a god in other areas ;D

    thx m8

  4. #4
    JimH
    Guest

    Re:gfx trouble with Redhat 7.2

    You don't need to rebuild the kernel, but you might have better luck recompiling the nvidia source rpms instead of using the binary rpm's.

    Jim H

  5. #5

    Re:gfx trouble with Redhat 7.2

    or try the .tar.gz files
    you need to use them if you use a custom kernel, not the default distro one
    whatdoyougetwhenyoumultiplysixbynine??

  6. #6
    Nehctik
    Guest

    Re:gfx trouble with Redhat 7.2

    Did you try to upgrade your Kernel version?
    I have a Geforce3 on an AMD Athlon based machine with Red-hat 7.2
    I had troubles ... then I upgraded my kernel version to 2.4.9-31
    and installed NVIDIA_kernel-1.0-2313.rh72up_2.4.9_31.athlon.rpm
    and NVIDIA_GLX-1.0-2802.i386.rpm
    and then I edited /etc/X11/XF86Config-4 like the installation instruction said .... and I did a startx
    and ... everything was working fine!
    If you have more questions, tell me, I will help you

  7. #7
    doggiebone
    Guest

    Re:gfx trouble with Redhat 7.2

    Hi there

    thx for your help and you've answered some question which I thought it might be too. The problem was when i installed the drivers and edit the /etc/X11/XF86Config-4 and read doc per instructions, redhat would boot, but I would loose my gui.

    I will try to upgrade my kernel which seems the most obvious choice. Is there a site or does redhat provide docs for upgrading kernel, as a newbie I wanna make a smooth transition

    thx doggiebone

  8. #8
    doggiebone
    Guest

    Re:gfx trouble with Redhat 7.2 SUCCESS :)

    Hi Guys and gals

    I'd like to thank all who that helped trying to sort out my nvidia and redhat gfx problem. ;D Finally today after abit of deductions and common sense I finally got to the bottom of the problem

    Thx all, I hope I can be of assistance in other area's of linux to you all 8)

  9. #9
    Spot
    Guest

    Re:gfx trouble with Redhat 7.2 SUCCESS :)

    Finally today after abit of deductions and common sense I finally got to the bottom of the problem
    So...what was it?

  10. #10
    doggiebone
    Guest

    Re:gfx trouble with Redhat 7.2

    I was using the wrong kernel, I have a duron cpu and saw the athlon kernel, but choose to ignore it. So i ran the nvchooser and it said i needed the athlon kernel. Well I coulda choked myself

    spent 3 weeks racking my brains. using different distro, then decided to give it one more go and hey presto it worked

Similar Threads

  1. RedHat cron trouble
    By elcaro in forum Linux - General Topics
    Replies: 1
    Last Post: 01-14-2007, 07:54 AM
  2. Redhat 8.0 install trouble
    By bill_bob in forum Linux - Hardware, Networking & Security
    Replies: 3
    Last Post: 02-22-2003, 12:26 AM
  3. Trouble connecting to the internet using Redhat 8.0
    By FLY_FISHER in forum Linux - Hardware, Networking & Security
    Replies: 2
    Last Post: 10-24-2002, 11:46 AM
  4. Trouble with Pan
    By Onewingdove in forum Linux - Software, Applications & Programming
    Replies: 6
    Last Post: 05-05-2002, 01:00 PM
  5. Trouble with ppp server on Redhat 7.1
    By rdly in forum Redhat / Fedora
    Replies: 4
    Last Post: 08-19-2001, 10:15 PM

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •