Results 1 to 4 of 4

Thread: Failed dependencies... Aaaaaarrrggghhhhh!

  1. #1
    Junior Member
    Join Date
    Jul 2001
    Posts
    91

    Failed dependencies... Aaaaaarrrggghhhhh!

    I'm trying to install a Bible app called Gnome Sword which requires gdk-pixbuf-0.11 or higher. I recently installed gtk+-2.0.0 whcihc includes gdk-pixbuf0.8, which isn't good enough.

    So I've downloaded an rpm of gdk-pixbuf-0.11.0 but get the dreaded "failed dependencies" message. It won't overwrite the 0.8 version becasue pixbuf-devel-0.8 requires pixbuf 0.8. I tried to install gdkpixbuf-devel-0.11 but it won't overwrite because gdkpixbuf-0.8 needs it!

    My question is this: how do I get rid of the old version of pixbuf to install the newer one? It's all in a subdirectory of the gtk package so I might stuff things up severely by deleting files willy nilly.

    I'm still something of a newbie when it comes to this stuff so any simple instructions would be helpful

    Keith

  2. #2
    JimH
    Guest

    Re:Failed dependencies... Aaaaaarrrggghhhhh!

    Where did you get the gtk+-2.x and gdk-pixbuf rpm's you are trying to install? What version of Red Hat are you tying to install them on?

    Jim H

  3. #3
    Junior Member
    Join Date
    Jul 2001
    Posts
    91

    Re:Failed dependencies... Aaaaaarrrggghhhhh!

    RH 7.1

    I can't tell you exactly where I got the rpms from... that was last night and my memory doesn't go back that far!!

    I installed gtk from a tar.gz file downloaded from www.gtk.org.

    Keith

  4. #4
    JimH
    Guest

    Re:Failed dependencies... Aaaaaarrrggghhhhh!

    Probably your best bet for installing the newer gdk-pixbuf will be to download the source rpm and try and rebuild it on your 7.1 system. If you get any errors trying to rebuild the source rpm, post them. I don't have a running 7.1 install to try it on and see what problems you might have.

    Jim H

Similar Threads

  1. Linux Dependencies
    By comtux in forum General Chat
    Replies: 27
    Last Post: 12-14-2004, 05:03 PM
  2. dependencies
    By elovkoff in forum Linux - General Topics
    Replies: 3
    Last Post: 03-19-2003, 01:02 AM
  3. failed dependencies
    By ohnoitselton in forum Linux - Software, Applications & Programming
    Replies: 2
    Last Post: 02-04-2003, 01:33 AM
  4. compiler dependencies
    By trickster in forum Linux - Software, Applications & Programming
    Replies: 4
    Last Post: 10-06-2002, 10:37 PM
  5. Solving dependencies
    By rreed in forum Linux - Software, Applications & Programming
    Replies: 2
    Last Post: 09-21-2002, 02:40 AM

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •