Results 1 to 4 of 4

Thread: Linux woes!

  1. #1
    Sidomatic
    Guest

    Linux woes!

    Hi!
    I was wondering if you could help me regarding linux. I've got a couple of questions :

    1. How do I set read/write permission to a hardrive?
    I mounted my shared drive between my windows xp and linux as /home, but when I attempt to boot using a user it says I don't have read/write permission, how can I change that? BTW i use RH7.2.

    2. How do go about using using desktop capture in KDE. I dont have gimp installed, so is there any other way?


    Thanks-
    Have a nice day!

    -Mark


    ---------------------------------------
    Here is a copy of my fstab!
    /dev/hda4/reiserfsdefaults 1 1
    /dev/hda2/bootext3defaults 1 2
    devpts/dev/ptsdevptsdefaults 0 0
    /dev/cdrecorder/media/cdrecorderautoro,noauto,user,exec 0 0
    /dev/cdrom/media/cdromautoro,noauto,user,exec 0 0
    /dev/dvd/media/dvdautoro,noauto,user,exec 0 0
    /dev/fd0/media/floppyautonoauto,user,sync 0 0
    /dev/sda4/media/zipautonoauto,user 0 0
    /dev/hdb1/mnt/Sharedvfatauto,user 0 0
    usbdevfs/proc/bus/usbusbdevfsdefaults,noauto 0 0
    proc/procprocdefaults 0 0
    /dev/hda1/windows/Cntfsro,noauto,user,umask=022 0 2
    /dev/hda3swapswappri=42 0 0
    ---------------------------------------
    ???

  2. #2
    Spot
    Guest

    Re:Linux woes!

    1. How do I set read/write permission to a hardrive?
    I mounted my shared drive between my windows xp and linux as /home, but when I attempt to boot using a user it says I don't have read/write permission, how can I change that? BTW i use RH7.2.
    --fstab--
    /dev/hda1 /windows/C ntfs ro,noauto,user,umask=022 0 2
    /dev/hdb1 /mnt/Shared vfat auto,user 0 0
    I don't believe that linux will alow you to mount a fat32 drive as /home, as there's no way to set up file permissions on fat32 like linux does on its native filesystems. You can, however, create a link to the drive in YOUR home directory so you don't have to wander to /mnt all the time...
    as su: ln -sv /mnt/Shared /home/<yer-user>/
    This will create a symbolic link (sort of like a windows 'shortcut') to the shared drive in your home directory.

    You're running NTFS on your Windows C...DO NOT try to enable write access to it! You *will* kill it. You'd have to recompile your kernel with ntfs write enabled, but DO NOT DO IT!
    RedHat 7.2 doesn't have any NTFS support by default, see http://www.getlinuxonline.com/omp/di...at/ompntfs.htm for more info.
    If you need to share files between OS's, setup another partition with fat32 or fat16 so that you can safely read & write to it, like you've done with your "shared" drive:

    Here's what my windrives look like under Mandrake 8.1:
    /dev/hda1 /mnt/winc ntfs iocharset=iso8859-1,umask=0 0 0
    /dev/hda5 /mnt/wind vfat iocharset=iso8859-1,umask=0,codepage=850 0 0

    2. How do go about using using desktop capture in KDE. I dont have gimp installed, so is there any other way?
    You should have gotten a util called ksnapshot installed with KDE. It might be labeled in the menu as "Screen Capture"...use that instead of installing Gimp.

  3. #3
    Sidomatic
    Guest

    Re:Linux woes!

    Okay....That still doesn't answer my question.

    Well first of all linux DOES allow you to mount fat32 as home with read/write permissions because I did it in Red Hat 7.1

    but that's besides the point. I need to know why my /mnt/Shared drive isn't letting my user account have read write permission, or what I should say is how can I get my 'user' be able to write to it?

    I'm not trying to get write access to my C: drive, I'm having problems with my /mnt/Shared drive. I can read and write to it just fine as root, but I need to be able to read/write to it as User.

    this is the line in my fstab I'm referring to:

    /mnt/Shared vfat auto,user 0 0

    What do I need to change it to, to make sure it mounts at startup, and that ALL users have read/write access to it

  4. #4
    JimH
    Guest

    Re:Linux woes!

    Quote Originally Posted by Sidomatic
    I'm not trying to get write access to my C: drive, I'm having problems with my /mnt/Shared drive. I can read and write to it just fine as root, but I need to be able to read/write to it as User.

    this is the line in my fstab I'm referring to:

    /mnt/Shared vfat auto,user 0 0

    What do I need to change it to, to make sure it mounts at startup, and that ALL users have read/write access to it
    There are a couple ways to do this. The easiest way to fix
    this is too add umask=0 to the mount options, but this isn't the best way.
    Mounting umask=0 gives ALL users, including users you might not want to have
    read/write access to the drive. The best way is to create a new group and use
    the gid mount option. Then any users you want to have access to the drive you
    make members of the group. Below is an example using a new group named
    "windows".

    Login as the root user

    Create a new group:
    #groupadd windows

    Find out what the new ID number for group is:
    #cat /etc/group | grep windows

    output will look similiar to this:
    windows:X:501:

    501 here is the new group ID

    make your user a member of the new group
    #usermod -G windows username

    Replace username with name of user you are adding to the group

    Check and see if you are now a member of the windows group
    #groups username

    output will look like this:
    username : username windows

    Edit /etc/fstab and save the changes:
    dev/hdb1 /mnt/shared vfat auto,users,gid=501,umask=007 0 0

    unmount and remount the drive
    #umount /mnt/shared
    #mount /mnt/shared

    The umask setting, umask=007, I used above is very restrictive you may not want it that way. You can change it to suit your needs.

    Jim H

Similar Threads

  1. DSL connection woes
    By jro in forum Linux - Hardware, Networking & Security
    Replies: 4
    Last Post: 02-17-2006, 05:05 PM
  2. RPM woes
    By mrkeef in forum Linux - Software, Applications & Programming
    Replies: 3
    Last Post: 01-01-2004, 01:21 AM
  3. XP / 2k woes
    By kornp in forum Windows - General Topics
    Replies: 19
    Last Post: 01-18-2003, 07:46 PM
  4. DSL WOES HELP!
    By DMAN in forum Mandriva
    Replies: 13
    Last Post: 09-12-2002, 09:02 PM
  5. Libranet Woes
    By johnqpublic in forum Linux - General Topics
    Replies: 8
    Last Post: 08-14-2001, 03:53 AM

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •