Page 1 of 2 12 LastLast
Results 1 to 10 of 18

Thread: Configuring Coyote for Real Player

  1. #1
    mudflap
    Guest

    Configuring Coyote for Real Player

    Any one know how to configure Real Player to work through a Coyote box. I have a line installed in the the firewall file.
    Ie. /sbin/modprobe ip_masq_raudio

    Not sure what else to do.
    Media player is working but Real Player won't

    Thanks
    Mud

  2. #2
    JimH
    Guest

    Re:Configuring Coyote for Real Player

    You need to open the ports Realplayer uses in your firewall script.

    This is what I used to have in my old ipchains firewall script. You will have to edit these for your setup.

    ipchains -A input -i $EXTERNAL_INTERFACE -p tcp ! -y \
    -s $ANYWHERE 7070:7071 \
    -d $IPADDR $UNPRIVPORTS -j ACCEPT

    ipchains -A output -i $EXTERNAL_INTERFACE -p tcp \
    -s $IPADDR $UNPRIVPORTS \
    -d $ANYWHERE 7070:7071 -j ACCEPT

    EXTERNAL_INTERFACE = ppp0 or eth0 or whatever you use
    ANYWHERE="any/0" This means from any ip address
    IPADDR = your ip address
    UNPRIVPORTS="1024:65535" This means only on ports from 1024 to 65535

    Little description.

    ipchains -A input -i $EXTERNAL_INTERFACE -p tcp ! -y

    Allow packets coming from your external interface, protocol TCP, ! -y <-- this means dont accept TCP packets that attempt to initiate a connection attempt.

    -s $ANYWHERE 7070:7071

    Allow packets coming from any ip address, but only ports 7070 and 7071

    -d $IPADDR $UNPRIVPORTS -j ACCEPT

    Allow packets coming to your ip address only on unprivileged ports.

    I believe Realplayer defaults to using ports 7070:7071. At least this is what I had before.

    Jim H



  3. #3
    mudflap
    Guest

    Re:Configuring Coyote for Real Player

    Thanks alot !! I will try this today
    Peter

  4. #4
    mudflap
    Guest

    Re:Configuring Coyote for Real Player

    Those ipchains you gave me. Are they only one line each??
    or should there be six? Do I replace the anywhere with any/0?

    So far not working for me. Once I have saved and backed up do I need to reboot?

    Thanks

  5. #5
    JimH
    Guest

    Re:Configuring Coyote for Real Player

    Quote Originally Posted by mudflap
    Those ipchains you gave me. Are they only one line each??
    or should there be six? Do I replace the anywhere with any/0?

    So far not working for me. Once I have saved and backed up do I need to reboot?

    Thanks
    They are actually 2 lines spread out over 6 lines. The \ at the end of the line means continued on the next line. Just makes the lines easier to read in the script.

    ANYWHERE and UNIPRIVPORTS are variables you need to replace them with numeric values if they are not defined in your script.

    Reboot Linux? No, you don't have to reboot. Just restart your firewall script. I'm not familiar with Coyote so I don't know exactly how they have things setup.

    Check your firewall logs also and see what packets are being rejected or dropped. Maybe your RealPlayer is setup to use another port other then 7070:7071.

    Jim H

  6. #6
    mudflap
    Guest

    Re:Configuring Coyote for Real Player

    Well I have tried to check the logs, but I am not sure which one to check. As you can tell I know about this damn thing.
    Nor do I want to know>>But I have to .
    Real Audio just won't work. I have added in all the lines you said. The module is loading...UGG!! 3 days on this damn thing.
    Yet Windows media player works great.
    ANy ideas????

    Thanks

  7. #7
    JimH
    Guest

    Re:Configuring Coyote for Real Player

    Unless Coyote uses a different file it will be logged to /var/log/messages. Did you check the settings in Real Player? I assume you mean Realplayer won't connect to any server?

    Jim H

  8. #8
    mudflap
    Guest

    Re:Configuring Coyote for Real Player

    Just checked the log only has a shutdown I did recently.
    Yes trying to get from my laptop to the outside.
    My company wants it setup.
    I have Real player setup to use ports 7070 and 7071.
    Udp. I have a proxy server here. But is setup according to microsoft with the same ports.
    Really weird and frusterating

    I will have to find out if the log files are kept elsewhere.
    I would think there should be alot more then that in them.

    Thanks
    Peter

  9. #9
    JimH
    Guest

    Re:Configuring Coyote for Real Player

    Quote Originally Posted by mudflap
    I have Real player setup to use ports 7070 and 7071.
    Udp.
    Udp? The ipchains rules I posted were for tcp. ;-) Add these Realplayer defaults to different ports for udp. If you use others change them below.

    ipchains -A input -i $EXTERNAL_INTERFACE -p udp \
    -s 0.0.0.0/0 1024:65535 \
    -d your ip 6970:6999 -j ACCEPT

    ipchains -A output -i $EXTERNAL_INTERFACE -p udp \
    -s your ip 1024:65535 \
    -d 0.0.0.0/0 1024:65535 -j ACCEPT
    Jim H

  10. #10
    mudflap
    Guest

    Re:Configuring Coyote for Real Player

    Thanks for all your help on this..
    Still not working..I have added all the stuff and nothing.
    Real player immediatly says can't contact.
    I have it set to use ports 7070:7071 which I reflected in the script.
    proxy server is setup up...Argg this is so frusterating.

    Do I need to add anything else???

Similar Threads

  1. Real Player
    By subban in forum Suse
    Replies: 5
    Last Post: 12-07-2006, 12:45 PM
  2. Real Player 10
    By coltrane in forum Linux - Software, Applications & Programming
    Replies: 5
    Last Post: 08-26-2004, 05:23 AM
  3. Real Player
    By mugs in forum Linux - Software, Applications & Programming
    Replies: 7
    Last Post: 12-14-2002, 08:07 AM
  4. Real Player
    By klrmar in forum Linux - General Topics
    Replies: 18
    Last Post: 04-16-2002, 01:14 PM
  5. Real Player and Yahoo
    By sarge7141 in forum Linux - Hardware, Networking & Security
    Replies: 3
    Last Post: 04-14-2002, 09:07 PM

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •