Results 1 to 8 of 8

Thread: Kernel 2.4.18 and gcc3.0.4

  1. #1

    Kernel 2.4.18 and gcc3.0.4

    Hi,
    I've been trying to compile kernel 2.4.18 on my Slackware 8 box. *I have running kernel 2.2.19 and gcc2.9.x (the default that Slackware 8 installs..)
    While checking the readme, I noticed it said you need gcc3.0 to compile it. I downloaded from the Slack site gcc3.0.4, and used pkgtool to install it. *However, when trying to make xconfig or menuconfig for the kernel, I get an error saying it cannot find ncurses (same error LiNuts is getting on his thred...). *If I take out gcc3.0.4 and compile it with gcc2.9.x, it compiles fine, without me getting any error message. *However, after doing all the stuff, I cannot get it to boot up to that kernel (following all the steps in the Kernel_Howto and the article on Vodoo Linux, the one on this site and the Slack book...). *I just get a blinking screen, no posting or anything. *I made sure to add the correct boot path in lilo and all that good stuff.
    I guess I have a couple of questions:
    1. *Is there any special step I need to take when upgrading gcc?
    2. *Anyone has seen that behaviour after compiling the kernel (just a screen that show no posts or anything)?
    3. *Anyone has any idea what may I be missing?

  2. #2
    Guest

    Re: Kernel 2.4.18 and gcc3.0.4

    2.95.3 compiles 2.4.18 just fine on my boxen... but then again, I tell myself that I know what I'm doing...

  3. #3

    Re: Kernel 2.4.18 and gcc3.0.4

    I know. It compiled for me fine, without any error messages, but after that, it wouldn't boot to that kernel. I wonder if I am missing any step... :-/

  4. #4
    Guest

    Re: Kernel 2.4.18 and gcc3.0.4


    I know. It compiled for me fine, without any error messages, but after that, it wouldn't boot to that kernel. I wonder if I am missing any step... :-/
    Then you did something wrong, did you remember to compile in support for all your hardware, and did you update lilo correctly ?

  5. #5

    Re: Kernel 2.4.18 and gcc3.0.4

    Yes, I went in an checked on all the options for the configuration file, and they seem ok (done this ticw already...) and updated lilio.conf and ran lilo after that.
    Seems like it is not finding the kernel image, though...

    Oh, BTW, I was wrong about what gcc it needs. *This is what the readme says :
    Make sure you have gcc-2.91.66 (egcs-1.1.2) available. *gcc 2.95.2 may
    * also work but is not as safe, and *gcc 2.7.2.3 is no longer supported*.
    * Also remember to upgrade your binutils package (for as/ld/nm and company)
    * if necessary.

  6. #6

    Re: Kernel 2.4.18 and gcc3.0.4

    I got it to boot finally, though I don't know what I did different. I might have been missing a step. I am getting some error messages when booting up, but I can probably figure them out. Thanks.

  7. #7

    Re: Kernel 2.4.18 and gcc3.0.4

    what is in /var/log/dmesg ?

  8. #8

    Re: Kernel 2.4.18 and gcc3.0.4


    what is in /var/log/dmesg ?
    I'm going to post it on a new thread.

Similar Threads

  1. Installing gcc3.1 in mandrake 8.2
    By Braveo in forum Mandriva
    Replies: 0
    Last Post: 07-31-2002, 12:15 AM
  2. Compiling Apache and gcc3
    By Freakazoid in forum Linux - Software, Applications & Programming
    Replies: 1
    Last Post: 06-14-2002, 09:56 PM
  3. Kernel 2.4.17 is out
    By pbharris in forum General Chat
    Replies: 16
    Last Post: 12-24-2001, 04:46 AM
  4. kernel.org ?
    By civ1492 in forum General Chat
    Replies: 4
    Last Post: 12-04-2001, 11:46 AM
  5. Kernel 2.4.14 is out
    By cloverm in forum General Chat
    Replies: 12
    Last Post: 11-23-2001, 03:01 PM

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •