I have been using ppp with a direct phone connection from one host to another for the last several months without problems. The ppp server was on a machine running Redhat 6.0, and the ppp client was on a Redhat 6.2 box. I replaced the client machine with a machine running Redhat 7.1, and it connected to the Redhat 6.0 ppp server fine. I then replaced the ppp server with a new machine running Redhat 7.1, and now the new ppp client running Redhat 7.1 cannot connect to the new ppp server running Redhat 7.1.

When the client calls the ppp server, the modems negotiate the carrier signals, and then hang up. I get the following messages in syslog.

--------------------------------------------------------------------
mgetty[1879]: data dev=ttyS5, pid=1879, caller='none', conn='38400', name='', cmd='/bin/login', user='ppp'
login(pam_unix)[1879]: session opened for user ppp by LOGIN(uid=0)
login -- ppp[1879]: DIALUP AT ttyS5 BY ppp
login -- ppp[1879]: LOGIN ON ttyS5 BY ppp
pppd[1891]: using the noauth option requires root privilege
login(pam_unix)[1879]: session closed for user ppp
mgetty[7881]: TIOCMBIS failed: Input/output error
mgetty[7881]: cannot turn off soft carrier: Input/output error
mgetty[7881]: tcgetattr failed: Input/output error
mgetty[7881]: cannot get TIO: Input/output error
mgetty[7881]: init chat failed, exiting...: Invalid argument
mgetty[7881]: failed in mg_init_data, dev=ttyS5, pid=7881
mgetty[7882]: failed dev=ttyS5, pid=7882, got signal 15, exiting
--------------------------------------------------------------------

The permissions on /usr/sbin/pppd for both client and server are -rwsr-xr-x
My options for the ppp client are
lock
hide-password
defaultroute
crtscts
modem
asyncmap 0

I use the following command on the client to connect to the server
/usr/sbin/pppd 192.168.1.1: connect '/usr/sbin/chat -v -f /root/.pppscript.server' defaultroute 115200 /dev/modem
(I'm using static addressing).

Does anyone know what I'm doing wrong with Redhat 7.1 that works with a Redhat 6.0 ppp server? I would be greatful for any assistance. -- Thanks.

rdly
gjaffe@bigplanet.com