Warning: Function ereg() is deprecated in ..../includes/class_postbit.php(345) : eval()'d code on line 4

Warning: Function split() is deprecated in ..../includes/class_postbit.php(345) : eval()'d code on line 19

Warning: Function ereg() is deprecated in ..../includes/class_postbit.php(345) : eval()'d code on line 4

Warning: Function split() is deprecated in ..../includes/class_postbit.php(345) : eval()'d code on line 19

Warning: Function ereg() is deprecated in ..../includes/class_postbit.php(345) : eval()'d code on line 4

Warning: Function split() is deprecated in ..../includes/class_postbit.php(345) : eval()'d code on line 19

Warning: Function ereg() is deprecated in ..../includes/class_postbit.php(345) : eval()'d code on line 4

Warning: Function split() is deprecated in ..../includes/class_postbit.php(345) : eval()'d code on line 19

Warning: Function ereg() is deprecated in ..../includes/class_postbit.php(345) : eval()'d code on line 4

Warning: Function split() is deprecated in ..../includes/class_postbit.php(345) : eval()'d code on line 19

Warning: Function ereg() is deprecated in ..../includes/class_postbit.php(345) : eval()'d code on line 4

Warning: Function split() is deprecated in ..../includes/class_postbit.php(345) : eval()'d code on line 19

Warning: Function ereg() is deprecated in ..../includes/class_postbit.php(345) : eval()'d code on line 4

Warning: Function split() is deprecated in ..../includes/class_postbit.php(345) : eval()'d code on line 19

Warning: Function ereg() is deprecated in ..../includes/class_postbit.php(345) : eval()'d code on line 4

Warning: Function split() is deprecated in ..../includes/class_postbit.php(345) : eval()'d code on line 19

Warning: Function ereg() is deprecated in ..../includes/class_postbit.php(345) : eval()'d code on line 4

Warning: Function split() is deprecated in ..../includes/class_postbit.php(345) : eval()'d code on line 19

Warning: Function ereg() is deprecated in ..../includes/class_postbit.php(345) : eval()'d code on line 4

Warning: Function split() is deprecated in ..../includes/class_postbit.php(345) : eval()'d code on line 19
Mozilla
Page 1 of 2 12 LastLast
Results 1 to 10 of 11

Thread: Mozilla

  1. #1
    garskoci
    Guest

    Mozilla

    I am currently searching for a browser. Netscape locks up periodically from Java. So, Iím fiddling with Mozilla. It seems to me that Mozilla is just a wrapper for Netscape components. Any truth to that? Same buttons, same plug-ins, terminology etc. Why use it? Why not just stick with Netscape?

  2. #2
    JimH
    Guest

    Re: Mozilla

    Actually it is the other way around. The netscape 6.x series is based on the Mozilla code. Mozilla is based on netscape's gecko rendering engine. However, the codebase IS NOT identical between netscape 6.x and Mozilla.

    You can change the appearance of the browser. Look under View/Apply Theme. There are only 2 installed by default classic and modern. There are many themes you can download View/Apply themes/Get new themes.


  3. #3
    garskoci
    Guest

    Re: Mozilla

    JimH - Right now I'm running version .7. Do you think that I should upgrade? OS is Redhat 7.1. I tried to install the Java plug-in and puked all over itself. I was thinking that the new Java plug-in might not be the correct version for the browser.

  4. #4
    JimH
    Guest

    Re: Mozilla

    Yes, definitely upgrade. The version of Mozilla that came with RedHat 7.1 is very old and no where near as stable as the current 0.9.4 release. You can download rpms built for RedHat 7.x from:

    http://ftp.mozilla.org/pub/mozilla/r...S/i3<br /> 86/

    The lastest is 0.9.4-2. Which I didn't know was out I was using 0.9.4-0. ;D I just upgraded.

    What java plugin did you try to install? This is the one that works very well on RedHat 7.1:

    http://java.sun.com/j2se/?frontpage-javaplatform

    There are 2 java versions listed. The one I'm currently using 1.3.1. I didn't know the 1.4 beta was out, going to try it out right now. ;D

    You can download either the JDK or just the runtime environment, it is all you need. Make sure you remove any old Java plugins you have installed. As the root user with mozilla not running:

    Change to the directory where you downloaded the Java rpm
    chmod a+x j2sdk-1_3_1-linux-i386-rpm.bin

    Extract the rpm:
    ./j2sdk-1_3_1-linux-i386-rpm.bin

    Install the rpm:
    rpm -ivh jdk-1.3.1.i386.rpm

    Create a symlink:
    cd /usr/lib/mozilla/plugins
    ln -s /usr/java/jdk1.3.1/jre/plugin/i386/ns600/libjavaplugin_obj.so .

    You will have to change the above as necessary. The above is based on downloading the JDK1.3.1 and installing it in the default location. Now start Mozilla and type in the address bar:

    http://java.sun.com

    Mozilla will crash this is a known bug with Java 1.3.1. If you downloaded the 1.4 beta this might not happen. ;D Restart Mozilla goto the Sun webite again. The plugins should load. Close Mozilla again and restart it. Now your set, Java should work fine now. If Java doesn't work, in Mozilla, from the menu Help/About plugins in Mozilla if the plugin is not listed you probably created the link wrong.

    Jim H

  5. #5
    JimH
    Guest

    Re: Mozilla

    Ok, Don't download Java 1.4.0 beta. I could not get Mozilla to recognize the plugin. Use Java 1.3.1 for now.

    Jim H

  6. #6
    bdl
    Guest

    Re: Mozilla

    JimH -

    Very cool! I hadn't bothered to setup java with mozilla until now, it was a snap! Thanks!

  7. #7
    JimH
    Guest

    Re: Mozilla


    JimH -

    Very cool! I hadn't bothered to setup java with mozilla until now, it was a snap! Thanks!
    Glad I could help! I knew I was good for something. ;D

  8. #8
    garskoci
    Guest

    Re: Mozilla

    JimH- OK, I'm a moron. I tried to upgrade to the most recent version of Mozilla. First, through RPM, I removed the original version. Second, I installed the new version. I tried to fire up the new version and it doesn't load. After looking through the scripts, I didn't really see anything. Here's the message that I received.
    From the command line I ran => ./run-mozilla.sh
    It seems as though it can't load the shared lib: libmsgbaseutil.so, with good reason. It's not there!
    Do I need to upgrade all of Mozilla's components? Such as this instant messaging of Mozilla's email?
    Here's the output.
    Thank's for your help.

    MOZILLA_FIVE_HOME=.
    LD_LIBRARY_PATH=.:./plugins:/usr/lib
    LIBRARY_PATH=.:./components
    SHLIB_PATH=.
    LIBPATH=.
    ADDON_PATH=.
    MOZ_PROGRAM=./mozilla-bin
    MOZ_TOOLKIT=
    moz_debug=0
    moz_debugger=
    **************************************************
    nsNativeComponentLoader: SelfRegisterDll(/usr/lib/mozilla/components/libabsyncsvc.so) Load FAILED with error: libmsgbaseutil.so: cannot load shared object file: No such file or directory
    **************************************************
    **************************************************
    nsNativeComponentLoader: SelfRegisterDll(/usr/lib/mozilla/components/libaddrbook.so) Load FAILED with error: /usr/lib/mozilla/components/libaddrbook.so: undefined symbol: Implementation__C8nsString
    **************************************************
    ./mozilla-bin: error while loading shared libraries: /usr/lib/mozilla/components/libimpText.so: undefined symbol: StartAssignmentByValue__14nsXPIDLCString

  9. #9
    JimH
    Guest

    Re: Mozilla

    How did you try and install the lastest version of Mozilla? Did you download the new rpms or the tar.gz? You don't have to remove the old Mozilla rpm's before installing the new ones. All you have to do is change to the directory where you downloaded the new rpm's and then to upgrade to the new version:

    rpm -Fvh mozilla*.rpm

    or

    rpm -Uvh mozilla*.rpm

    You should at least install these rpm's:

    mozilla
    mozilla-mail
    mozilla-psm

    These are the one's installed by default on RH 7.1. The others are optional.

  10. #10
    garskoci
    Guest

    Re: Mozilla

    JimH - Mozilla is up and running! Java and all!!! Thanks for your help. If I can only keep Zmail from dropping the attachments.
    Thanks again.

Similar Threads

  1. Mozilla Firefox 1.0.2 + Mozilla Thunderbird 1.0.2 Released!
    By shebang in forum Linux - Software, Applications & Programming
    Replies: 3
    Last Post: 04-17-2005, 02:49 AM
  2. Mozilla and XBL
    By mugs in forum Linux - Software, Applications & Programming
    Replies: 6
    Last Post: 07-21-2002, 01:35 AM
  3. about:mozilla
    By pbharris in forum General Chat
    Replies: 6
    Last Post: 05-14-2002, 01:05 PM
  4. Mozilla 0.9.9
    By cloverm in forum General Chat
    Replies: 9
    Last Post: 03-14-2002, 12:15 AM
  5. Mozilla 0.9.4
    By papanohair in forum Linux - Software, Applications & Programming
    Replies: 4
    Last Post: 12-10-2001, 11:22 AM

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •