Warning: Function ereg() is deprecated in ..../includes/class_postbit.php(345) : eval()'d code on line 4

Warning: Function split() is deprecated in ..../includes/class_postbit.php(345) : eval()'d code on line 19

Warning: Function ereg() is deprecated in ..../includes/class_postbit.php(345) : eval()'d code on line 4

Warning: Function split() is deprecated in ..../includes/class_postbit.php(345) : eval()'d code on line 19

Warning: Function ereg() is deprecated in ..../includes/class_postbit.php(345) : eval()'d code on line 4

Warning: Function split() is deprecated in ..../includes/class_postbit.php(345) : eval()'d code on line 19

Warning: Function ereg() is deprecated in ..../includes/class_postbit.php(345) : eval()'d code on line 4

Warning: Function split() is deprecated in ..../includes/class_postbit.php(345) : eval()'d code on line 19
Date Settings
Results 1 to 4 of 4

Thread: Date Settings

Hybrid View

  1. #1
    Junior Member
    Join Date
    Jul 2001
    Posts
    91

    Date Settings

    I know this is probably a stupid question, and I have tried to work it out...

    How do I change the sytem default date format from US style (mm/dd/yy) to UK/Australian style (dd/mm/yy)? I am finding that in some software apps which take their information from the sytem they are printing the dates in the "wrong" format.

    I'm running RH 7.1 and using Gnome. I've looked in the Gnome setup and config settings and haven't found anything that looks appropriate.

    Thanks

    Keith

  2. #2
    JimH
    Guest

    Re: Date Settings

    Look in /etc/sysconfig/i18n. Look at LANG=
    I believe the setting for english Australian is en_AU

    It is possible that the application you are trying to print from only supports one date format. Anyway to change the format in the program itself?

    After changing /etc/sysconfig/i18n you will have to logout and login for the new settings to take effect.

  3. #3
    Junior Member
    Join Date
    Jul 2001
    Posts
    91

    Re: Date Settings

    Thanks Jim.

    I checked out /etc/sysconfig/i18n and it already says LANG = en_AU, so that's not the problem. I also checked out the other files in the directory looking for date defaults but there wasn't anything that was obvious.

    It's not software specific. Quicken shows the dates correctly under windows but when I run it under wine it shows dates in the US format- this is for exactly the same data files. I wouldn't worry too much but I have to publish financial reports and it may cause some confusion.

    Also Star Office accepts dates in UK format in my database forms, but when I run a query on the database it returns the dates in US format!

    Any other ideas? Thanks!

    Keith

  4. #4
    JimH
    Guest

    Re: Date Settings

    I checked the default date format for the en_AU setting. It shows the format as being d/m/y. You can check it by using:
    locale -ck LC_TIME

    It sounds like wine doesn't have i18n support. I looked on their website, but I don't see anything. Did you check the language settings in StarOffice and see how they are set? Maybe they are set to use english US.


Similar Threads

  1. replace date using sed
    By svar in forum Linux - Software, Applications & Programming
    Replies: 0
    Last Post: 11-17-2010, 04:30 AM
  2. I got a date!!!
    By gmoreno in forum General Chat
    Replies: 37
    Last Post: 04-25-2003, 04:04 AM
  3. %s fomat for date
    By Blaqb0x in forum Linux - Software, Applications & Programming
    Replies: 1
    Last Post: 12-11-2002, 10:37 PM
  4. Keeping configs up to date
    By SwampDonkey in forum Linux - Software, Applications & Programming
    Replies: 4
    Last Post: 11-24-2002, 09:29 PM
  5. Release date for RH7.4?
    By Blaqb0x in forum Linux - General Topics
    Replies: 3
    Last Post: 09-10-2002, 03:57 PM

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •