Results 1 to 6 of 6

Thread: QT-1.45 and 2.0 lib

  1. #1
    nfallon
    Guest

    QT-1.45 and 2.0 lib

    I'm trying to install an application and getting an error when trying to configure. The error is Qt (>=1.45 and < 2.0) (libraries)
    not found.

    Where can I download the libraries. I did a google search but it came up with the same sort of problems that people are having but no solutions.

    Neil



  2. #2
    JimH
    Guest

    Re: QT-1.45 and 2.0 lib

    Hmmm, must be an old application not to be using the Qt2 libraries. What distribution and version of Linux are you using?

    Jim H

  3. #3
    nfallon
    Guest

    Re: QT-1.45 and 2.0 lib

    Hmmm, must be an old application not to be using the Qt2 libraries. What distribution and version of Linux are you using?

    Jim H


    It's Mandrake 8.1


  4. #4
    JimH
    Guest

    Re: QT-1.45 and 2.0 lib

    Well, looking at the rpm's for Mandrake 8.1 on their ftp site, it looks like they don't provide QT-1.45 any longer. :-( Little strange that they don't, Redhat still provides them with 7.2.

    There are Qt-1.44 rpm's for Mandrake 8.0, but from your error message, Qt (>=1.45 and < 2.0), it looks like you will need 1.45. However, they still may work.

    You can still download Qt-1.45 from TrollTech and compile it yourself.

    ftp://ftp.trolltech.com/qt/source

    Using either of these options you will probably still have to pass the location of Qt to configure.

    --with-qt-includes=DIR where the Qt includes are.
    --with-qt-libraries=DIR where the Qt library is installed.

    ./configure --help shows the options available.

    Is there possibly an updated version of the program you are trying to compile that uses the current QT2.x libraries?

    Jim H

  5. #5
    nfallon
    Guest

    Re: QT-1.45 and 2.0 lib

    Hi Jim,

    Thanks for the info. I changed the path to QT2 and it seems to have cleared up the problem. The error has gone away.

    Neil

  6. #6
    JimH
    Guest

    Re: QT-1.45 and 2.0 lib

    Hi Jim,

    Thanks for the info. I changed the path to QT2 and it seems to have cleared up the problem. The error has gone away.
    Interesting, from the error message you were getting it looked like it wanted < 2.0 Qt (>=1.45 and < 2.0) (libraries)
    not found.


    At least it is working, thats all that counts. ;D

    Jim H

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •