Page 1 of 5 123 ... LastLast
Results 1 to 10 of 46

Thread: Video Problems (Newbie)

  1. #1
    waltnjulie
    Guest

    Video Problems (Newbie)

    I've been trying everything to get the video configuration to work with my MediaGX computer. I'm a complete newbie trying to set up Debian potato. I got the monitor specs easily enough on the web, but the built-in video for the MediaGX is harder to find. I played with the numbers in xf86Config, and I've gone from text (that worked) to, well, something that looks like it should work but doesn't. I have a sort-of graphical interface now. : The resolution seems to be stuck at 640x480, since xfree deleted all the other options. It's not stable, and goes into a shimmer at the slightest excuse. I can make menus pop up, but they don't *do* anything, and the mouse won't move from the bottom of the screen. And I can't get back into text mode. If I press Ctrl-Alt-Backspace it goes to text for a second, then back into the graphical mode. It won't stabilize there. So now I'm having trouble making any more changes that might help. From here I'm having trouble even getting back to xf86config. Any suggestions would be welcome.

  2. #2
    jman_77
    Guest

    Re: Video Problems (Newbie)

    Oh wow... multiple problems going on here. You'll want to first drop XF86 back down to the default vga mode.
    go to /var/log and open XFree86.0.log. You're looking for a line similar to this one:
    (==) Using config file: "/etc/X11/XF86Config-4"
    It may not be exactly that file or path, but that's what you're looking for. Switch to the directory mentioned above, su to root, and open that config file.
    Now, you're looking for something like this:

    # ************************************************** ********************
    # Graphics device section
    # ************************************************** ********************

    Section "Device"
    Identifier "Generic VGA"
    Driver "vga"
    EndSection


    If that's not there, add it... if there's anything there about another card, delete it. Now, scroll down and find this.
    # ************************************************** ********************
    # Screen sections
    # ************************************************** ********************

    Section "Screen"
    Identifier "screen1"
    Device "NVIDIA GeForce 256 (generic)"
    Monitor "monitor1"
    DefaultColorDepth 16
    Subsection "Display"
    Depth 8
    Modes "1280x1024" "1024x768" "800x600" "640x400"
    ViewPort 0 0
    EndSubsection
    Subsection "Display"
    Depth 16
    Modes "1280x1024" "1024x768" "800x600" "640x480"
    ViewPort 0 0
    EndSubsection
    EndSection

    Change "Nvidia Geforce" to "Generic VGA" (sorry, this is all copied out of my config files)
    Save, quit, and restartX

    That should give you a little more legible X interface. Now, you said ctrl-alt-backspace isn't killing X... Well.. that's a runlevels problem, likely because you set your system to start x on boot. I can't recall how to fix that off the top of my head. The instructions above should help you get X working okay. Use a boot disk to get to a command prompt if you need to.
    Chapter 2 coming tomorrow.. it's almost 4 in the morning and I need to go to sleep. Hope this helps, let us know

  3. #3

    Re: Video Problems (Newbie)

    Jman has a good suggestions, but doesn't know the woes of Debian!

    I am struggling through potato right now too and I am having quite a few of the problems your having now. First, your Video card with a NVidia is not going to work with the kernel that is distributed with potato. You will have to goto

    http://www.kernel.org

    and get the latest kernel, 2.4.7. Follow their instructions on how to recompile your kernel, it is difficult but it will work for you after a bit. We'll also be able to help you here with that.

    Now your going to have to goto

    http://www.xfree86.org

    to get the latest xfre86 server. See the problem is that potato comes with Xfre86 3.3.6 and you need a 4.x.x version. The newer x server comes with some builtin nvidia compatibility for the new nvidia drivers.
    Now you need to goto

    http://www.nvidia.com

    and download the latest nvidia drivers, you have to get the
    tar.gz files because debian doesn't support rpm's.

    Now as far as booting up into the graphical mode I am like Jman, I don't remember how to remove this without doing it the hardway so I am going to tell you how I got around it.

    When it boots up into the graphical mode...since you got it to work a bit it isn't like mine where you can't see ANYTHING at all...you need to type

    ctrl+alt+F2

    this will take you to tty2 it is a virtual terminal that you'll be able to access console mode. Now goto the directory /etc/X11 and type

    rm XF86*

    this will delete all of your xf86 config files...yes this is what you want, trust me....

    now from here I am not going to write this thing all over again. I have submitted an OMP, just goto the main page and goto OMP and the Nvidia driver installation is what your going to have to click on....then I would suggest going to the text version and printing it out to follow. That will get you up and running with the video card. I am also guessing that with the new version of XFree86 your mouse problems will be solved as well, as well as your keyboard problems. If not we'll work that out after you install XFree86...it will just have to do with toying with your config file......

    one of the nicest ways once you get the new x server installed is to run XF86Setup from the prompt...that way you can choose your port and such...more than likely if it is a usbmouse it is on port /dev/psaux in debian..that is where it stuck mine...but if it is a ps2 mouse it is probably /dev/mouse, but like I said we'll get to that later...get that stuff installed and we'll be able to work through the rest with you very easily. You have a long night ahead of you anyways. Welcome to the world of Debian!

    Aragorn
    If you give a man a fire he'll be warm, if you light the man on fire he'll be warm for life.

  4. #4
    waltnjulie
    Guest

    Re: Video Problems (Newbie)

    Okay, I think I can try it. Remember, I don't have an nVidia card; I think that was Jman's example. I have a MediaGX, which has no separate video card. XF86 3.3.6 is supposed to work with mediagx (it's number 427 on the list, if I remember correctly). But it doesn't seem to work, and I think the other settings have to be tweaked to get any results. The display I have is the result of a few hours studying the Video Timing How-To and playing with the numbers for the display settings. Supposedly the SVGA driver will handle it.

    I did sleep eventually last night, so I'm tackling this now. Ctrl-Alt-F2 did get me out of graphics mode, so that's one positive step. I hope I don't need to get web updates just to get up and running--I haven't even plugged in a phone line yet, and I'm using my WinMe machine to communicate.

    Julie

  5. #5

    Re: Video Problems (Newbie)

    Oh, sorry about that!!! That is my fault....I didn't read very well...Jman can kick me for that later!

    Umm...hmmm......lets see.....you might want to run XF86Setup, and play with the settings visually....but to do this you'll have to delete the XF86Config file like I showed you then reboot and you'll goto console rather than that blasted log in screen. Then run XF86Setup (case sensitive). You should be able to set up your mouse and keyboard to work fine through there too....choose your card and then goto advance setup or card details, whatever it says I can't remember it is in the bottom right of the screen. And tweak the settings....I wouldn't mess with setting the speed...autoprobing should do that.....try that before downloading all that junk that I told you...that was my fault...sorry about that.....detail is key and I lost the key I guess!

    Aragorn
    If you give a man a fire he'll be warm, if you light the man on fire he'll be warm for life.

  6. #6
    waltnjulie
    Guest

    Re: Video Problems (Newbie)

    I can't run XF86Setup; I just get shimmery diagonal lines. I used xf86config to start with, and still got nothing until I started tweaking numbers. I tried your suggestion of starting over with the VGA server, and I still get nothing at all, not even the nonfunctional display I had before. Looks like the system tried to boot into graphical mode (Flashed a few times) then went back to console.

    Julie

  7. #7

    Re: Video Problems (Newbie)

    Did you delete the XF86Config file???

    you have to do this

    cd /etc/X11
    rm XF86C*

    then reboot

    it won't be able to load the windows manager because it has nothing to go on...then your XF86Setup should work....

    Aragorn
    If you give a man a fire he'll be warm, if you light the man on fire he'll be warm for life.

  8. #8
    waltnjulie
    Guest

    Re: Video Problems (Newbie)

    Yeah,but... XF86Setup is a graphical program. Why would I expect it to work when I'm having graphics problems?

  9. #9

    Re: Video Problems (Newbie)

    it is graphical...but only simplified graphics....should work on any graphics card......my situation was a lot worse than yours.....x server would screw up my vcard totally, making the screen totally unusable even when I switched tty's....XF86Setup should work....but if it isn't then I guess you gotta stick with xf86config...hmmm....I would attempt to not even try selecting your card....but I would try skipping the card selection and just loading the XF86_SVGA server...and then make sure your monitor settings are correct....that might get it up and going for ya. If it does, but still looks to big, to small...then type

    ctrl+alt+ +
    or
    ctrl+alt+ -

    to adjust the resolution settings....see if that does anything for ya! We will get you through this! I promise! ;D

    Aragorn
    If you give a man a fire he'll be warm, if you light the man on fire he'll be warm for life.

  10. #10
    waltnjulie
    Guest

    Re: Video Problems (Newbie)

    Maybe this would help:

    I just reran xf86config (after deleting the file). Now it doesn't leave console mode at all. I have a long string of messages stating that the various modes need hsync freq greater than my monitor allows. At the end is: Config error: /usr/X11R6/lib/XF86Config:542
    ViewPort 0 0
    Mode name expected

    I interpret this as meaning that none of the possible modes in XF86Config are supported by my monitor? This is why I was tinkering with timing in the first place.

Similar Threads

  1. Dell GX270 Intel 82865G chipset video problems with Linux
    By starfish in forum Linux - Software, Applications & Programming
    Replies: 0
    Last Post: 09-22-2005, 07:27 AM
  2. linux newbie: KPPP problems
    By vetrivelsn in forum Linux - General Topics
    Replies: 5
    Last Post: 01-16-2005, 12:21 AM
  3. FreeBSD Video problems
    By in forum BSD
    Replies: 13
    Last Post: 02-25-2003, 05:16 AM
  4. MOVED: FreeBSD Video problems
    By kenshi in forum General Chat
    Replies: 0
    Last Post: 01-22-2003, 04:09 AM
  5. Install problems with RedHat 8.0 (Video Related) Please help.
    By Nekronos in forum Linux - Hardware, Networking & Security
    Replies: 3
    Last Post: 01-05-2003, 11:23 PM

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •