Page 2 of 3 FirstFirst 123 LastLast
Results 11 to 20 of 24

Thread: sound blaster live not working on redhat 7.2

  1. #11
    JimH
    Guest

    Re: sound blaster live not working on redhat 7.2

    chmod ugo+rwx /dev/dsp

    There is actually a better way that doesn't compromise your system so much. You could add your user to the sys group under /etc/group if your running slackware and achieve the samething without messing with permissions. You could also create a group in /etc/group called audio, then do a chgrp audio /dev/dsp*; /dev/audio*; /dev/mixer* and then add your user to group audio, which would allow access to the sound device.
    This isn't necessary Red Hat sets the device ownership to the user when the user logs in.

    Jim H

  2. #12
    dook
    Guest

    Re: sound blaster live not working on redhat 7.2

    ok so i ran %/sbin/modprobe emu10k1
    and got error: no such file or directory

    then i ran
    /sbin/lsmod

    and the emu10k1 module is listed, but under used by it says 0 (autoclean)

    then i ran modprobe sound-slot-0 and nothing happened

    i looked in the error log and it says:
    Feb 13 13:15:42 6532113hfc69 modprobe: modprobe: Can't locate module sound-slot-1
    Feb 13 13:15:42 6532113hfc69 modprobe: modprobe: Can't locate module sound-service-1-0

    any ideas?

  3. #13
    JimH
    Guest

    Re: sound blaster live not working on redhat 7.2

    /sbin/lsmod

    and the emu10k1 module is listed, but under used by it says 0 (autoclean)

    then i ran modprobe sound-slot-0 and nothing happened
    If the module is listed it is loaded. Did you check your mixer setting and see if the volume is turned down/muted or the speaker inputs are disabled?

    /sbin/lsmod should list these.

    emu10k1 59200 0 (autoclean)
    sound 58380 0 (autoclean) [emu10k1]
    soundcore 4164 7 (autoclean) [emu10k1 sound]

    You will get more feedback using: modprobe -v sound-slot-0

    i looked in the error log and it says:
    Feb 13 13:15:42 6532113hfc69 modprobe: modprobe: Can't locate module sound-slot-1
    Feb 13 13:15:42 6532113hfc69 modprobe: modprobe: Can't locate module sound-service-1-0
    Harmless don't worry about these.

    Jim H

  4. #14
    dook
    Guest

    Re: sound blaster live not working on redhat 7.2

    when i run /sbin/ldmod
    i don't see the sound one

    i see
    emu10k1 and
    soundcore


  5. #15
    JimH
    Guest

    Re: sound blaster live not working on redhat 7.2

    when i run /sbin/ldmod
    i don't see the sound one

    i see
    emu10k1 and
    soundcore
    OK it looks like sound isn't required on older kernel versions. I looked at the emu10k1 module dependencies on the 2.4.9-21 kernel for 7.2. I don't have anything older then that installed. What kernel are you using and did you look at your mixer settings?

    Jim H

  6. #16
    dook
    Guest

    Re: sound blaster live not working on redhat 7.2

    yup looked at the mixer settings.. everything looked fine.

    i just updated my kernel last night, but how do i see the number?

    if i updated the kerner to the most recent, then shouldn't i see sound?

  7. #17
    JimH
    Guest

    Re: sound blaster live not working on redhat 7.2

    yup looked at the mixer settings.. everything looked fine.

    i just updated my kernel last night, but how do i see the number?

    if i updated the kerner to the most recent, then shouldn't i see sound?
    To see what kernel is running: uname -r

    You don't have any sound at all? system sounds? music cd? mp3? anything? Gnome? KDE?

    Something is strange. Is this a SB Live 5.1?

    Jim H

  8. #18
    dook
    Guest

    Re: sound blaster live not working on redhat 7.2

    that is correct.. wavs, mp3s, system.. all i get is system beeps

    i'm running kde.

    it is the latest version of soundblaster live.

    there is something strange, i feel like i'm missing one little thing that is causing this problem.

    should i try uninstalling and reinstalling the module? is that even possible?

    my speakers take a digital input.. is there some setting that i need to check somewhere?



  9. #19
    JimH
    Guest

    Re: sound blaster live not working on redhat 7.2

    should i try uninstalling and reinstalling the module? is that even possible?
    You can unload the module with:

    /sbin/rmmod emu10k1
    /sbin/rmmod soundcore

    and then reload it.

    /sbin/modprobe -v sound-slot-0

    You will probably have to logout, log back in or at least restart aRTS, the KDE sound server. Probably better off logging out.

    my speakers take a digital input.. is there some setting that i need to check somewhere?

    That could be a problem. I have never tried hooking my SB Live to the digital input on my speakers. I never got around to buying the adapter I need. Can you hook your speakers up to the analog input to try and see if you get any sound.

    Jim H

  10. #20
    Aaron_Adams
    Guest

    Re: sound blaster live not working on redhat 7.2

    Jim, just so you know SkyNet's comment on permissions was directed towards me, regarding slackware

Similar Threads

  1. Sound Blaster isa
    By eugeniom in forum Redhat / Fedora
    Replies: 2
    Last Post: 01-12-2008, 05:35 PM
  2. Sound problems with FC3 - Now FC4 still working on it - help!
    By DamselNDistress in forum Linux - General Topics
    Replies: 30
    Last Post: 07-31-2005, 11:51 PM
  3. Sound Blaster Live LS 5.1
    By comtux in forum General Chat
    Replies: 9
    Last Post: 02-14-2005, 08:43 PM
  4. sound blaster live 1024
    By doggiebone in forum Redhat / Fedora
    Replies: 8
    Last Post: 05-22-2002, 11:20 PM
  5. soundblaster live with redhat
    By S_D_Willie in forum Linux - Software, Applications & Programming
    Replies: 8
    Last Post: 01-31-2002, 12:35 PM

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •