Page 1 of 4 123 ... LastLast
Results 1 to 10 of 31

Thread: Sound problems with FC3 - Now FC4 still working on it - help!

  1. #1

    Sound problems with FC3 - Now FC4 still working on it - help!

    Compaq Armada 1750, FC3
    Soundcard is ESS-1688, with configuration options rev=11 at 0x220, irq=5, dma=1
    I have no sound. I had sound once when I tried Ubuntu, but it was just stuck on an annoying loud drumbeat, so I muted it. The last time I tried, I could play an audio CD in the drive, so the speakers are fine. What I don't have is system sound of any kind.

    I have found all kinds of help for this problem, but either I don't understand the instructions, or the command is not recognized, or the file/folder doesn't exist, or or or.....

    Here's some things I've tried -

    [root@localhost betsey]# /sbin/lsmod
    Module Size Used by
    snd 54053 0
    soundcore 9889 1 snd
    ppp_deflate 5697 0
    zlib_deflate 20697 1 ppp_deflate
    ppp_async 11585 1
    crc_ccitt 2113 1 ppp_async
    ppp_generic 35669 6 ppp_deflate,ppp_async
    slhc 7105 1 ppp_generic
    nfs 221765 1
    lockd 63241 2 nfs
    parport_pc 24705 1
    lp 11565 0
    parport 41737 2 parport_pc,lp
    usblp 12993 0
    autofs4 24005 0
    i2c_dev 10433 0
    i2c_core 22081 1 i2c_dev
    sunrpc 160421 4 nfs,lockd
    ds 16965 4
    ipt_REJECT 6465 1
    ipt_state 1857 1
    ip_conntrack 40693 1 ipt_state
    iptable_filter 2753 1
    ip_tables 16193 3 ipt_REJECT,ipt_state,iptable_filter
    md5 4033 1
    ipv6 232577 10
    sr_mod 17381 0
    usb_storage 61321 4294967294
    scsi_mod 118417 2 sr_mod,usb_storage
    ehci_hcd 31557 0
    ohci_hcd 22225 0
    joydev 8705 0
    yenta_socket 18753 1
    pcmcia_core 59913 2 ds,yenta_socket
    uhci_hcd 31449 0
    floppy 58609 0
    dm_snapshot 17029 0
    dm_zero 2369 0
    dm_mirror 23341 2
    ext3 116809 2
    jbd 74969 1 ext3
    dm_mod 54741 6 dm_snapshot,dm_zero,dm_mirror

    [root@localhost betsey]# alsamixer

    alsamixer: function snd_ctl_open failed for default: No such device

    And tried another suggestion:
    [root@localhost betsey]# /sbin/modprobe sound
    FATAL: Module sound not found.
    [root@localhost betsey]# /sbin/modprobe snd
    [root@localhost betsey]# /sbin/modprobe sb io=0x220 irq=5 dma=1 dma16=5
    FATAL: Module sb not found.
    [root@localhost betsey]# /sbin/modprobe opl3 io=0x388
    FATAL: Module opl3 not found.

    I've found several options of stuff to put in /etc/modules.conf, which I don't have.

    Gnome soundcard detection (system-config-soundcard) either doesn't work at all or tells me "no soundcard detected" with "close" as the only option.

    Panel volume control: Sorry, no mixer elements and/or devices found

    Any ideas?

  2. #2

    Re:Sound problems with FC3

    this thread looked like it may help:

    also - get sndconfig


  3. #3

    Re:Sound problems with FC3

    I can't download with either the direct link you provided or the one provided on the linuxheadquarters link. Could very well be operator error. I'm trying to find a download I can get - got one but it's source so I'm looking for what I want -- let me know if you have any other suggestions.

  4. #4

    Re:Sound problems with FC3

    Found it, installed it, ran it. Got:

    You don't seem to be running a kernel with modular sound │
    │ enabled. (soundcore.o was not found in the module search path). │
    │ To use sndconfig, you must be running a kernel with modular │
    │ sound, such as the kernel shipped with Red Hat Linux or a 2.2 │
    │ or greater kernel.

    Anything else I could try?

  5. #5

    Re:Sound problems with FC3

    From the fedora forum thing . . .

    1) Make sure the CMOS settings are as follows. Under ESS 1869 Audio Controller Interface set the I/O range to 0x0230-0x0237. Under ESS 1869 Plug & Play Audiodrive use the following settings:
    IRQ 5
    I/O Range 0x0220-0x022F
    I/O Range 0x0388-0x038B
    I/O Range 0x0330-0x0331

    How do I check and or change CMOS settings?

  6. #6

    Re:Sound problems with FC3

    can you please run /sbin/modprobe -l | grep es1688 and /sbin/modprobe -l | grep soundcore and let us know what happens - i assume this is a straight fedora kernel...

  7. #7

    Re:Sound problems with FC3

    [root@localhost ~]# /sbin/modprobe -l| grep es1688

    [root@localhost ~]# /sbin/modprobe -l| grep soundcore

    As far as it being a straight fedora kernel . . . as far as I know I haven't done anything to it. Would I know if I had a crooked kernel? Could I acheive that accidentally? If so, it's a possibility.

  8. #8

    Re:Sound problems with FC3

    nah - i highly doubt you got it accidently . the kernel looks good (2.6.9-1.667)

    i am sure that it is not corrupt - i think this sndconfig tool is meant for 2.4.x kernels - my bad. lets see if we can get it work by loading the modules - in the file /etc/modprobe.conf try this:

    alias snd-card-0 snd-es1688
    options snd-card-0 index=0 
    options snd-emu10k1 index=0 
    remove  snd-es1688 {/usr/sbin/alsactl store 0 >/dev/null 2>&1 || : ; }; /sbin/modprobe -r --ignore-remove snd-es1688
    then run depmod -a and see if sound appears...

  9. #9

    Re:Sound problems with FC3

    We're getting there, I think. I ran alsamixer and aumix to adjust the volume levels, and they're okay now. I'm still getting "no devices or mixers" or some such from the volume control. And I don't get any sound. I think this has moved from a soundcard issue to a settings issue. Or a gnome problem. I don't know. I did get feedback when I upped the mic volume in the alsamixer, so I put that back down, but I took it as a good sign.

    Thanks, by the way!

  10. #10

    Re:Sound problems with FC3

    what does the sytem devices show? dumb - but needed question - it is enabled in the BIOS - right?

Similar Threads

  1. My Sound card working on Fedora 15
    By Anandh in forum Linux - Hardware, Networking & Security
    Replies: 1
    Last Post: 11-04-2011, 08:56 AM
  2. sound card problems
    By martina_alyce in forum Linux - Hardware, Networking & Security
    Replies: 1
    Last Post: 09-02-2002, 05:10 PM
  3. Sound Problems
    By BDV in forum Linux - Hardware, Networking & Security
    Replies: 12
    Last Post: 07-19-2002, 02:09 PM
  4. sound problems
    By klrmar in forum Linux - General Topics
    Replies: 7
    Last Post: 04-14-2002, 03:32 AM
  5. sound blaster live not working on redhat 7.2
    By dook in forum Linux - Hardware, Networking & Security
    Replies: 23
    Last Post: 02-19-2002, 12:52 AM


Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts