Results 1 to 8 of 8

Thread: Suse 9.3 on a Dell Latitude D810

  1. #1

    Suse 9.3 on a Dell Latitude D810

    Hello All

    Due to a recent company switch I have become the owner of a new Dell
    Latitude D810. I have installed Suse 9.3 Professional with no troubles,
    however I have one issue which became apparent after the install.

    For some reason I cannot access my cdrom. The error I receive is,
    Unable to mount the selected volume, mountnly root can mount
    /dev/cdrom on /media/cdrom.

    Now, I have tried mount the volume as root with the same error message.

    I have been googling for more information, and have asked around
    locally, but I seem to be the only one with this issue.

    Suse recognizes the drive correctly as a TSSTcorp CDRW/DVD TSL462C and
    the only thing different from my last laptop besides the name is that
    the Dell has SATA interfaces. The Disk Controller is a Dell 8280 1FBM
    (ICH6M) SATA Controller using module ata_pix.

    Any pointers would be great at this point.

    Thanks

    Rumrunner

  2. #2

    Re:Suse 9.3 on a Dell Latitude D810

    Try the following command, from a shell:

    Code:
    su -c "mount /dev/hdc /media/cdrom"
    or


    Code:
    su -c "mount /dev/sdc /media/cdrom"

  3. #3

    Re:Suse 9.3 on a Dell Latitude D810

    I have no idea what's wrong with it if root can't mount it, but a copy-paste from the terminal as you go through the process of mounting would definitely help debug.

  4. #4

    Re:Suse 9.3 on a Dell Latitude D810

    Both commands give me the same response;

    "mount: /dev/hdc is not a valid block device"

    "mount: /dev/sdc is not a valid block device"

    Ideas?

  5. #5

    Re:Suse 9.3 on a Dell Latitude D810

    Update

    Did the following;

    su -c "mount /dev/sr0 /media/cdrom"

    which mounted the cdrom with no problems.

    Not sure why this is not automatic, anyhow, more feedbeck would be great.

    Thanks
    Rumrunner

  6. #6

    Re:Suse 9.3 on a Dell Latitude D810

    My guess is that for some reason, SuSE messed up the device on your fstab.
    I'd say edit your /etc/fstab and look for the entry that points to your cd-rom, and maek sure the device listed is /dev/sr0.
    Also, if you add the option user to the fstab parameters for that device, you should be able to mount it as a regular user.

    Example:

    Code:
    /dev/sr0 /media/cdrom  iso9660 noauto,owner,ro,user 0 0

  7. #7

    Re:Suse 9.3 on a Dell Latitude D810

    Also, lots and lots and LOTS of programs expect to find your cdrom at /dev/cdrom.

    You can make these programs work by creating a symlink to your actual cd device.

    Code:
    su -c "ln -s /dev/sr0 /dev/cdrom"

  8. #8

    Re:Suse 9.3 on a Dell Latitude D810

    Will, as we say back on the ROCK!

    "Yes bys, we got 'ere now!"

    Looks like the modifications to the "Fstab" file and the symlink did the trick.

    Thanks for all your help folks!

    Rumrunner

Similar Threads

  1. What the Dell is going on here?
    By Fatal Error in forum General Chat
    Replies: 5
    Last Post: 06-30-2005, 12:20 PM
  2. Replies: 1
    Last Post: 07-14-2004, 02:56 AM
  3. Dell Inspiron
    By knight in forum Linux - Hardware, Networking & Security
    Replies: 5
    Last Post: 02-08-2004, 04:23 PM
  4. Pentium III, Dell Latitude, NOT SCSI?
    By DefGuy in forum Linux Distros
    Replies: 9
    Last Post: 10-12-2003, 04:08 PM
  5. Screw Dell
    By paradox in forum Linux - General Topics
    Replies: 2
    Last Post: 12-03-2001, 10:15 PM

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •