Page 1 of 2 12 LastLast
Results 1 to 10 of 20

Thread: Unable to change permissions on a mounted win2k_server folder

  1. #1

    Unable to change permissions on a mounted win2k_server folder

    I have a win2k_server box whose folder i have mounted thro samba onto a linux mandrake box. I want to be working on some spreadsheets on this mounted folder. I want to use the linux box as the client in the meantime. But i cannot change the write permissions to the folder and its contents. Apparently the mountis owned by root, but i still cannot change the permissions even from the root. I have enabled all rights on the win2k pc, and added the linux user but no success. Other windows users can fully access this folder

  2. #2

    Re:Unable to change permissions on a mounted win2k_server folder

    Hi,

    You need to mount the share as a regular user.

    Please check this thread for info.

  3. #3
    Senior Member
    Join Date
    May 2001
    Posts
    411

    Re:Unable to change permissions on a mounted win2k_server folder

    Open a terminal window.

    Become su.

    Put this in your /etc/fstab file:

    //Windows_Box/Windows_Share /client_mnt_point smbfs credentials=/root/.smbcredentials,dmask=0777,fmask=0777 0 0

    OR

    //Windows_Box/Windows_Share /client_mnt_point cifs credentials=/root/.smbcredentials,dir_mode=0777,file_mode=0777 0 0

    if your Linux kernel is compiled for CIFS. They say CIFS is better than SMBFS.

    Substitute the variables Windows_Box, Windows_Share, and client_mnt_point to suit your system. Create /root/.smbcredentials as a hidden file containing the username and password you use to log in to your Windows box, like so:

    username=your_Windows_login_ID
    password=your_Windows_login_password

    Assuming the Windows share isn't mounted (if it is, unmount it), issue the command:

    mount -a

    Now, whenever you fire up your Linux box and if your Windows box is running, your Windows share will be automagically mounted and you will have read and write permission to all the files stored there.

  4. #4

    Re:Unable to change permissions on a mounted win2k_server folder

    I been trying this with Debian to connect to my Thinkpad laptop using Win2K, but I keep getting an error about "invalid share name" or something like it.

    what name do I use for share?

    the machine name is Saptech-01 and my login name for it is "sappy".

    What go in this: //Saptech-01/share? If I want to share the D drive, would I put //Saptech-01/D$ ?

    Thnx.

  5. #5

    Re:Unable to change permissions on a mounted win2k_server folder

    D$ is an administrative share. You can try that, as long as sappy is an administrator of that machine. Otherwise, you need to create a share on the server machine, and assign it a share name.

  6. #6

    Re:Unable to change permissions on a mounted win2k_server folder

    Thnx Trickster for the reply. Even though I get this error, and I did try without the D$, when I use Nautilas to view Network, I can see the machine listed, but can't see any files or folders.

    I do have share files & printers checked on the Win2K machine.

    I'm doing all this on the linux machine as normal user.

    Any more ideas?

    Thnx.

  7. #7

    Re:Unable to change permissions on a mounted win2k_server folder

    You need to actually create a share on the Windows machine.
    Follow this link.

  8. #8

    Re:Unable to change permissions on a mounted win2k_server folder

    Never mind, I got it figured out. The Win machine IP doesn't end in 101 but 102. My Linux machine IP ends with 100, so what is 192.168.0.101?

    Anyway everything is working using LInux to connect to Win2K, next to get Win machine to connect to Linux.

    Thanks again.



    I have it shared and I switched from using the D$ to a regular folder on the windows machine.

    Something is not setup right even though I can see the Win machine, but using the command line I get errors.

    saptech@ghostdawg80:~$ smbmount //Saptech-01/Misc /mnt/saptech-01
    Error connecting to 192.168.0.101 (No route to host)
    6481: Connection to Saptech-01 failed
    SMB connection failed
    saptech@ghostdawg80:~$

    When I ping it I get this:

    saptech@ghostdawg80:~$ ping Saptech-01
    PING Saptech-01 (192.168.0.101) 56(84) bytes of data.
    From 192.168.0.100 icmp_seq=2 Destination Host Unreachable
    From 192.168.0.100 icmp_seq=3 Destination Host Unreachable
    From 192.168.0.100 icmp_seq=4 Destination Host Unreachable

    Even using the IP numbers I get same error.

    Thnx.


  9. #9

    Re:Unable to change permissions on a mounted win2k_server folder

    Are the machines connected directly, or through a switch? Do they have the correct getway?

  10. #10

    Re:Unable to change permissions on a mounted win2k_server folder

    They are connected through a wireless router. The Win machine have a wireless nic and the Linux has the router with cable net.

Similar Threads

  1. Setting permissions for folder and file access in Linux
    By honey bee in forum Linux - General Topics
    Replies: 1
    Last Post: 06-08-2007, 10:09 AM
  2. Sound system problems, need help with change permissions (fixed, thanks)
    By AljoshaNL in forum Linux - Hardware, Networking & Security
    Replies: 3
    Last Post: 08-21-2005, 02:24 PM
  3. Unable to change resolution
    By stodgel in forum Linux - Software, Applications & Programming
    Replies: 1
    Last Post: 06-13-2003, 02:28 AM
  4. Exporting several mounted fs over NFS...
    By sancho in forum Linux - Hardware, Networking & Security
    Replies: 1
    Last Post: 01-12-2003, 10:41 PM
  5. change permissions to 1777
    By Blaqb0x in forum Linux - Software, Applications & Programming
    Replies: 2
    Last Post: 06-02-2002, 04:06 PM

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •