Results 1 to 4 of 4

Thread: I can't connect to internet

  1. #1

    I can't connect to internet

    I am having the same "Could not look up internet address for . . . This will prevent Gnome from operating . . ." error that has been reported by others.

    I've read the thread "New to linux, cannot connect to internet" initiated by roy, and have tried several of the suggestions there. If I open a browser, and then try
    /sbin/dhclient eth0
    the browser will work but I can't start any other program and must reboot.

    Any advice (suitable for a newbie) would be appreciated.

    My machine's name is paul-cellar. It connects to a Trendnet TE100-S5P switch and thence to a Speedstream 5200 DSL router. There is no network "domain" or "domain controller. My /etc/hosts file has
    127.0.0.1 localhost.localdomain localhost

    Running chkconfig --list| less shows no entries for either dhclient nor dhcp service.

    Running chkconfig --list | grepdh gives nothing.


  2. #2

    Re:I can't connect to internet

    First, to get rid of the popup in Gnome, edit /etc/hosts and add your machine name to the end of that row you gave. Ie, you said your machine name is paul-cellar.

    Code:
    127.0.0.1  localhost.localdomain  localhost
    becomes

    Code:
    127.0.0.1  localhost.localdomain  localhost paul-cellar
    Now what do you mean when you say you can't start any other program? Have you tried launching one from a terminal? Is it EVERY program, or just some? If it's just some, are they programs that use the network? Try this: open up a terminal and issue a "/sbin/dhclient eth0", and then type "gedit" in the terminal. See if an editor pops up. If not, do you get an error message?

  3. #3

    Re:I can't connect to internet

    Thanks, Tyr_7BE .

    Adding the computer name to the end of the hosts entry helped. The Gnome popup disappeared.

    I tried opening the browser, an OpenOffice program, and a few others. Sometimes nothing happened and sometimes a box opened at the bottom of the screen saying "Starting XXX" and then disappeared.

    After adding the computername to the hosts file as you suggested, I changed the network settings to DHCP-assigned IP addresses and rebooted, Boot took a very long time but when it finished I was able to connect to the internet and run programs.

    Thanks!

  4. #4

    Re:I can't connect to internet

    Glad it worked out for you!

Similar Threads

  1. Connect to internet
    By arennuit in forum Linux - Hardware, Networking & Security
    Replies: 1
    Last Post: 08-20-2011, 05:24 PM
  2. Connect to local network fine, connect to internet - no go
    By thundersmurf in forum Linux - Hardware, Networking & Security
    Replies: 5
    Last Post: 03-31-2005, 07:27 AM
  3. Connect to internet with Win 95 or 98
    By regix in forum Windows - General Topics
    Replies: 0
    Last Post: 01-01-2005, 02:13 AM
  4. How do I connect to the internet
    By cwatkiuk in forum Linux - Hardware, Networking & Security
    Replies: 1
    Last Post: 07-21-2003, 03:57 AM
  5. connect to internet through a lan
    By benny666 in forum Linux - Hardware, Networking & Security
    Replies: 1
    Last Post: 03-05-2002, 12:14 AM

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •