Results 1 to 9 of 9

Thread: can't get eth0 up on Fedora Core 3

  1. #1

    can't get eth0 up on Fedora Core 3

    Hi all,

    I haven't been around in a while, but I'm having an issue that is really bothering me. It's likely that I've lost my sanity and just forgot something stupid, but anyway I figured I'd come here for a sanity check.

    I have a Dell Dimension desktop I need to install Linux on, so I had the fedora core 3 cd's lying around, and so I used them.

    Bootup looks ok except that the Broadcom 4401 ethernet (wired) card refuses to get an IP via DHCP. Messages in /var/log/messages say things like "dhclient: bogus udp packet length". I have checked the logs on the dhcp server, and all is well. The DISCOVER gets there, and the server promptly sends out the OFFER in reply. Note: this server is fine -- it works for hundreds of other clients.

    I figured something was goofy with the dhclient or something, so I thought I'd go ahead and just give it a static IP so I can get out to a yum repository and do an update. No go. I assigned the IP, did the ol' "route add default gw...", checked /etc/resolv.conf and /etc/hosts, all kinds of stuff, and I still can't even ping my gateway.

    mii-tool says the link is perfect. ifconfig says all is well. The messages file doesn't give any indications of trouble when I statically configure stuff. I turned off SELinux and IPtables, just in case. I also disabled ipv6, which ifconfig confirms by *not* showing any sign of ipv6, which is nice. ;-)

    The card uses the b44 driver, which works on the same hardware under fedora core 1, and I've seen reports of it working under FC3. I'm gonna try a different node (I have a few), but in the meantime, if anyone else has had this issue, lemme know. Google turns up almost nothing.

    brian.

  2. #2

    Re:can't get eth0 up on Fedora Core 3

    As root, can you try,

    Code:
    `dhcpcd eth0`
    ?

    Hopefully that works. Also, if that doesn't work, make sure the b44 module is loaded.. You can check that by doing so:

    Code:
    `lsmod`
    as root. And check that.

    If b44 is not listed, then do (as root):

    Code:
    modprobe b44 .
    Good Luck..

  3. #3

    Re:can't get eth0 up on Fedora Core 3

    Bogus UDP packet length? That sounds seriously fucked up. I think that in order to misinterpret the length of a packet there would have to be a problem with the driver itself.

    Is this your first install of FC3? Maybe try formatting and reinstalling cause it could be a corrupted driver.

  4. #4

    Re:can't get eth0 up on Fedora Core 3

    Thanks, Tyr, those are my exact sentiments and suspicions.

    Over the time that's passed, I went ahead and installed FC3 on my laptop, and hooked it up to the same network. No problems there, which eliminates dhcpcd as the source of the problem. The only thing really left (in software, anyway) is the driver, which I imagine is probably hosed. I'll try to get it installed on another node in this lab -- all identical hardware -- and see if troubleshooting on that leads me to the same ol' b44 driver.

    Oddly, a bunch of other identical nodes are running FC1 with the b44 driver without issue ???

    Whatever. :

    /nj

  5. #5

    Re:can't get eth0 up on Fedora Core 3

    Just wanted to get back and say it looks like this was either a cable or other hardware issue. I installed FC3 successfully on another node of identical hardware configuration. I even made sure the same modules were loaded after boot. Exactly the same -- that node is dead :-\

  6. #6

    Re:can't get eth0 up on Fedora Core 3

    thanks for letting us know. It looked pretty messed up...

  7. #7

    Re:can't get eth0 up on Fedora Core 3

    I have this same problem on an ASUS motherboard with an onboard broadcomm (broadcom)? ethernet adapter. The unit worked fine in Fedora core 1 yesterday, but not on Core 3 installed over core 1 today.

    In Core 1, the onboard broadcomm chip was recognized as eth0 by default, but in Core 3 it seems to be confused. During the anaconda install it recognized eth0 as broadcom and my other ethernet pci card as eth1, but in the network config tool in Core 3, this is reversed.

    I switched the broadcom unit to be recognized as eth0 using the GUI config tool, highlighted it and clicked the "activate" radio button. My hardware firewall then recognized a connection had been made to my computer (the computer link light turns green), but I still could not get out.

    The hardware works fine here on win98 and worked on Core 1 prior to installing Core 3 over it.

    Any ideas? Could SELinux be a culprit? Any known broadcom driver problems?

    Thanks in advance.

  8. #8

    Re:can't get eth0 up on Fedora Core 3

    After booting up today in Core 3, eth0 comes up and works fine with my onboard Broadcom ethernet

    My guess:
    The PCI card initialized before the onboard ethernet the first time, and the change I made to the eth0/eth1 assignment (changed the onboard broadcom to eth0) did not take effect until reboot.

    Is this possible?

  9. #9

    Re:can't get eth0 up on Fedora Core 3

    Well you could have always shutdown the network and the started it back up again. Otherwise yes you would be correct

Similar Threads

  1. Fedora Core 10
    By kupertini in forum Redhat / Fedora
    Replies: 1
    Last Post: 10-16-2008, 01:30 AM
  2. Fedora Core 5-T1 DVD
    By GhostDawg in forum Linux - General Topics
    Replies: 2
    Last Post: 11-29-2005, 02:31 PM
  3. Fedora Core 4 Available
    By trickster in forum General Chat
    Replies: 14
    Last Post: 09-27-2005, 05:24 AM
  4. Fedora Core 2
    By in forum Linux - General Topics
    Replies: 49
    Last Post: 06-12-2004, 11:57 AM
  5. Fedora Core 2 is here
    By babbing in forum Redhat / Fedora
    Replies: 3
    Last Post: 05-31-2004, 06:05 AM

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •