Warning: Function ereg() is deprecated in ..../includes/class_postbit.php(345) : eval()'d code on line 4

Warning: Function split() is deprecated in ..../includes/class_postbit.php(345) : eval()'d code on line 19

Warning: Function ereg() is deprecated in ..../includes/class_postbit.php(345) : eval()'d code on line 4

Warning: Function split() is deprecated in ..../includes/class_postbit.php(345) : eval()'d code on line 19

Warning: Function ereg() is deprecated in ..../includes/class_postbit.php(345) : eval()'d code on line 4

Warning: Function split() is deprecated in ..../includes/class_postbit.php(345) : eval()'d code on line 19

Warning: Function ereg() is deprecated in ..../includes/class_postbit.php(345) : eval()'d code on line 4

Warning: Function split() is deprecated in ..../includes/class_postbit.php(345) : eval()'d code on line 19
trouble installing a package..........
Results 1 to 4 of 4

Thread: trouble installing a package..........

Hybrid View

  1. #1
    Mentor
    Join Date
    May 2001
    Location
    New Jersey
    Posts
    1,473

    trouble installing a package..........

    hey guys,
    i'm getting an errorwhen trying to install evolution on slackware 10.

    this is the error;
    checking for libgtkhtml-3.1... Package libgtkhtml-3.1 was not found in the pkg-config search path.
    Perhaps you should add the directory containing `libgtkhtml-3.1.pc'
    to the PKG_CONFIG_PATH environment variable
    No package 'libgtkhtml-3.1' found

    configure: error: Library requirements (libgtkhtml-3.1) not met; consider adjusting the PKG_CONFIG_PATH environment variable if your libraries are in a nonstandard prefix so pkg-config can find them.


    i located the libgtkhtml file and it's in /usr/local/lib/pkgconfig/libgtkhtml-3.1 and /usr/local/include/

    i tried setting the PKG_CONFIG_PATH by typing on the command line PKG_CONFIG_PATH=/usr/local/lib/pkgconfig/ and
    PKG_CONFIG_PATH=/usr/local/include

    am i leaving something out in setting the correct path?
    Can someone help me correct this error?

  2. #2

    Re:trouble installing a package..........

    Only thing you need is:

    export PKG_CONFIG_PATH=/usr/local/lib/pkgconfig

    then run ./configure again, and it should work.

  3. #3
    Mentor
    Join Date
    May 2001
    Location
    New Jersey
    Posts
    1,473

    Re:trouble installing a package..........

    it's not going to change it to that, it'll just add that to the path, right?

  4. #4

    Re:trouble installing a package..........

    Actually, it'll change to that, if you want to add it, you can do this:

    export PKG_CONFIG_PATH=/usr/local/lib/pkgconfig:/usr/lib/pkgconfig

    and that'll add to the path.

    Hope that helps!

    Sincerely,
    Shebang

Similar Threads

  1. having trouble installing OpenBSD
    By open_bsd in forum BSD
    Replies: 1
    Last Post: 09-18-2007, 11:36 AM
  2. Trouble installing rpm's
    By Gaiadin in forum Linux - General Topics
    Replies: 4
    Last Post: 03-02-2005, 04:40 PM
  3. trouble installing the 2.6 kernel
    By Mantis166 in forum Linux - General Topics
    Replies: 9
    Last Post: 07-27-2003, 03:51 AM
  4. trouble installing on xp
    By rod in forum Linux - Software, Applications & Programming
    Replies: 6
    Last Post: 07-08-2002, 03:45 AM
  5. installing a .bz2 package?
    By chadm1967 in forum Linux - Software, Applications & Programming
    Replies: 4
    Last Post: 12-20-2001, 08:07 AM

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •