Results 1 to 9 of 9

Thread: Cannot start X

  1. #1

    Cannot start X

    Hello:
    I installed Fedora Core3 with default values/parameters and with an IBM monitor. I no longer have access to that monitor and have switched to a Seanix KM-411 model monitor. With the IBM monitor everything was running fine. Now, I can work in console mode but not in GUI. How do I configure X without having to edit config files? I mean, is there a console utility that will allow me to configure X?

    :'(

  2. #2

    Re:Cannot start X

    Fedora Core 3 uses xorg-x11. So the command would be:

    xorgconfig


  3. #3

    Re:Cannot start X

    If that doesn't work, can you provide some additional information? What happens when you try to start X? Does it give any error message, or does it just look strange? Take a look at /var/log/Xorg.0.log. Does it contain any errors (search for lines that begin with "(EE)"...that indicates an error)? If so, what are they?

  4. #4

    Re:Cannot start X

    hello shebang:
    I tried xorgconfig and got:: -bash: xorgconfig: command not found.

    Actually, I had already tried xorgconfig, xfree86config, xconfigurator, linuxconf...

    I know that commands are also case sensitive, so how do you spell xorgconfig?

    To answer Tyr_7BE, "no screens found" is the message I get. And there are no error lines in /var/log/Xorg.0.log

    Since I have set the system to start with X automatically, it tries to load X and comes back with a window saying it has problems loading X, and if it should try loading the config utility. When I say, Yes, it tries to load Vesa mode, and then the screen goes all kaleidscopy! At this point I have to hard boot the system. And when I get to a console screen and login as root and then run "startx", the message is "no screens found". The error is:X10: fatal IO error 104 (connection reset by peer) on X Server:"0:0"

    Thanks to both of you for your responses so far.

  5. #5

    Re:Cannot start X

    you need to run the command as root. Try the following:

    Code:
    su
    then

    Code:
    /sbin/xorgconfig

  6. #6

    Re:Cannot start X

    Hello Trickster:
    I get the message: no such file or directory

  7. #7
    Guest

    Re:Cannot start X

    Try `whereis xorgcfg' should be something like /usr/X11R6/bin/xorgcfg. If all goes well run `xorgcfg -textmode' and edit your xorg.conf from there.

    Good luck.

  8. #8

    Re:Cannot start X

    Hello Cassius:
    I think something must have gone wrong...I don't get any response for the "whereis" command. Meaning it seems as though there is no such file...
    Can I re-install X from the original Core 3 CD? Could you please give me some instructions?

  9. #9
    Guest

    Re:Cannot start X

    Sounds like X isn't fully installed, or at least the configuration tools weren't installed. I would love to help you but unfortunately I haven't ran fedora in a long time, you can probably use up2date or some other installation tool to install X though.

    Any fedora users around, that are willing to lend your expertise here?

Similar Threads

  1. Can't start X
    By GNEEOT in forum Linux - General Topics
    Replies: 2
    Last Post: 07-02-2006, 10:54 AM
  2. Box won't start up ...
    By Compunuts in forum Windows - General Topics
    Replies: 6
    Last Post: 10-25-2004, 03:51 AM
  3. How do I start a tar.gz
    By FLY_FISHER in forum Linux - General Topics
    Replies: 9
    Last Post: 06-06-2003, 02:33 AM
  4. Cannot start x
    By teva in forum Linux - Hardware, Networking & Security
    Replies: 9
    Last Post: 05-21-2002, 05:40 AM
  5. KDE does not start
    By irox in forum Linux - Software, Applications & Programming
    Replies: 6
    Last Post: 12-30-2001, 06:51 PM

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •