Results 1 to 10 of 10

Thread: SuSe 9.1 root boots directly to Yast

  1. #1

    SuSe 9.1 root boots directly to Yast

    I've been trying to get my modem to work with help from the networking board. Somehow I've managed to do something -- when I log on as root I go directly to yast (do not pass go, do not collect $200 :P). My user login takes me to Kde, but root only goes to yast, full screen. yast appears to be functioning fine here, but my only option to get out of it is to select "close", which logs me out. I know this is a ridiculous thing to have happened, and I've done something I shouldn't have, and I've looked for help but apparently this is such a stupid thing that I may be the newest newbie ever before seen by the linux community and noone has managed to pull this trick. I hope there's a simple trick but at this point I have no idea where to even begin to look for the answer.

    As a note, I'm running 9.1 on a laptop I bought used with the distro already installed, so I have no CDs or other fancy gadgets. I'm thinking maybe I should just purchase a new, latest-greatest distro (thinking Mandrake) and start over. But I've had so much trouble so far that I'm afraid I won't be able to install it!

    Is there a board specifically for idiot frustrated newbies?

  2. #2

    Re:SuSe 9.1 root boots directly to Yast

    The board for frustrated newbies would be this one. The biggest thing to remember when learning Linux is patience. I know a lot of people who have given up after a few days of things not working like they're used's just a matter of learning the ropes. Just learn a few tips and tricks and you'll be able to set up a system in no time flat.

    Root booting directly to YaST doesn't surprise me. In Windows, logging in as the Administrator is allowed and usually what's done. Linux has a bit of a tighter security policy in that logging in as root from the initial login screen is supposed to be ONLY for system maintenance. Normal usage should be done under a user account. Whenever you need administrator access to files, you can use the "su" command in a terminal to become root user ("exit" will drop you back down to the user account you came from). Alternatively, if you have "sudo" installed, you can add your username and relevant parameters to /etc/sudoers, and then use sudo to mimick root user. Just use "sudo <commandname> <flags>".

    So if this gives you a no-permission error:
    vim /var/log/messages
    You can use this instead
    sudo vim /var/log/messages
    And that will run that command as root (btw, "Esc" followed by ":q" will exit vim if you try this and find you can't get out ).

    Anyway I run all my boxes with my username in the /etc/sudoers file with the NOPASSWD option so I never have to type in a password. Works pretty seamlessly, and I never have to log in as root. In fact, there are distributions out there that don't have a root account at all and rely completely on sudo in order to get root stuff done.

    So the point of this little foray into Linux philosophy has been to say that logging in as root should be used for system maintenance only (ie, when things break horribly) and is generally discouraged. I'm thinking that SUSE sends you to YaST by default since YaST is SUSE's system config tool. You should be logging in as a user and then performing administrative actions by either typing "su" in a terminal or setting up your /etc/sudoers file so you can use "sudo" instead.

  3. #3

    Re:SuSe 9.1 root boots directly to Yast

    Thanks for your help! It wasn't doing this before, but if it's not a problem I can live with it. Of course, in the meantime I've managed to trap myself in text mode. I've logged out as root and logged back in as a user, but when I try to run kde it tells me
    xset: unable to open display ""
    a couple of times
    ksplash: cannot connect to X server
    kdeinit: Aborting. $Display not set.
    Warning: connect() failed: :No such file or directory
    Error: Can't contact kdeinit!
    startkde: Running shutdown scripts. . .
    startkde: Done.

    I don't want to just turn the darn thing off (well, actutally I do : but also want to avoid terrible catastrophe.) and hope that when I power back up it fixes itself, because I doubt that will happen. Any suggestions?

  4. #4

    Re:SuSe 9.1 root boots directly to Yast

    Okay. Managed to reboot safely (I can only guess) and have my kde back. Again, thanks for your help.

  5. #5

    Re:SuSe 9.1 root boots directly to Yast

    That's another thing to keep in mind...expect to break your first few installs of Linux....that's just what happens when you tinker

    I'd recommend grabbing a backup ISO so you can reinstall when you hose your system (note, I said when, not if ;D ). A particularly nice choice that's been making the rounds lately is Ubuntu (available at ). The entire install fits on one CD, as opposed to other distros that require 4 - 6 cds to install. If you grab Ubuntu and burn a copy, you'll have a backup in case things go wrong with your SUSE.

  6. #6
    Good Guru
    Compunuts's Avatar
    Join Date
    May 2001

    Re:SuSe 9.1 root boots directly to Yast

    Well, for the record, every distro needs only ONE disk of all you want is basic Linux for you to use. The rest are all programs.

    What kind of laptop are you trying to install on? What chipset you have? I'm running SuSE Linux Enterprise Server 9.0 on Toshiba Tecra 8100 Machine. Let me know if you need specific help.

  7. #7

    Re:SuSe 9.1 root boots directly to Yast


    I'm in much less distress now.

    I have a Compaq Armada 1700.

    I loaded Ubuntu, but had problems with my display resolution. Looked around and found several bits of info on the 1700 & 1750, but just couldn't figure out how to escape from Gnome in order to change the monitor settings.

    So, loaded a version of Fedora Core 1 that came with this snappy little book which finally arrived from -- Linus for Non-Geeks. Good little book. It took me a couple of tries to get it loaded (the graphical installer just didn't want to start) but when I tried in text mode it loaded right on in.

    I'm pretty happy with Fedora Core so far. I have loaded my very own OS, manually changed the automatically detected display, configured the soundcard AND got the winmodem to work! I'm printing and online in Linux! This may not seem like a grand accomplishment to y'all but I'm pretty darn proud of myself!

    Thanks for the forum for all your help - I gained enough knowledge and confidence now to really foul things up so I'm sure I'll be back.

  8. #8

    Re:SuSe 9.1 root boots directly to Yast

    Glad to hear that.! I am running Fedora Core 3 now. It is pretty sweet.

  9. #9

    Re:SuSe 9.1 root boots directly to Yast

    Indeed, good job! I'm sorry to hear that Ubuntu didn't work out for you. When it does work it's a gorgeous distribution.

    FC1 was great but it's kind of ageing. I almost hestitate to say it now that you're seeing some success, but you should try upgrading to FC3 and see how that goes You could always fall back on FC1 if things go bad. If FC1 is up and running you should be able to burn cds (download the FC3 isos from and just right-click on them and hit "write to cd...&quot.

    FC3 has some really nice goodies like Gnome 2.8 as a desktop environment (I believe FC1 has 2.4...there are some drastic improvements in 2.8) as well as the very modern X.Org windowing system. It also uses kernel 2.6, which should provide some really significant speed improvements over the kernel used in FC1.

  10. #10

    Re:SuSe 9.1 root boots directly to Yast

    Hey Damsel,

    How did you configure the display and soundcard in FC1? I too have a Compaq Armada 1700 and can't get the resolution above 600x800 and haven't been successful getting the system to recognize the soundcard with FC3.

    I found a post on another site that mentioned running sndconfig, Unfortunately, sndconfig is not part of the standard install package.

    I would take any assistance I can get here.

    Thanks much

Similar Threads

  1. Suse 10.0 YAST Issue with Sound Level
    By vwgtiturbo in forum Suse
    Replies: 2
    Last Post: 02-16-2006, 07:45 AM
  2. Suse 8.2 and Yast
    By BadDudes in forum Linux - General Topics
    Replies: 14
    Last Post: 01-30-2006, 07:54 AM
  3. Suse....rpms....yast..updates??
    By Wildheart in forum Linux - General Topics
    Replies: 3
    Last Post: 08-15-2005, 01:10 PM
  4. SuSE 8.0: YaST Online Update
    By VampyreUK in forum Linux - General Topics
    Replies: 0
    Last Post: 05-31-2002, 08:20 AM
  5. SuSE 8.0: YaST Online Update
    By VampyreUK in forum Linux - General Topics
    Replies: 1
    Last Post: 05-31-2002, 06:39 AM


Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts