Warning: Function ereg() is deprecated in ..../includes/class_postbit.php(345) : eval()'d code on line 4

Warning: Function split() is deprecated in ..../includes/class_postbit.php(345) : eval()'d code on line 19

Warning: Function ereg() is deprecated in ..../includes/class_postbit.php(345) : eval()'d code on line 4

Warning: Function split() is deprecated in ..../includes/class_postbit.php(345) : eval()'d code on line 19

Warning: Function ereg() is deprecated in ..../includes/class_postbit.php(345) : eval()'d code on line 4

Warning: Function split() is deprecated in ..../includes/class_postbit.php(345) : eval()'d code on line 19

Warning: Function ereg() is deprecated in ..../includes/class_postbit.php(345) : eval()'d code on line 4

Warning: Function split() is deprecated in ..../includes/class_postbit.php(345) : eval()'d code on line 19
Getting Mplayer to work
Results 1 to 4 of 4

Thread: Getting Mplayer to work

  1. #1

    Getting Mplayer to work

    Hey,
    I am trying to get MPLAYER to work. I compiled, etc. It compiled fine. I have all the fonts, codecs, skins (default) installed. But It keeps spitting this out:

    Code:
    # mplayer dvd://1 -dvd-device /dev/dvd
    MPlayer 1.0pre5-3.3.4 (C) 2000-2004 MPlayer Team
    
    CPU: Intel Pentium 4/Xeon Willamette 2181 MHz (Family: 8, Stepping: 2)
    Detected cache-line size is 64 bytes
    CPUflags:  MMX: 1 MMX2: 1 3DNow: 0 3DNow2: 0 SSE: 1 SSE2: 1
    Compiled for x86 CPU with extensions: MMX MMX2 SSE SSE2
    
    Reading config file /usr/etc/mplayer/mplayer.conf: No such file or directory
    Reading config file /home/ind171/.mplayer/config
    Reading /home/ind171/.mplayer/codecs.conf: Can't open '/home/ind171/.mplayer/codecs.conf': No such file or directory
    Reading /usr/etc/mplayer/codecs.conf: Can't open '/usr/etc/mplayer/codecs.conf': No such file or directory
    Using built-in default codecs.conf.
    /home/ind171/.mplayer/font/font.desc is empty or a directory, ignoring
    Font /usr/share/mplayer/font/font.desc loaded successfully! (206 chars)
    Linux RTC init error in ioctl (rtc_irqp_set 1024): Permission denied
    Try adding "echo 1024 > /proc/sys/dev/rtc/max-user-freq" to your system startup scripts.
    Using usleep() timing
    Input config file /home/ind171/.mplayer/input.conf parsed: 0 binds
    
    Playing dvd://1.
    libdvdread: Could not open device with libdvdcss.
    libdvdread: Can't open /dev/dvd for reading
    Couldn't open DVD device: /dev/dvd
    
    
    Exiting... (End of file)
    I tried google'ing it and found some with similar problems and found some solutions but none seem to be working. It's a regular DVD/CD Combo. Mounting CDs and Playing Audio CDs works (with gnome-cd).

    Any Ideas ?

  2. #2

    Re:Getting Mplayer to work

    Well, actually I got it to work (as root) but I don't know what caused the problem. The only thing I did was add an empty /usr/etc/mplayer/mplayer.conf ...

    I still need to get it working as my user though.

  3. #3
    Mentor
    Join Date
    Jun 2001
    Posts
    1,672

    Re:Getting Mplayer to work

    Try this (as root):

    chmod a+rw /dev/dvd


  4. #4

    Re:Getting Mplayer to work

    Or try pointing it to /dev/cdrom

Similar Threads

  1. Mplayer URL History?
    By zerg445 in forum Linux - Software, Applications & Programming
    Replies: 5
    Last Post: 08-08-2006, 01:41 AM
  2. MPlayer & mp3
    By gabbath in forum Linux - Software, Applications & Programming
    Replies: 1
    Last Post: 05-08-2005, 05:52 AM
  3. MPlayer
    By stodgel in forum Linux - Software, Applications & Programming
    Replies: 3
    Last Post: 06-30-2003, 11:43 PM
  4. mplayer -gui = no go
    By S_D_Willie in forum Linux - Software, Applications & Programming
    Replies: 8
    Last Post: 09-21-2002, 04:33 AM
  5. Mplayer
    By Bogler in forum Linux - General Topics
    Replies: 5
    Last Post: 06-20-2002, 02:39 AM

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •